Contribute
Register

[Guide] Fanless mini Mojave: i5-8600 | Gigabyte Z370N WiFi | Intel HD630

Joined
Jun 4, 2016
Messages
134
Motherboard
Gigabyte Z370N-WiFi-F10-Clover
CPU
i5-8600
Graphics
HD 630
Mac
MacBook, MacBook Pro
Mobile Phone
Android
I am using a single monitor setup (Philips 276E)
So I had a look at your Essentials and I can't see anything wrong. Your config is the same as mine. You have some more kexts in LE but they don't seem relevant to the problem AFAIK.

My monitor works fine, but after following B1's link ...

I can see that the current framebuffer properties they quote for our m/b are different to what I've been using. I've replaced the ones in my config.plist and there's no difference to my monitor behaviour. It might help you.

Attached is my current config.plist (remember to select model 18.1 from the pick list in Clover Configurator).

If you try it, like to know how it goes. In mine, I expected the Connectors section in Hackintool to look different after I applied the changes but it looks the same.
 

Attachments

Last edited:
Joined
Jun 4, 2016
Messages
134
Motherboard
Gigabyte Z370N-WiFi-F10-Clover
CPU
i5-8600
Graphics
HD 630
Mac
MacBook, MacBook Pro
Mobile Phone
Android
Did you try to match my settings? High chance that it will help.
Thanks for this. Seems you have everything turned off, so only your display sleeps ... and the machine stays awake?

I have had a more aggressive sleep setup and it has worked right up to F12. I like the system sleeping and the LED going off. It takes a couple of seconds to wake, but it's fine (well it was fine).

I could try your values but that would lose the sleeping. It would also not explain what has changed from F10 to F12. Everything was good in F10. For now, I've gone back there while I think about it :think:
 
Joined
Jul 1, 2018
Messages
396
Motherboard
GIGABYTE Z370N
CPU
i7-8700
Graphics
RX 560
Mac
MacBook
Mobile Phone
iOS
Thanks for this. Seems you have everything turned off, so only your display sleeps ... and the machine stays awake?

I have had a more aggressive sleep setup and it has worked right up to F12. I like the system sleeping and the LED going off. It takes a couple of seconds to wake, but it's fine (well it was fine).

I could try your values but that would lose the sleeping. It would also not explain what has changed from F10 to F12. Everything was good in F10. For now, I've gone back there while I think about it :think:
My sleep works. And it works only with this settings :)

Auto sleep, manual sleep, wakeup with keyboard/mouse, unlock with Apple watch. Everything works.
 
Last edited:
Joined
Nov 8, 2011
Messages
85
Motherboard
ASRock X99 Extreme4/3.1
CPU
E5-1620-V3
Graphics
Gigabyte GTX 960 OC 2GB
Joined
Sep 21, 2013
Messages
4
Motherboard
Gigabyte Z370N WIFI
CPU
i5-8600T
Graphics
UHD 630
Mac
Mac mini
If it is of any help, I am running dual 4k@60Hz with one Monitor connected to the DP and one to the HDMI 2.0 port.

In my opinion and following all steps of the whatevergreen-intel-patching guide (https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.IntelHD.en.md) I do think that only framebuffer-con0 must be patched in order to have all ports working. framebuffer-con1 is the HDMI 2.0 port which uses the MegaChips MCDP2800 and therefore is a "DP device" thus fb-patching the port to "HDMI" is actually wrong.

To further support this assumption, the real MacMini 8,1 also uses a MegaChips converter along with the unpatched AAPL,ig-platform-id <07009b3e>.

If you are going to use my config pls note that using a tool like "ResXtreme" might be required once to set both monitors to 4k@60Hz@10/8Bit.

I did include my config plist in order for others to have a look at it but wont offer any support.

Kexts used are:

AppleALC.kext (Audio)
IntelMausiEthernet.kext (LAN 1)
Lilu.kext
SmallTree-Intel-211-AT-PCIe-GBE.kext (LAN 2)
USBInjectAll.kext (USB)
VirtualSMC.kext (SMC)
WhateverGreen.kext (Graphics)
XHCI-unsupported.kext (USB)
 

Attachments

Joined
Jun 4, 2016
Messages
134
Motherboard
Gigabyte Z370N-WiFi-F10-Clover
CPU
i5-8600
Graphics
HD 630
Mac
MacBook, MacBook Pro
Mobile Phone
Android
Hello world.
Sorry I have moved away from Hackintosh, towards the enemy.
Thanks so much to @b166ar and @inarush and many others for their outstanding support and encouragement.
I greatly appreciated it. This is a wonderful community. I'm sure I'll get sick of the opposition and come running back with my tail between my legs.
All best!
 
Joined
Jul 1, 2018
Messages
396
Motherboard
GIGABYTE Z370N
CPU
i7-8700
Graphics
RX 560
Mac
MacBook
Mobile Phone
iOS
Hello world.
Sorry I have moved away from Hackintosh, towards the enemy.
Thanks so much to @b166ar and @inarush and many others for their outstanding support and encouragement.
I greatly appreciated it. This is a wonderful community. I'm sure I'll get sick of the opposition and come running back with my tail between my legs.
All best!
Did you buy iMac Pro?:)
 
Top