Contribute
Register

[Guide] Fanless mini Mojave: i5-8600 | Gigabyte Z370N WiFi | Intel HD630

Joined
May 23, 2011
Messages
633
Motherboard
GA-Z370N-WiFi
CPU
i7-8700
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
I just don’t even understand how the SMBIOS is impacting this (if it is).

The MT2 full suite of options are available, I think, to literally any Mac of any vintage in the last 8 years that connects to it. So frustrating.
 
Joined
May 23, 2011
Messages
633
Motherboard
GA-Z370N-WiFi
CPU
i7-8700
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Joined
Jun 4, 2016
Messages
135
Motherboard
Gigabyte Z370N-WiFi-F10-Clover
CPU
i5-8600
Graphics
HD 630
Mac
MacBook, MacBook Pro
Mobile Phone
Android
Did the bt reset and factory reset of Apple devices - no luck.
Thanks for updating with the result. Shame.

Myself, I'd try different SMBIOSs. The reason I think that matters is the message about "some mac models" not having the same options. It's this value MacOS checks. So find a HS build on the same m/b and use their SMBIOS number. I think it'll be that simple (famous last words!).

Alternatively to prove the BT and Magic Trackpad is working, if you have cloned backups, I'd try Mojave under 18,1 and see if MT works like mine. This doesn't help HS, but it would confirm HS is part of the problem.
 
Joined
May 23, 2011
Messages
633
Motherboard
GA-Z370N-WiFi
CPU
i7-8700
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Ugh - any ideas on now what?

Are there any core files that I could try copying over from Mojave to HS that deal with this?
Sort of a wing and prayer here..

This sucks.

(moving to Mojave not an option as I'm using and very happy with the 1080ti setup for both Mac/Win sides of this machine)
 
Joined
Jun 4, 2016
Messages
135
Motherboard
Gigabyte Z370N-WiFi-F10-Clover
CPU
i5-8600
Graphics
HD 630
Mac
MacBook, MacBook Pro
Mobile Phone
Android
any ideas on now what?
First, don't copy files around. Its a config thing, I reckon.

Second, make 100% certain the MT options you want are available on HS models. Just in case. (Also I assume you have the most recent HS version? I'm sure you do but anyway.)

Then look for a Z370N HS build. I think there are others on here also on other Hack sites. Check their SMBIOS number. Ask if their MT works the same.

Might be good to post a general help here saying "Magic Trackpad 2 on HS problem". You might get advice from other m/b users that could help.

(Understand about Mojave. It was a useful exercise anyway.)
 
Joined
May 23, 2011
Messages
633
Motherboard
GA-Z370N-WiFi
CPU
i7-8700
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Second, make 100% certain the MT options you want are available on HS models. Just in case.
No question about that.
All the MT2 features predate HS anyhow, by a couple years.

Will poke around for HS builds - Hoping some are still actually on HS and haven't all moved to Mojave.
I noticed a ton of the z370n builds are either just using Intel UHD 630 or an AMD dGPU - all to be up on Mojave.

Honestly I'd have a Vega card if the performance of the AMD cards wasn't so relatively awful in X-Plane 11, which is what I care about on the Win10 install. That's supposed to get better by the end of the year as they are implementing Vulkan, but - until they do - who knows. Power draw/heat are another reason I'm not on an AMD card as this is an ITX build and the last thing I need in there is an AMD furnace.
 
Joined
May 23, 2011
Messages
633
Motherboard
GA-Z370N-WiFi
CPU
i7-8700
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
So a variety of threads have all but confirmed that it's simply a bug introduced by Apple into 10.13.6

Here too.. (I linked to a thread above about this but it was endlessly awaiting mod approval)


Totally brutal. Thanks Apple.

People in all these threads had everything working fine and all that changed was the point release update to 10.13.6, usually for good reasons like security and/or FCP X updates that needed it, etc.

I posted about the possibility of copying over key files relating to bluetooth from 10.13.5 perhaps. Those must be similar enough that it might be possible one would think - maybe not though - I'm not an expert for sure.
 
Last edited:
Joined
May 23, 2011
Messages
633
Motherboard
GA-Z370N-WiFi
CPU
i7-8700
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
So - Update!
By comparing plist files from Mojave located in /USER/Library/Preferences/..

These:

com.apple.AppleMultitouchTrackpad
com.apple.driver.AppleBluetoothMultitouch.trackpad

I managed to add/change a couple settings and I *am* getting silent clicking and lower click strength after editing with PlistEditorPro (I assume many Plist editors would work for this)!

!! yes!!

It didn't take right away but after doing some permissions/cache rebuilding for other reasons (FakeSMC updates), all of the sudden it *did* take upon a reboot!

This is wonderful!!!!

I'm not 100% sure what is doing what exactly, but some of it is intuitive and I'd love to hear thoughts from others.
The ones I focused on were Clicking=0, ActuationStrength=0

I'd like to know the range on ActuationStrength before testing more, but honestly right now I'm just happy to have silent clicking. That was most important to me.

 
Top