Contribute
Register

[Guide] Enabling ATI Radeon HD 5450

Joined
Feb 22, 2016
Messages
1
Motherboard
HP Elitebook 840G1 - Haswell
CPU
Intel(R) Core(TM) i5-4300U CPU @ 1.90Ghz
Graphics
Intel HD Graphics 4400
After spending significant time trying different options -

On my 'el capitan' system with an ATI 5450 1GB card with vga/dhmi and dvi connections, in order to get two screens (one to HDMI and one to DVI) to function at the same time I had to use Cedar video driver and not the Eulemur video driver. Enabling or disabling "fixdisplay" or "vbios" made no difference. I had used the fakeID 68e01002 with both FBnames, but with cedar both screens functioned.

With the emular driver only one screen would function at a time.
 
Joined
Jun 19, 2012
Messages
4
Motherboard
dh57h am2
CPU
i3 550
Graphics
Visiontek HD 5450
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hello, I know this thread is ancient history by now but if anyone cares to help me I've attached the files. I could not find a patch for my MB; Dh57dd am2. It is a Visiontek 5450 I got for 20 bucks, and I found the computer in the trash. So I figured why not make it a hackintosh.

I have no issue using kexts and not updating, as it will just be an office internet/pritiner mostly. And I only have legal access to my 10.11 installer anyway.
It's relatively fresh install, I've no problem starting over if need be.

thank you
 

Attachments

  • fresh dsdt ioreg config.zip
    404.3 KB · Views: 118
Joined
Oct 23, 2016
Messages
331
Motherboard
HP EliteBook 1030 G1 (Clover)
CPU
m7-6Y75
Graphics
HD515, 3200x1800
Any one successfully config PowerColor HD 5450?
 
Joined
Dec 16, 2018
Messages
23
Motherboard
P8H61-M LE R2.0
CPU
2,6 GHz Intel Core i3
Graphics
GeForce GT 440 1024 MB
Mac
  1. iMac
Hi, guys!
I did a clean install of OS X Mavericks.
Followed your screenshots exactly, but when I looked up at my About This Mac window, its said
ATI Radeon HD 5450 Series 5 MB
Even though its a 1024 mb Graphics card. Can you help me out?
config attached
 

Attachments

  • config.plist
    4.6 KB · Views: 124
Joined
Mar 31, 2019
Messages
3
Motherboard
GA-H61N-USB3
CPU
i3-2105
Graphics
GTX 660
So much information here that it's easy to get lost in it.

I have the Radeon HD 6350, which apparently follows the guide of the ATI Radeon 5450. Here's what I did:;

1. Sierra Installer on USB flash drive.
2. Boot flash drive, select options, inject ATI, main menu, press space bar, select safe mode and verbose - used safe and verbose for entire installation period until I got to Multibeast.
3. Install and configure multibeast for your particular setup.
4. Download and run 'Clover Configurator' - Google it.
5. Left hand side menu - 'Mount EFI' - 'Mount Partition'
6. 'File' menu - 'Open' - 'EFI-EFI-Clover-config.plist'
7. Left hand side menu - 'ACPI' - 'Fixes' - √ 'Fix Display'
8. Left hand side menu - 'Devices' - 'Fake ID' - 'ATI' - "68E01002"
9. Left hand side menu - 'Graphics' - √ 'Inject EDID' - 'VendorID' : 0x1002 - 'ProductID' : 0x68E0 - √ 'Inject ATI'
10. Save and close Clover Configurator
11. Locate 'AMD5000Controller.kext' and 'AMDRadeonX3000.kext' in /Volumes/YOURDRIVE/System/Library/Extensions/
12. Right click - Show Package Contents - Contents - Open 'info.plist'
13. Verify that 'AMD5000Controller.kext' contains:
<key>IOPCIMatch</key> <string>0x68981002 0x68f91002 0x68991002 0x68E01002 0x68E11002 0x68D81002 0x68C01002 0x68C11002 0x68D91002 0x68B81002 0x68B01002 0x68B11002 0x68A01002 0x68A11002 </string>
14. Verify that 'AMDRadeonX3000.kext' contains:
<string>AMDCedarGraphicsAccelerator</string> <key>IODVDBundleName</key> <string>AMDRadeonVADriver</string> <key>IOKitDebug</key> <integer>0</integer> <key>IOMatchCategory</key> <string>IOAccelerator</string> <key>IOPCIMatch</key> <string>0x68f91002 0x68E01002</string>
15. Save everything, reboot, and bask in the lukewarm glow of nine year old technology.
 
Joined
Nov 23, 2019
Messages
1
So much information here that it's easy to get lost in it.

I have the Radeon HD 6350, which apparently follows the guide of the ATI Radeon 5450. Here's what I did:;

1. Sierra Installer on USB flash drive.
2. Boot flash drive, select options, inject ATI, main menu, press space bar, select safe mode and verbose - used safe and verbose for entire installation period until I got to Multibeast.
3. Install and configure multibeast for your particular setup.
4. Download and run 'Clover Configurator' - Google it.
5. Left hand side menu - 'Mount EFI' - 'Mount Partition'
6. 'File' menu - 'Open' - 'EFI-EFI-Clover-config.plist'
7. Left hand side menu - 'ACPI' - 'Fixes' - √ 'Fix Display'
8. Left hand side menu - 'Devices' - 'Fake ID' - 'ATI' - "68E01002"
9. Left hand side menu - 'Graphics' - √ 'Inject EDID' - 'VendorID' : 0x1002 - 'ProductID' : 0x68E0 - √ 'Inject ATI'
10. Save and close Clover Configurator
11. Locate 'AMD5000Controller.kext' and 'AMDRadeonX3000.kext' in /Volumes/YOURDRIVE/System/Library/Extensions/
12. Right click - Show Package Contents - Contents - Open 'info.plist'
13. Verify that 'AMD5000Controller.kext' contains:
<key>IOPCIMatch</key> <string>0x68981002 0x68f91002 0x68991002 0x68E01002 0x68E11002 0x68D81002 0x68C01002 0x68C11002 0x68D91002 0x68B81002 0x68B01002 0x68B11002 0x68A01002 0x68A11002 </string>
14. Verify that 'AMDRadeonX3000.kext' contains:
<string>AMDCedarGraphicsAccelerator</string> <key>IODVDBundleName</key> <string>AMDRadeonVADriver</string> <key>IOKitDebug</key> <integer>0</integer> <key>IOMatchCategory</key> <string>IOAccelerator</string> <key>IOPCIMatch</key> <string>0x68f91002 0x68E01002</string>
15. Save everything, reboot, and bask in the lukewarm glow of nine year old technology.


@RickSanchez I'm very new to hackintosh, I just installed hackintosh on my very old pc which has this 5450 graphics on it, I followed your guide, but still not getting the correct output from the driver. I'm currently on Catalina 10.15 .
Should I downgrade to Sierra?
Are all amd kexts files the same for different versions of OS? Since I had to download AMD kexts files separately which was for the Yosemite version.

Can you please provide AMD kexts?
 
Last edited:
Joined
Jun 9, 2013
Messages
10,703
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
@RickSanchez I'm very new to hackintosh, I just installed hackintosh on my very old pc which has this 5450 graphics on it, I followed your guide, but still not getting the correct output from the driver. I'm currently on Catalina 10.15 .
Should I downgrade to Sierra?
Are all amd kexts files the same for different versions of OS? Since I had to download AMD kexts files separately which was for the Yosemite version.

Can you please provide AMD kexts?

Please follow forum rules and add your hardware to your profile. https://www.tonymacx86.com/rules/
 
Joined
Sep 8, 2013
Messages
23
Motherboard
Dell Optiplex 9020
CPU
i5-4590
Graphics
K6000
Mac
  1. iMac
Classic Mac
  1. Apple
Mobile Phone
  1. Android
hi bro I do very thing you do on Sierra to my hd5450 but in dsdt have no pop1 or pegp or peg0
my pc is delloptiplex360
 
Top