Contribute
Register

[Guide] El Capitan on the Intel Skylake NUC

Status
Not open for further replies.
Joined
Mar 20, 2014
Messages
10
Mac
Classic Mac
Mobile Phone
Yes there is a Recovery option in the Clover, thanks for the explanation.)

I'll try to hide those options I don't need (two Windows and Recovery) to have it clean.
 
Joined
Jun 5, 2015
Messages
9
Motherboard
Intel NUC 6i5SYH
CPU
i5 Skylake 6260U
Graphics
Intel Iris Graphics 540
Mac
  1. Mac mini
Classic Mac
Mobile Phone
  1. iOS
Ammulder,

thank you! I was able to run El Capitain by just following your instruction and everything is working as expected.

I just have a strange behavhiuor (minor issue) during the boot that I would like to share in order to find a possible solution.
My configuration is involving an Intel NUC 6i5SYH,16GB RAM Kingston DDR4, m.2 NVMe drive Samsung 950Pro 256GB.
When the NUC is powered ON (or also rebooted), the clover menu appears and then after few seconds the apple logo appears and the progress bar is at beginning. From this point I have to wait +/- 60 seconds before the boot continue regurarly.
I tried to boot in verbose mode and I see the message in the attached picture before the boot sequence stops for some seconds.
IMG_0942.JPG

Have any of you some suggestion on how to get rid of this boot delay?
Thank you
 
Joined
Sep 1, 2014
Messages
2,955
Motherboard
GA-H87N-WIFI
CPU
i7-4790S
Graphics
GT 740
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Mine also has a noticeable delay there, but I would have said it was more like 15 seconds than 60. I should time it I guess. I wondered whether the delay depends on the number of kexts you have in the CLOVER/kexts/ directory (as opposed to installed to /Library/Extensions) but I haven't tested that.
 
Joined
Feb 14, 2016
Messages
2
Motherboard
NUC
CPU
i3-6100U
Graphics
Intel HD Graphics 520
Mac
Classic Mac
Mobile Phone
Excellent guide!

I've got El Capitan running on my NUC6i3SYH. I've had some issues with dual boot to Win 10 through Clover but I'll admit I followed a different guide for the dual boot stuff. I partitioned for both OSes then installed Win 10 first (direct from the installer CD) and then went back to install OSX per the guide. I can get back to Win 10 by exiting Clover (at least until I did a windows update and keep getting MEMORY_MANAGEMENT errors on restart :(). The (now 2) Win boot options in my Clover menu aren't working for me. I just get a blank screen with a cursor that sits there forever (at least the less than 1 minute forever that I am willing to wait). I'll probably reinstall Win 10 following the guide to get things working.

El Capitan has been working fine for me with the graphics acceleration disabled. No bluetooth or wifi but it still works. Looking forward to the updates like everyone else so I don't have to hobble the HW to get things working.

Thanks for the excellent resource!
 
Joined
Sep 1, 2014
Messages
2,955
Motherboard
GA-H87N-WIFI
CPU
i7-4790S
Graphics
GT 740
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
If Apple gets off their duff and releases solid integrated graphics drivers for Skylake, it'll be the 6i5 hands down. But if you want a regular-use machine before then, I think it has to be one of the 5i* ones. I don't know, maybe you'd use it differently, but not having App Store is annoying and not having Preview is a deal-breaker for me.
 
Joined
Jun 5, 2015
Messages
9
Motherboard
Intel NUC 6i5SYH
CPU
i5 Skylake 6260U
Graphics
Intel Iris Graphics 540
Mac
  1. Mac mini
Classic Mac
Mobile Phone
  1. iOS
I had a nuc5i5myhe Nuc and it worked in a fantastic way with El Capitain and following the Ammulder guide related to the Broadwell nuc. It was running quite like my Mac Mini.
Then I moved to the skylake version NUC6i5SYH and I'm pretty satisfied of on how the system is working keeping in mind that still there is no apple driver for skylake graphic.
Of course the graphic acceleration is disabled in order to avoid graphics artifact but ,except for the spotify application that anyway has some graphics glithces, the other apps installed in my system are workings fine.
 
Joined
Jan 23, 2016
Messages
22
Motherboard
Intel NUC7i5BNK
CPU
i5-7260U
Graphics
Intel Iris 640
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
Audio goes out sometimes in El Capitan on NUC6i5SYH.

I have El Capitan running good now after installing last week but noticed audio goes out sometimes. It only seems to go out on various websites/youtube/etc using Firefox, my default browser. It seems to be random, but I'm not sure. The only thing that will restore audio out of the headphone jack on the NUC is a total reboot of the system.

Also, on a separate question is there a way to set up automatic login through Clover boot screen into OSX? I don't see any option there on the Clover bootup screen.
 
Joined
Sep 1, 2014
Messages
2,955
Motherboard
GA-H87N-WIFI
CPU
i7-4790S
Graphics
GT 740
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Not sure about the audio problem. It's not my daily-use computer, so I haven't tested that extensively. We'll have to see if others can speak up about it. If it only drops out after the computer sleeps, you can try CodecCommander (or disabling sleep). Actually, if sleep/wake works for you, you could try CodecCommander no matter what, and if you have a drop out, do a sleep/wake and see if that resets it.

Also, on a separate question is there a way to set up automatic login through Clover boot screen into OSX? I don't see any option there on the Clover bootup screen.

Yes, it's the Boot / DefaultVolume option in config.plist. Set it to the name of the system partition (e.g. "Macintosh HD" or whatever you named it). Then the Timeout option in the same place sets how may seconds to wait before starting that OS automatically.
 
Joined
Jan 23, 2016
Messages
22
Motherboard
Intel NUC7i5BNK
CPU
i5-7260U
Graphics
Intel Iris 640
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
Login / Logout doesn't correct the audio issue, only a full reboot. Now, I notice I don't get video or audio on Amazon, Netflix, Hulu, and most webstream sites so that might be related to this issue. Sites like YouTube and Vimeo have both audio and video working fine. Sounds like we're back to video driver issue.

Yes, setting timeout to zero only allows the Intel NUC splash screen to show for a fraction of a second before automatic boot into OSX. It's starting to feel like a real Mac!

Windows dual boot: Would there be any advantage to install Windows on the 2nd drive slot (M.2) vs same drive as OSX is installed? I'm up for trying it on this SYH, but I would like to know beforehand.
 
Status
Not open for further replies.
Top