Contribute
Register

[Guide] El Capitan on the Intel Broadwell NUC

Status
Not open for further replies.
Joined
Feb 21, 2011
Messages
104
Motherboard
Asus Rampage V Extreme X99
CPU
i7-5960
Graphics
GTX 1080 Ti
My NUC5i7RYH worked great for months, being connected to a 4K TV via a mini HDMI cable (but I used it at 1080p) . I was only getting a small glitch while viewing the Apple logo and loading meter during booting but once booted it was ok. After summer vacations I get really bad garbage/artifacts on both login screen and desktop. The screen is garbled all the time, even without moving the mouse and even when viewing the screen from Apple Remote Desktop. I don't recall changing anything. I've now tried updating Clover, MacOSX from 10.11.5 to 10.11.6, changing SMBIOS from MacBookAir 6,2 to 7,2 but still nothing. My BIOS is v358. Any ideas ?

Can someone with a working setup share his/her config.plist ? The OP's config does not work for me (anymore ?).

What's the correct combination of SMBIOS, SSDTs, and KextsToPatch entries in Clover ?

Is ig-platform-id needed and what is the right one for NUC5i7RYH ?

At least, once I remove Toleda's GPU SSDT I can have a slow non-accelerated screen. If I leave it inside CLOVER/ACPI/patched I get an extensively garbled desktop which disconnects to a garbled login screen every 20 seconds.
 
Last edited:
Joined
Mar 4, 2016
Messages
15
CPU
i7-6770HQ
Graphics
Intel® Iris™ Pro Graphics 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Can someone with a working setup share his/her config.plist ? The OP's config does not work for me (anymore ?).

What's the correct combination of SMBIOS, SSDTs, and KextsToPatch entries in Clover ?

Is ig-platform-id needed and what is the right one for NUC5i7RYH ?

At least, once I remove Toleda's GPU SSDT I can have a slow non-accelerated screen. If I leave it inside CLOVER/ACPI/patched I get an extensively garbled desktop which disconnects to a garbled login screen every 20 seconds.
I don't have the i7 version. Do you want me to send you my i5 config.plist?
 
Joined
Feb 21, 2011
Messages
104
Motherboard
Asus Rampage V Extreme X99
CPU
i7-5960
Graphics
GTX 1080 Ti
I don't have the i7 version. Do you want me to send you my i5 config.plist?
I suspect it is the Iris Pro 6100 of i7 but it would be nice, thanks Sbouillon. I will try yours and report back. I don't know what I am doing wrong, it was working ok before (maybe it's the 10.11.6 update ?). I also followed Rehabman's generic NUC5 guide and I get the same glitches/garbles.
 
Joined
Jun 7, 2011
Messages
5
Motherboard
MAC OS 10.8.2
CPU
E5400
Graphics
GT9600
Mac
Classic Mac
Mobile Phone
hi,i have got the BCM94352Z chip wifi card,but which seems no place to insert,
intel said their m.2 only accept the M.2 ssd,pls advice .
 
Joined
Jun 7, 2011
Messages
5
Motherboard
MAC OS 10.8.2
CPU
E5400
Graphics
GT9600
Mac
Classic Mac
Mobile Phone
hi,
Hi,
my first message on this board as well. thanks a lot ammulder!

I'm verry happy with 10.11.1 on my 5i5ryh

Using a Dell p2715q 3840x2160@60Hz via DP and it runs smoothly, besides the fact that it needs a power cycle after login, otherwise it stays black.

Also i activated the bluetooth and it runs nicely for me.

Thanks a lot for the great guid!
hi,pls advice how to activated the bluetooth ,which doesnot work on my nuc
 
Joined
Mar 4, 2016
Messages
15
CPU
i7-6770HQ
Graphics
Intel® Iris™ Pro Graphics 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
I suspect it is the Iris Pro 6100 of i7 but it would be nice, thanks Sbouillon. I will try yours and report back. I don't know what I am doing wrong, it was working ok before (maybe it's the 10.11.6 update ?). I also followed Rehabman's generic NUC5 guide and I get the same glitches/garbles.
How do you want me to send it to you? Do you want to message me your email?
 

Attachments

  • config.plist
    5.8 KB · Views: 107
Joined
Mar 4, 2016
Messages
15
CPU
i7-6770HQ
Graphics
Intel® Iris™ Pro Graphics 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
edit: deleted comment. Uploaded config.plist to last post.

FYI: I have "fast boot" enabled on it.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,488
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I also followed Rehabman's generic NUC5 guide and I get the same glitches/garbles.

Reply in my guide thread. Attach files/output requested in "Problem Reporting".
 
Joined
Jan 31, 2016
Messages
21
Motherboard
Gigabyte Z97X-UD3H
CPU
Intel i5 4690K
Graphics
EVGA GTX 750 FTW
Mac
  1. iMac
Mobile Phone
  1. Android
Will a USB WIFI adapter, mac compatible, work with our machines? I'm trying to find a kext for the Netgear A6200 but I've given up. I'll buy an adapter specifically made for Mac if it will work.

You should buy a TP-Link AC600 Archer T2UH. It's a USB wifi adapter with a removable antenna.
Here would be the Mac OS drivers for this wifi adapter.
http://www.mediatek.com/en/downloads1/downloads/?sort=os
 
Joined
Jun 7, 2011
Messages
5
Motherboard
MAC OS 10.8.2
CPU
E5400
Graphics
GT9600
Mac
Classic Mac
Mobile Phone
[Guide] 10.11 on Intel Broadwell NUC 2.0

Ok getting a little further after turning off Trusted Platform Serial Port, and GPIO Lockdown. Compared your bios screen shots to mine and made everything as close as possible,but not everything is the same on my model.

Never
get to the install screen. Stuck at this screen about 3/4 of the way. Any ideas?

View attachment 154027

thanks for the quick reply!

the same as me,do you slove it?
 
Status
Not open for further replies.
Top