Contribute
Register

[Guide] El Capitan on the Gigabyte GA-Z170N-Gaming 5 (mini-ITX)

Joined
Aug 22, 2016
Messages
23
Yes everything works, except there are some hoops to get the Wifi card I have working. If you have the same card I'd wait a few weeks for a guide to show up here (maybe I'll write one, using the guide on InsanelyMac as a base).

There is also an issue with the integrated HD 530 having artifact in the top left corner. It's accelerated out of the box without a patch however. Not an issue if you have PCI graphics card of course.
Thanks! I have the same Wifi card so I guess i'll wait. I'm using the integrated HD530 as well.
 
Joined
Jan 2, 2013
Messages
50
Motherboard
ZBOX-1070K
CPU
Intel i5-7500K
Graphics
NVDIA GTX 1070
For future reference, here are the patches I needed in El Capitan and Sierra to get the BCM 94352Z card working.

  • In Devices menu, copy and paste into the wifi box: 0x43BA14E4
  • In kexts to patch you can add the airport patches and hot spot handoff (these are the same as for El Capitan)
Name: IOBluetoothFamily
Find: 4885ff7447488b07
Replace: 41be0f000000eb44
Comment: 10.11 / 10.12 BT4LE-Handoff-Hotspot, credit RehabMan based on Dokterdok Patch

Name: AirPortBrcm4360
Find: 6B100000750D
Replace: 6B1000009090
Comment: Third party card to Airport Patch
  • Additional patch to enable card in Sierra
Kext: AirPortBrcm4360
Find: 81F952AA00007529
Replace: 81F952AA00006690
Comment : Sierra FVCO patch
  • Optional 5GHz patch
Name: AirPortBrcm4360
Find: 58540025182B210020
Replace: 5854080A321B43000A
Comment: 5GHZ Patch
 
Joined
Aug 22, 2016
Messages
23
For future reference, here are the patches I needed in El Capitan and Sierra to get the BCM 94352Z card working.

  • In Devices menu, copy and paste into the wifi box: 0x43BA14E4
  • In kexts to patch you can add the airport patches and hot spot handoff (these are the same as for El Capitan)
Name: IOBluetoothFamily
Find: 4885ff7447488b07
Replace: 41be0f000000eb44
Comment: 10.11 / 10.12 BT4LE-Handoff-Hotspot, credit RehabMan based on Dokterdok Patch

Name: AirPortBrcm4360
Find: 6B100000750D
Replace: 6B1000009090
Comment: Third party card to Airport Patch
  • Additional patch to enable card in Sierra
Kext: AirPortBrcm4360
Find: 81F952AA00007529
Replace: 81F952AA00006690
Comment : Sierra FVCO patch
  • Optional 5GHz patch
Name: AirPortBrcm4360
Find: 58540025182B210020
Replace: 5854080A321B43000A
Comment: 5GHZ Patch
Thank you! This worked beautifully though now I have lost sound---there is no audio device recognized. I tried changing to all of the known ports. Also tried using kextbeast to reinfect appleALC and also reinstall ALC1150 and 100 series with Multi Beast. None of those steps worked.
 
Joined
Jan 2, 2013
Messages
50
Motherboard
ZBOX-1070K
CPU
Intel i5-7500K
Graphics
NVDIA GTX 1070
I have audio working so I don't think that ruined it. My recommendation is so make you have a fresh AppleHDA (see the toleda guide) and start again with AppleALC. Basically the AppleALC is an alternative to the Multibeast/toleda method done by MultiBeast. To reset you need to reinstall a fresh copy of AppleHDA.

I found patching to be messy and it can be avoided with AppleALC kext. On this version Inject 1 works (previously 7 did). Also you need the DSDT patch in clover to change HDAS to HDEF (100 series patch in Multi Beast).
 
Joined
Jan 12, 2014
Messages
47
Motherboard
GA-Z170N-Gaming 5
CPU
I5-6600K
Graphics
RX 560
Mac
MacBook
Mobile Phone
iOS
Thanks to all contributors. I am able to run El Cap 11.6 version on this board with I5-6600K. Anyone able to run 4K monitor resolution with on board HD530 graphics?
 
Joined
Jan 12, 2014
Messages
47
Motherboard
GA-Z170N-Gaming 5
CPU
I5-6600K
Graphics
RX 560
Mac
MacBook
Mobile Phone
iOS
I tried the patch from the above link. It did not work after the first few reboots, i do not know what I did, but after a while the 4K started working. The only think I did differently the last time was to add inject EDID in graphics of clover, maybe that was the missing link.

As a side question: The bluetooth in system preference says its active, but do not have any device to test it. Any way I can test this. I tried an iphone 4s, but no luck getting it to connect.
 
Joined
Jan 2, 2013
Messages
50
Motherboard
ZBOX-1070K
CPU
Intel i5-7500K
Graphics
NVDIA GTX 1070
I tried the patch from the above link. It did not work after the first few reboots, i do not know what I did, but after a while the 4K started working. The only think I did differently the last time was to add inject EDID in graphics of clover, maybe that was the missing link.

As a side question: The bluetooth in system preference says its active, but do not have any device to test it. Any way I can test this. I tried an iphone 4s, but no luck getting it to connect.
Not really sure what your problem is. For El Capitan you need to inject the proper ig-platform-id and inject Intel. For some resolutions over HDMI you need to install a Pixel Clock patch. For Sierra you do not need to inject anything, and there is a new pixel clock patch. See https://github.com/Floris497/mac-pixel-clock-patch-V2.
 
Joined
Jan 2, 2013
Messages
50
Motherboard
ZBOX-1070K
CPU
Intel i5-7500K
Graphics
NVDIA GTX 1070
So I'm going to update this guide for Sierra when the new NVIDIA drivers are released. For anyone watching this thread, are there any tips or trips for the new OS that you want to add or recommend?
 
Top