Contribute
Register

[Guide] El Capitan on the Gigabyte GA-Z170N-Gaming 5 (mini-ITX)

Joined
Apr 5, 2016
Messages
936
Motherboard
GIGABYTE Z170X-Gaming 7
CPU
i7-6700K
Graphics
GTX TITAN X
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Apple
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
So I'd have to make this a dual boot system to figure out this issue? Seems like extra work. I'll check out this guide though thanks!

It's a PC. It's supposed to have Windows on it. You need Windows to do things like update firmware of devices like the Thunderbolt chip. The extra work part is making it all work with macOS but to do that, it helps to know how it all works in Windows.
 
Joined
Aug 12, 2017
Messages
1
Motherboard
Gigabyte z170n Gaming 5
CPU
Skylake i7 6700K
Graphics
EVGA GeForce GTX 1060 6GB SSC
Mac
  1. iMac
First off, thank you for the notes here. They have been incredibly helpful in getting my first build up and running with integrated graphics!

I am having trouble getting my GPU recognized (at all), and since this is my first build ever I cannot decide if *I* am the problem, or if the GPU is the problem. I have followed all the instructions here, and have read a bunch of threads in the graphics section of the site off and on for the past 2 weeks; its driving me crazy!

As of today, I am getting _zero_ signal out of an HDMI connection to my GPU. I cannot even boot to the bios (currently at F22) config screen. Is there some super-secret setting that I am missing, or is this a bad piece of hardware? Any suggestions would be greatly appreciated.
 
Joined
Aug 19, 2016
Messages
69
Motherboard
ASRock Z390 PHANTOM GAMING-ITX/AC
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Did someone update to High Sierra?
 
Joined
Apr 5, 2016
Messages
936
Motherboard
GIGABYTE Z170X-Gaming 7
CPU
i7-6700K
Graphics
GTX TITAN X
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Apple
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Did someone update to High Sierra?
Not yet. I updated my Gaming 7 though. All I had to do was:
- Update Clover (using the Clover preferences panel to download the latest)
- Update my Lilu and LiluFriend and Lilu plugin extensions
- Update my config.plist so that the IONVMeFamily patches only match 10.11.x,10.12.x because 10.13 has NVMe support.
- Download the High Sierra installer from the App Store (or copy it from another computer into the Applications folder)
- Start High Sierra installer
- Reboot into Clover and select install (once or twice? I forget. The install option should disappear after it's no longer applicable)
- Reboot into Clover and select my updated High Sierra partition
- Update Nvidia web driver
- Reboot
 
Joined
Aug 19, 2016
Messages
69
Motherboard
ASRock Z390 PHANTOM GAMING-ITX/AC
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
My GA-Z170N-Gaming 5 is working perfectly with HS. The only thing I'm not able to enable is Handoff.

Regards,
Ben
 
Joined
Mar 14, 2016
Messages
18
Motherboard
Gigabyte GA-Z70N Gaming 5
CPU
i7-6700K @ 4Ghz
Graphics
nvidia GTX960 Mini-ITX
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
My GA-Z170N-Gaming 5 is working perfectly with HS. The only thing I'm not able to enable is Handoff.

Regards,
Ben

When I get home from vacation...I'll upload my configuration files for you. Hopefully it'll help you get that Handoff working.
 
Joined
Jun 10, 2016
Messages
4
Motherboard
Gigabyte GA-Z170N-Gaming 5 Mini ITX LGA1151 Motherboard
CPU
i5 6600K 6MB Cache
Graphics
Intel® HD Graphics 530
could somebody please update the guide for fresh installation of High Sierra too? I tried following this guide just by replacing the El Capitan with HS, but only thing I get is black screen after selecting macOS on clover menu.
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,492
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
@mohamnag, please update your profile (personal details) with your Motherboard or Make/Model, CPU and Graphics Card.
The Rules said:
Profiles need to contain at least your primary system to assist others with helping you.
 
Joined
Sep 16, 2015
Messages
8
Motherboard
GA-H270N-Wifi
CPU
i3 7100
Graphics
GT710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi @VanillaIcee !

Thanks a lot for this tutorial! It's one of the best one I've read! I sadly have a H270N-Wifi instead of you H170 one... And I have a problem to get my USB port alimentation working properly. I wondered if you could explain me how to generate the same SSDT you did for your Mobo? For the USB ports... Is it with the ssddtPRGen.sh from Piker-Alpha?! :)

Thanks a lot in advance for your help!!
 
Top