Contribute
Register

[Guide] Dual boot Windows and Yosemite with Clover EFI Boot Loader on a Acer Aspire V Nitro VN7-591G

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I'll try another time then to deal with errors...

I attach my IOreg, the ClickPad is Synaptics cause that are the drivers recommended by Acer for Windows...
Do you see something else relevant in my IOreg???

Thank you
ioreg comments:
- lots of work to do regarding ACPI patching here...
- GenericUSBXHCI.kext not recommended (not needed either) (use FakePCIID+FakePCIID_XHCIMux instead)
- CPU power management not implemented
- IGPU power management not implemented (comes along with correct ACPI patching)
- Nvidia not disabled (again... ACPI patching)
- backlight control not implemented (guess what you need...)
- there is no PS2 trackpad
- guessing your trackpad is connected via internal USB (would require special drivers to be created for full functionality)

See pinned guides: http://www.tonymacx86.com/forums/el-capitan-laptop-support.181/
 
Joined
Jul 16, 2011
Messages
160
Motherboard
Acer Aspire v15
CPU
Intel Core i7-4720HQ Processor (2.6 GHz)
Graphics
NVIDIA GeForce GTX 960M
Mac
Classic Mac
Mobile Phone
I recently had a hard drive failure.

I am trying to retrace my steps

For some reason the screen is garbled on boot from hard drive but not when i boot from my usb install

Why is this? What could be causing the problem?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I recently had a hard drive failure.

I am trying to retrace my steps

For some reason the screen is garbled on boot from hard drive but not when i boot from my usb install

Why is this? What could be causing the problem?
Make sure your Clover setup on HDD is the same as on USB.
 
Joined
Jul 16, 2011
Messages
160
Motherboard
Acer Aspire v15
CPU
Intel Core i7-4720HQ Processor (2.6 GHz)
Graphics
NVIDIA GeForce GTX 960M
Mac
Classic Mac
Mobile Phone

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I found my last working config file here


http://www.tonymacx86.com/threads/guide-dual-boot-windows-and-yosemite-with-clover-efi-boot-loader-on-a-acer-aspire-v-nitro-vn7-591g.160345/page-26

but for some reason my video ram is showing up as 7 Mb

what would cause this to have this showing 7 mb and not the full amount?
Attach ioreg as ZIP: http://www.tonymacx86.com/audio/58368-guide-how-make-copy-ioreg.html. Please, use the IORegistryExplorer v2.1 attached to the post! DO NOT reply with an ioreg from any other version of IORegistryExplorer.app.

Provide output (in Terminal):
Code:
kextstat|grep -y acpiplat
kextstat|grep -y appleintelcpu
kextstat|grep -y applelpc
kextstat|grep -y applehda
Attach EFI/Clover folder as ZIP (press F4 at main Clover screen before collecting). Please eliminate 'themes' directory. Provide only EFI/Clover, not the entire EFI folder.

Attach output of (in Terminal):
Code:
sudo touch /System/Library/Extensions && sudo kextcache -u /
Compress all files as ZIP. Do not use external links. Attach all files using site attachments only.
 
Joined
Jul 16, 2011
Messages
160
Motherboard
Acer Aspire v15
CPU
Intel Core i7-4720HQ Processor (2.6 GHz)
Graphics
NVIDIA GeForce GTX 960M
Mac
Classic Mac
Mobile Phone
here is the files you requested
 

Attachments

Joined
Feb 10, 2013
Messages
3
Motherboard
Acer Aspire VN7-591
CPU
Core i5-4210H 2.90GHz
Graphics
Intel HD Graphics 4600
Mobile Phone
Android
Hello,

First, I want to say thank you for this awesome guide, it's the first time that I successful to have an appropriate setup (I failed the first time because I had no time and build a hackintosh is a real challenge).

I'm on the same laptop, I installed El Capitain, and the most of things works (gpu, sound, etc) thanks to this thread (and the others guides on the El Capitan forum).

But I have some mistakes with SSDT Patching for disabling nvidia GPU.
My dump was done on Archlinux, with the help of the patching DSDT/SSDT Guide.
On the first page of this thread, Ikayghan said that SSDT4 and SSDT5 must be patched, and when I patch SSDT4 for fix brightness, I can't compile, I have 4 errors, the same in different lines : "Syntax Error, unexpected PARSEOP_INTEGER".
In the SSDT5, the _OFF method is completely different than the example, so I tried to adapt the code to my SSDT, but it ends with an error : "Input file does not appear to be an ASL or data table source file" when I copy paste (with changing CXTX/SGOF and try to respect the format) or "Too few Arguments (CCHK Requires 1)" on

Code:
If (LEqual (CCHK, Zero))
and
Code:
Store (One, CCHK)
I notice also that I have the iasl message when I disassemble SSDT4 :"There were 10 external control methods found during disassembly, but only 9 were resolved" (I used the refs.txt). I am on this since 2 days, I don't know what to do ; If there is an obvious fix to all this problem, I am very sorry, but it's my "very" first time to build an hackintosh, I am lost.

There is my .ioreg file and my native files from the archlinux dump.

Thank you in advance for help.

(I am sorry for my bad english)
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello,

First, I want to say thank you for this awesome guide, it's the first time that I successful to have an appropriate setup (I failed the first time because I had no time and build a hackintosh is a real challenge).

I'm on the same laptop, I installed El Capitain, and the most of things works (gpu, sound, etc) thanks to this thread (and the others guides on the El Capitan forum).

But I have some mistakes with SSDT Patching for disabling nvidia GPU.
My dump was done on Archlinux, with the help of the patching DSDT/SSDT Guide.
On the first page of this thread, Ikayghan said that SSDT4 and SSDT5 must be patched, and when I patch SSDT4 for fix brightness, I can't compile, I have 4 errors, the same in different lines : "Syntax Error, unexpected PARSEOP_INTEGER".
In the SSDT5, the _OFF method is completely different than the example, so I tried to adapt the code to my SSDT, but it ends with an error : "Input file does not appear to be an ASL or data table source file" when I copy paste (with changing CXTX/SGOF and try to respect the format) or "Too few Arguments (CCHK Requires 1)" on

Code:
If (LEqual (CCHK, Zero))
and
Code:
Store (One, CCHK)
I notice also that I have the iasl message when I disassemble SSDT4 :"There were 10 external control methods found during disassembly, but only 9 were resolved" (I used the refs.txt). I am on this since 2 days, I don't know what to do ; If there is an obvious fix to all this problem, I am very sorry, but it's my "very" first time to build an hackintosh, I am lost.

There is my .ioreg file and my native files from the archlinux dump.

Thank you in advance for help.

(I am sorry for my bad english)
Use Clover F4 to extract ACPI files.

See guide: http://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/
 
Joined
Feb 10, 2013
Messages
3
Motherboard
Acer Aspire VN7-591
CPU
Core i5-4210H 2.90GHz
Graphics
Intel HD Graphics 4600
Mobile Phone
Android
I did it, but it doesn't work, I have the same issues. :(
The SSDT4 is now SSDT-6.aml and SSDT5 is SSDT-7.aml.

I have always the 4 errors on SSDT-6.dsl and the 2 errors in SSDT-7.dsl.
 

Attachments

Top