Contribute
Register

[Guide] Disabling discrete graphics in dual-GPU laptops

Joined
Nov 25, 2010
Messages
41
Motherboard
Asus G771JM-DH71-CA
CPU
i7-4710HQ
Graphics
GTX 860M - HD4600

Attachments

  • debug_23258.zip
    2.3 MB · Views: 51
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,691
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Apologies for that! Appreciate you taking the time to help with this (and everyone else's) issues.

Attached are the files generated by that tool.

Your ACPI/patched files are not correct. They don't even have the correct names... (and there are files there that require no patches).
And the ACPI/origin files are NOT the result of a Clover F4 dump.
Start over and follow post #1 as written.

Also, your config.plist has incorrect settings for this guide. You must use AutoMerge=true as per post #1.
And you should use the RehabMan fork of Clover as suggested.
See guide for good starter plists and my build of Clover:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
 
Joined
Jan 25, 2018
Messages
3
CPU
Intel Core i3 380M Arrandale
Graphics
Nvidia Geforce 315M
Hello Friend,

I am running high sierra on my laptop the graphics doesn't work well. I have intel core i3 1st gen 380M arrandale CPU and i guess there is internal IGPU inte hd graphics but on my laptop it is by default disabled and insted of that there is nvidia geforce 315M 1GB graphics card which is enabled by default. Now, the problem i am facing is there is no option for disabling the nvidia graphics card inorder to enable the IGPU which is supported i guess. I want my graphics to run properly with acceleration, since my laptop screen is LVDS connector. I am unable to find kexts for nvidia 315M or you can say, i can't get any guide on how to enable 315 Nvidia on hackintosh. Either of the two graphics must run, which one to use i have no idea. Please help me on this issue of mine for which i would be very grateful to you guys.

Thanks in Advance
Gourab
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,691
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello Friend,

I am running high sierra on my laptop the graphics doesn't work well. I have intel core i3 1st gen 380M arrandale CPU and i guess there is internal IGPU inte hd graphics but on my laptop it is by default disabled and insted of that there is nvidia geforce 315M 1GB graphics card which is enabled by default. Now, the problem i am facing is there is no option for disabling the nvidia graphics card inorder to enable the IGPU which is supported i guess. I want my graphics to run properly with acceleration, since my laptop screen is LVDS connector. I am unable to find kexts for nvidia 315M or you can say, i can't get any guide on how to enable 315 Nvidia on hackintosh. Either of the two graphics must run, which one to use i have no idea. Please help me on this issue of mine for which i would be very grateful to you guys.

Thanks in Advance
Gourab

Off-topic.
This thread is for laptops with Nvidia or AMD graphics in a dual-GPU switched configuration.
Your laptop has only dedicated Nvidia...
 
Joined
Jan 25, 2018
Messages
3
CPU
Intel Core i3 380M Arrandale
Graphics
Nvidia Geforce 315M
Off-topic.
This thread is for laptops with Nvidia or AMD graphics in a dual-GPU switched configuration.
Your laptop has only dedicated Nvidia...

Thanks for your quick response !! i think i should ask the question on nvidia geforce graphics in that section..
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,691
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thanks for your quick response !! i think i should ask the question on nvidia geforce graphics in that section..

You should open a separate thread in the appropriate laptop support forum.
 
Joined
Feb 16, 2016
Messages
22
Motherboard
Haswell Toshiba Satellite Pro
CPU
i7-4700MQ
Graphics
HD4600
Mobile Phone
  1. iOS
_OFF is in DSDT.

There is no corresponding _INI, so just add one under _OFF:
Code:
Method (_INI) { _OFF() }

Your EC is named IEC. If you look at _OFF you will see EC related code (the call to SPIN)... That code will need to be moved to _REG as described in the guide.



You should not expect the same files from patchmatic -extract as Clover F4.



Your question regarding dynamic SSDTs is answered in the guide: http://www.tonymacx86.com/el-capitan-laptop-support/152573-guide-patching-laptop-dsdt-ssdts.html

Hi Rehab,
I have tried a year ago to disable discrete graphics in dual-GPU:

- Toshiba Satellite Pro L50-A531
- intel core i7-4700MQ Haswell architecture
- Intel HD 4600
- Nvidia Geforce 740M (integrated NOT disabled)

- Sierra 10.12.6
- Everything is working (sleep, wake, wifi, HDMI, sound, brightness)

You tried to help me (thank you sooo much) I followed the guide and your advice but I failed then gave up.
Until I decided to upgrade to High Sierra and ran to "Window Server Service only ran for 0 seconds"
Read your guide https://www.tonymacx86.com/threads/...-only-ran-for-0-seconds-with-dual-gpu.233092/

- my _OFF is in DSDT only and no _INI
- I added _INI under _OFF
- Deleted Spin and relocated spin to _REG
- Created Discretespoof SSDT


Still my NVIDIA is not disabled.

Could you please take a look at my DSDT and help me disable discrete graphics in dual-GPU.


 

Attachments

  • DSDT.dsl
    923.8 KB · Views: 88
  • DSDT_patched.dsl
    921.5 KB · Views: 61
  • SSDT-DiscreteSpoof.aml
    132 bytes · Views: 68

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,691
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi Rehab,
I have tried a year ago to disable discrete graphics in dual-GPU:

- Toshiba Satellite Pro L50-A531
- intel core i7-4700MQ Haswell architecture
- Intel HD 4600
- Nvidia Geforce 740M (integrated NOT disabled)
- Sierra 10.12.6
- Everything is working (sleep, wake, wifi, HDMI, sound, brightness)

You tried to help me (thank you sooo much) I followed the guide and your advice but I failed then gave up.
Until I decided to upgrade to High Sierra and ran to "Window Server Service only ran for 0 seconds"
Read your guide https://www.tonymacx86.com/threads/...-only-ran-for-0-seconds-with-dual-gpu.233092/

- my _OFF is in DSDT only and no _INI
- I added _INI under _OFF
- Deleted Spin and relocated spin to _REG
- Created Discretespoof SSDT


Still my NVIDIA is not disabled.

Could you please take a look at my DSDT and help me disable discrete graphics in dual-GPU.



"Problem Reporting" files are incomplete.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Feb 16, 2016
Messages
22
Motherboard
Haswell Toshiba Satellite Pro
CPU
i7-4700MQ
Graphics
HD4600
Mobile Phone
  1. iOS

Attachments

  • debug_9163.zip
    2.7 MB · Views: 46
  • CLOVER.zip
    2.8 MB · Views: 38
  • iMac.ioreg
    3.9 MB · Views: 61

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,691
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Sorry,

I hope the attachments are complete ... thanks

You forgot to press F4 (files from ACPI/origin are from Jan 26... today is Feb 8).
Please read "Problem Reporting" again. Carefully.
 
Top