Contribute
Register

[Guide] Dell XPS 9560 Monterey OpenCore

Joined
Jan 7, 2022
Messages
2
Motherboard
XPS 15-9560
CPU
i7-7700HQ
Graphics
Intel HD 630
Ah you know what, I think it is dead. I don't know why checking bluetooth didn't occur to me but I just checked and that does work... So yeah it is probably dead. Fun... Thanks for the tip though!
 
Joined
Jul 23, 2017
Messages
2
Motherboard
asrock
CPU
i7
Graphics
rx580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Ciao!
i've a big problem.
after following your guide i created the boot usb and the efi partition, but when i chose 'Instal...' the system require internet connection to complete. is it normal?my wificard is incompatible and i Know, but For full install, not recovery, i dont know

ty
 
Joined
Jan 31, 2022
Messages
3
Motherboard
Dell XPS 9560 - YH90J
CPU
i7-7700HQ / HM170
Graphics
IHD 630, GTX 1050, 1920x1080
Hello.
I've got a problem and maybe have a solution for it (at least maybe someone can figure it out).
I have plugged my XPS to external monitor via hdmi. My laptop monitor is 1920x1080x60hz just like my hdmi monitor. There is no problems until i've start two virtual machines. Memory pressure rise up (not that much actually, but swap started to rise) and macOS kick me out of session and i need to log in again. After that i check crash logs and find out that WindowServer is crashed.
I've googled it and found this issue on github. Yes i've had that "enable-hdmi20" enabled as it is in latest EFI folder from here (v 1.1). Looks like it has been deprecated for "max-pixel-clock" feature. I will try to disable "enable-hdmi20" and write here if i had a crash again.
I hope i help someone figure it out.
 
Joined
May 15, 2021
Messages
1
Motherboard
a
CPU
s
Graphics
d
Can FakePCIID.kext be removed from the kexts folder, if I only want to use Mac OS monterey?

And thx for bringing @blazinsmokey build back to life :) I will try it, on Tuesday.
I have updraged BigSur to Monterey on Dell XPS 9650
I have tried with your setup but no luck,
its weird because I have the same hardware,
I hope you can find what is wrong, because I can't

my xps:
Dell XPS 15 9560 (i7-7700HQ, FHD) (XPS 15 9560 Series)
Processor -Intel Core i7-7700HQ 4 x 2.8 - 3.8 GHz, Kaby Lake
Graphics adapter -NVIDIA GeForce GTX 1050 Mobile - 4096 MB, Core: 1354 MHz, Memory: 7008 MHz, GDDR5, 373.06, Optimus
Memory -32GB , 1300 MHz, Dual-Channel, 17-17-17-39, 2x SODIMM
Display -15.60 inch 16:9, 1920 x 1080 pixel 141 PPI, IPS
Mainboard -Intel HM175
Networking -Dell DW1560 (Broadcom BCM94352Z M.2) Broadcom 802.11ac Network Adapter #2
Battery -97 Wh Lithium-Ion
Disk - Model KXG50ZNV1T02 NVMe TOSHIBA 1024GB
Connections -2 USB 3.0 / 3.1 Gen1, 1 USB 3.1 Gen2, 1 Thunderbolt, 1 HDMI, 1 DisplayPort, 1 Kensington Lock, Audio Connections: 3.5mm combo, Card Reader: SD, Brightness Sensor
CameraWebcam: HD 720p
BIOS Version/Date Dell Inc. 1.23.1, 5/25/2021

thank you in advance
Y
I have upgraded from BigSur to Monterey on my Dell XPS 9560 with almost the same profile above.
I have Intel HD 630 GPU.
Everything works but graphic card is not working. I could not find a proper solution on internet. Since this is the specific guide for a Dell Laptop, someone or the owner of this post can help me to resolve the issue.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,427
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I have updraged BigSur to Monterey on Dell XPS 9650

I have upgraded from BigSur to Monterey on my Dell XPS 9560 with almost the same profile above.
I have Intel HD 630 GPU.
Everything works but graphic card is not working. I could not find a proper solution on internet. Since this is the specific guide for a Dell Laptop, someone or the owner of this post can help me to resolve the issue.
As per rules, please update your hardware profile to allow others to help you easier

please read the faq for proper hardware profile setup:
 
Joined
Jul 25, 2013
Messages
419
Motherboard
Asus X99 Deluxe
CPU
E5-2697v3
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. Xserve
Mobile Phone
  1. Android
  2. iOS
For those who update their OpenCore regularly, you are free and clear to upgrade to OC 0.7.8 and to update your kexts. I will likely handle releases as major fixes are released - updating and maintaining your own EFI is a good skill to have. I expect to update the EFI release when 12.3 is made public with Universal Control.
 
Joined
Feb 5, 2022
Messages
13
Motherboard
Gigabyte z390 I aorus pro wifi
CPU
i5 8500
Graphics
UHD 630
I have recently purchased a 9560 4k Model with i7 7700HQ and 32GB of ram. I have made a full offline installer using the full Mac OS Monterey image downloaded from my Gigabyte z390 Hackintosh. Unfortunately I won't be able to replace the wifi card for 1-2 weeks, will it boot with the Killer Wireless card removed or disabled and the laptop connected through ethernet or usb tether? Will be 1-2 weeks before I can switch to DW1560 or DW1830
 
Joined
Jul 25, 2013
Messages
419
Motherboard
Asus X99 Deluxe
CPU
E5-2697v3
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. Xserve
Mobile Phone
  1. Android
  2. iOS
will it boot with the Killer Wireless card removed or disabled and the laptop connected through ethernet or usb tether? Will be 1-2 weeks before I can switch to DW1560 or DW1830
I've not personally booted this machine without my DW1560 installed, but at the very least, it should be fine with the Killer removed and may even work with it installed, though, obviously, the Killer card won't function.

USB -> Ethernet or Type-C to Ethernet should work fine until your card comes in, and though I haven't tried it personally, USB tether should work too.
 
Joined
Feb 5, 2022
Messages
13
Motherboard
Gigabyte z390 I aorus pro wifi
CPU
i5 8500
Graphics
UHD 630
I've not personally booted this machine without my DW1560 installed, but at the very least, it should be fine with the Killer removed and may even work with it installed, though, obviously, the Killer card won't function.

USB -> Ethernet or Type-C to Ethernet should work fine until your card comes in, and though I haven't tried it personally, USB tether should work too.
Final Edit- I am now all the way installed using usb tethering from my iPhone mavericks 12.2.1. I had to add Nullethernet.kext and ssdt-rmne.aml to the EFI but once I did that I was able to login to my iCloud account and iMessage. Thanks!
 
Last edited:
Joined
Feb 5, 2022
Messages
13
Motherboard
Gigabyte z390 I aorus pro wifi
CPU
i5 8500
Graphics
UHD 630
Final Edit- I am now all the way installed using usb tethering from my iPhone mavericks 12.2.1. I had to add Nullethernet.kext and ssdt-rmne.aml to the EFI but once I did that I was able to login to my iCloud account and iMessage. Thanks!
Updated to 0.7.9 today without issue.
 
Top