Contribute
Register

[Guide] Dell XPS 9560 Monterey OpenCore

Joined
Jul 25, 2013
Messages
418
Motherboard
Asus X99 Deluxe
CPU
E5-2697v3
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. Xserve
Mobile Phone
  1. Android
  2. iOS
Release and Updates
  • Release Dec 12, 2021 XPS 9560 v1.1 - OC 0.7.6
    • Add 1080p Support
      • Added @jstash Device-Properties in new config_1080p.plist
    • Add @blazinsmokey's fix for HDMI Audio
      • Remove FakePCIID - deprecated
    • Add FeatureUnlock.kext 1.0.4
    • Update to latest Lilu / VirtualSMC / WhateverGreen

Good morning all - sorry for the delay in this update. See above for the notable changes in this zip, and as always, thanks to everyone for your testing and input. With all of your help, I've added a new config_1080p.plist to accommodate those with 1080p screens. I am unable to test this setup, so please report back and we can adapt it accordingly.

Additionally, we've deprecated FakePCIID for HDMI audio with an updated device property and added FeatureUnlock.kext for Sidecar, AirPlay to Mac, etc.

Again, thanks to everyone for your input and testing.
 

Attachments

  • XPS 9560 v1.1 - OC 0.7.6.zip
    16.4 MB · Views: 771
Joined
Jan 10, 2015
Messages
20
Motherboard
Dell XPS 15 9560
CPU
i7-7700HQ
Graphics
HD630 / GTX1050 (1920x1080)
Mac
  1. MacBook Pro
Release and Updates
  • Release Dec 12, 2021 XPS 9560 v1.1 - OC 0.7.6
    • Add 1080p Support
      • Added @jstash Device-Properties in new config_1080p.plist
    • Add @blazinsmokey's fix for HDMI Audio
      • Remove FakePCIID - deprecated
    • Add FeatureUnlock.kext 1.0.4
    • Update to latest Lilu / VirtualSMC / WhateverGreen

Good morning all - sorry for the delay in this update. See above for the notable changes in this zip, and as always, thanks to everyone for your testing and input. With all of your help, I've added a new config_1080p.plist to accommodate those with 1080p screens. I am unable to test this setup, so please report back and we can adapt it accordingly.

Additionally, we've deprecated FakePCIID for HDMI audio with an updated device property and added FeatureUnlock.kext for Sidecar, AirPlay to Mac, etc.

Again, thanks to everyone for your input and testing.
For the 1080p config.plist, the UIScale should be corrected to <01>. Otherwise, it works great!
 
Joined
Dec 18, 2021
Messages
4
Motherboard
XPS 15, 9560
CPU
i7 << need model # >> See Forum Rules !!
Graphics
630
Can you provide me with ur EFI, please? As I have the 1080p and I'm using the wireless killer card for 9560 and it's not working...
I want also to learn how to do it later on, how to modify things and make things work...
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,390
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Can you provide me with ur EFI, please? As I have the 1080p and I'm using the wireless killer card for 9560 and it's not working...
I want also to learn how to do it later on, how to modify things and make things work...
read post 1
 
Joined
Dec 18, 2021
Messages
4
Motherboard
XPS 15, 9560
CPU
i7 << need model # >> See Forum Rules !!
Graphics
630
Thanks, @Feartech Appreciated it.

Working perfectly fine after editing the UIScale to <01> as I'm using 1080p hardware.

QQ:

Based on my UFI, the wifi is not working... I've added USBPorts.kext + SSDT-USBP.aml but still not working :(

Not sure what's the issue, I have killer wifi ac1535 wireless network card... Didn't make any changes, yet can't make it work.

Can you view please my UFI and let me know where did I miss?
 

Attachments

  • Updated OC 0.7.6 modfied.zip
    16.2 MB · Views: 84
Joined
Jul 25, 2013
Messages
418
Motherboard
Asus X99 Deluxe
CPU
E5-2697v3
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. Xserve
Mobile Phone
  1. Android
  2. iOS
Based on my UFI, the wifi is not working... I've added USBPorts.kext + SSDT-USBP.aml but still not working :(

Not sure what's the issue, I have killer wifi ac1535 wireless network card... Didn't make any changes, yet can't make it work.

Can you view please my UFI and let me know where did I miss?

Killer Wireless not supported. Remove your WiFi card and replace with a supported model. Unsure why you are toggling USB Port definitions in hope of wireless - this will not help in this scenario. Only solution is to replace, I'm afraid.

For others - update to macOS 12.1 went smoothly, feel free to update.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,390
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thanks, @Feartech Appreciated it.

Working perfectly fine after editing the UIScale to <01> as I'm using 1080p hardware.

QQ:

Based on my UFI, the wifi is not working... I've added USBPorts.kext + SSDT-USBP.aml but still not working :(

Not sure what's the issue, I have killer wifi ac1535 wireless network card... Didn't make any changes, yet can't make it work.

Can you view please my UFI and let me know where did I miss?
best choice if your laptop supports it is a BCM94360NG, no kexts required, works great
 
Joined
Dec 18, 2021
Messages
4
Motherboard
XPS 15, 9560
CPU
i7 << need model # >> See Forum Rules !!
Graphics
630
Both Dell BCM94352Z/BCM94360NG is not available in Egypt... and it's too expensive to buy from Amazon. Will go to the computer mall tomorrow to check with the technical guys there.
Thanks, @Feartech & @InsaneCultist for your reply and support.
 
Joined
Dec 18, 2021
Messages
4
Motherboard
XPS 15, 9560
CPU
i7 << need model # >> See Forum Rules !!
Graphics
630
QQ,
I know I'm a new/noob to this... but it shows Intel HD Graphics 630 4095 MB.
Is that something good or bad?
 

Attachments

  • Screenshot 2021-12-19 at 3.16.47 AM.png
    Screenshot 2021-12-19 at 3.16.47 AM.png
    584.6 KB · Views: 99
Joined
Dec 19, 2021
Messages
4
Motherboard
XPS15-9560
CPU
i7-7700HQ
Graphics
Intel HD 630
Hi all, First post, so please be gentle...
I managed to get Monterey installed, on my XPS15-9560; Thank you this helped SO much! But I only seem to get 1080p display, when I have a 4k screen... I'm sure I've missed a step... but I can't seem to spot what I've done wrong... any help?
 
Top