Contribute
Register

[Guide] Dell XPS 9560 Monterey OpenCore

Joined
Oct 15, 2015
Messages
27
Motherboard
Dell 5490
CPU
i7-8650U
Graphics
HD 620
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
How do you make Universal Control work with the DW1560? I have a Dell 5490 (Intel 8th Gen + UHD620) with a DW1560 and it even let me do it with the ipad connected through the cable. Sidecar only work thetered as well (via wifi the computer gives me a time out error.

Thanks.
 
Joined
Sep 15, 2013
Messages
44
Motherboard
<< need non-Apple model # >> See Forum Rules !!
CPU
<< need model # >> See Forum Rules !!
Graphics
HD 630
Mac
  1. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. Android
  2. iOS
I been trying to upgrade to Ventura since beta 1 and nothing but errors and blackscreen....can't get past boot. the real version just got released, can this notebook even be upgraded to Ventura? Anybody have any luck at all?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,407
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I been trying to upgrade to Ventura since beta 1 and nothing but errors and blackscreen....can't get past boot. the real version just got released, can this notebook even be upgraded to Ventura? Anybody have any luck at all?
please read the faq for proper hardware profile setup:
 
Joined
Jul 15, 2019
Messages
27
Motherboard
Dell XPS 9560
CPU
i7-7700HQ
Graphics
GTX 1050/HD 630
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Updated OC to 0.8.5 and upgraded to Ventura.
The update itself went fine and BT/WiFi/touchpad/brightness keys etc... all seem to function as usual.

Getting a kernal panic whenever trying to shut down though. Need to look into it more I see a crash log in Console regarding Bluetooth and a crash report after the panic restart, which Google directs to a thread regarding the voodooI2C kexts. Edit: turns out that VoodooI2CHID is the culprit - see post on the next page of this thread.

Ran out of time today, so that'll be a job for tomorrow.
 
Last edited:
Joined
Jan 10, 2015
Messages
20
Motherboard
Dell XPS 15 9560
CPU
i7-7700HQ
Graphics
HD630 / GTX1050 (1920x1080)
Mac
  1. MacBook Pro
I been trying to upgrade to Ventura since beta 1 and nothing but errors and blackscreen....can't get past boot. the real version just got released, can this notebook even be upgraded to Ventura? Anybody have any luck at all?
The best way is to update your EFI using OCAuxiliaryTools to any OC version later than 0.8.3. Make sure to update the KEXTS as well as the OC and Boot folders in the EFI using the tool. I am running Ventura 13.1 (beta) with no issues.
 
Joined
Jul 15, 2019
Messages
27
Motherboard
Dell XPS 9560
CPU
i7-7700HQ
Graphics
GTX 1050/HD 630
Mac
  1. MacBook Air
Mobile Phone
  1. Android
The best way is to update your EFI using OCAuxiliaryTools to any OC version later than 0.8.3. Make sure to update the KEXTS as well as the OC and Boot folders in the EFI using the tool. I am running Ventura 13.1 (beta) with no issues.
If you don't mind, could you please share your config.plist? (Feel free to scrub out the serial etc...)

Still having issues with the shutdown/restart panic and although I double checked my config, I'm wondering if there's something I missed. My EFI folder was working fine in Monterey before the upgrade to Ventura.

Since you seem to be having no issues, I thought I'd ask so I can compare. Would really appreciate it. :)
 
Joined
Jan 10, 2015
Messages
20
Motherboard
Dell XPS 15 9560
CPU
i7-7700HQ
Graphics
HD630 / GTX1050 (1920x1080)
Mac
  1. MacBook Pro
If you don't mind, could you please share your config.plist? (Feel free to scrub out the serial etc...)

Still having issues with the shutdown/restart panic and although I double checked my config, I'm wondering if there's something I missed. My EFI folder was working fine in Monterey before the upgrade to Ventura.

Since you seem to be having no issues, I thought I'd ask so I can compare. Would really appreciate it. :)
Sharing my config.plist would be problematic because there will be differences depending on which OC version and whether you are using 1080 or 4K display. Make sure you use OCAuxiliaryTools to check you config.plist and it matches the requirements for the OC version you are using. I am using OC 0.8.6 (dev) version.
 
Joined
Jul 15, 2019
Messages
27
Motherboard
Dell XPS 9560
CPU
i7-7700HQ
Graphics
GTX 1050/HD 630
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Sharing my config.plist would be problematic because there will be differences depending on which OC version and whether you are using 1080 or 4K display. Make sure you use OCAuxiliaryTools to check you config.plist and it matches the requirements for the OC version you are using. I am using OC 0.8.6 (dev) version.
I have the 4k display but I'm aware of the changes between the 1080p and 4k configs so I'm not sure if it's really a huge issue.

I did use OCAT - no errors detected on 0.8.5. I'll try with 0.8.6 dev and see if there's any improvement.
 
Last edited:
Joined
Jan 10, 2015
Messages
20
Motherboard
Dell XPS 15 9560
CPU
i7-7700HQ
Graphics
HD630 / GTX1050 (1920x1080)
Mac
  1. MacBook Pro
I have the 4k display but I'm aware of the changes between the 1080p and 4k configs so I'm not sure if it's really a huge issue.

I did use OCAT - no errors detected on 0.8.5. I'll try with 0.8.6 dev and see if there's any improvement.
My 9560 has the 1080p display.
 
Joined
Sep 15, 2013
Messages
44
Motherboard
<< need non-Apple model # >> See Forum Rules !!
CPU
<< need model # >> See Forum Rules !!
Graphics
HD 630
Mac
  1. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. Android
  2. iOS
ty for the reply, ill take that advice and update my OC to the latest and use OCAuxiliaryTools.
 
Top