Contribute
Register

[Guide] Dell XPS 9560 Mojave VirtualSMC, I2C Trackpad, Clover UEFI Hotpatch

Status
Not open for further replies.
Joined
Jul 21, 2019
Messages
43
Motherboard
Dell XPS 15
CPU
i7 7700HQ
Graphics
UHD 630 - GTX 1050 (Not recognized by MACOSX)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
OK was able to finally get into the OS with the help of LeLunZ's help with his clover. Still having some boot issues. My system bypasses Clover boot and goes straight to Windows. I copied over the clover from the boot usb but still nothing...Thoughts?
 
Joined
Nov 9, 2018
Messages
72
Motherboard
Dell XPS 9560 - YH90J
CPU
I7-7700HQ
Graphics
GTX 1050, HD 630
OK was able to finally get into the OS with the help of LeLunZ's help with his clover. Still having some boot issues. My system bypasses Clover boot and goes straight to Windows. I copied over the clover from the boot usb but still nothing...Thoughts?

Just delete Or place Windows from your boot sequenze in the bios (after the clover config). And add the right clover Efi file.
 
Joined
Sep 25, 2018
Messages
10
Motherboard
Dell XPS 9350
CPU
i7-6560U
Graphics
Iris 540
Mobile Phone
  1. Other
After update to Catalina, my Darkintosh lost the camera and bluetooth. Anyone faced with that problems too?
 
Joined
Nov 9, 2018
Messages
72
Motherboard
Dell XPS 9560 - YH90J
CPU
I7-7700HQ
Graphics
GTX 1050, HD 630
After update to Catalina, my Darkintosh lost the camera and bluetooth. Anyone faced with that problems too?
Yeah, we have a discussion about Bluetooth already. Check page 71.
there you can find a Link with a new way^^

and i need to check my camera, will report back.
 
Joined
Nov 9, 2018
Messages
72
Motherboard
Dell XPS 9560 - YH90J
CPU
I7-7700HQ
Graphics
GTX 1050, HD 630
Joined
Jul 21, 2019
Messages
43
Motherboard
Dell XPS 15
CPU
i7 7700HQ
Graphics
UHD 630 - GTX 1050 (Not recognized by MACOSX)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
So just got everything up and running and its working great on Catalina. Thanks LeLunz for the assist. I do have 1 minor minor thing, and its more cosmetic than anything else. on my clover screen the actual wallpaper is very tiny :) any way to make it take up the whole screen? i added a photo so you can see what i am talking about
913DD345-19F8-49BF-A30B-79AE006FDFC3_1_105_c.jpeg
 
Joined
Nov 9, 2018
Messages
72
Motherboard
Dell XPS 9560 - YH90J
CPU
I7-7700HQ
Graphics
GTX 1050, HD 630
So just got everything up and running and its working great on Catalina. Thanks LeLunz for the assist. I do have 1 minor minor thing, and its more cosmetic than anything else. on my clover screen the actual wallpaper is very tiny :) any way to make it take up the whole screen? i added a photo so you can see what i am talking about View attachment 429540
Do you have the 4k Version?

Just open config.plist from Clover folder and try to remove the whole dict with the key BootGraphics!
And then try again. Or play with these settings if it doesn't work?
 
Joined
Dec 27, 2012
Messages
103
Motherboard
Dell XPS 9560 FHD
CPU
i7-7700HQ
Graphics
HD 630
Mac
  1. MacBook
Mobile Phone
  1. iOS
I am using all 3 kexts and its working pretty well.
Are you sure that you can connect to devices with your bluetooth setup?


EDIT:
Like noted in a post before. There is a new fork of RehabMan's BRCMPatchRam.

Sorry you are perfectly right, all the 3 kext need to be installed in EFI/CLOVER/Kext/Other since Catalina.
 
Joined
Sep 25, 2018
Messages
10
Motherboard
Dell XPS 9350
CPU
i7-6560U
Graphics
Iris 540
Mobile Phone
  1. Other
Yeah, we have a discussion about Bluetooth already. Check page 71.
there you can find a Link with a new way^^

and i need to check my camera, will report back.

Could you please describe your doing steps?

I tried but neither place those 3 kexts to EFI/CLOVER/kexts/Other nor install to L/E using kextbeast solve the problem,
Firmware Version still v14 c4096 in system report.
 
Joined
May 20, 2018
Messages
83
Motherboard
Dell XPS-15 9560-Clover
CPU
i7-7700HQ / HM175
Graphics
HD 630 / 3840 x 2160
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
EMERGENCY. No idea what to do. Didn’t install the kexts properly and now it fails to load VoodooI2CHIdevice. Can’t boot into the machine anywhere in any way.
 

Attachments

  • 5BF66D0C-51DD-4C32-8320-318103A0F7E3.jpeg
    5BF66D0C-51DD-4C32-8320-318103A0F7E3.jpeg
    163.2 KB · Views: 31
Status
Not open for further replies.
Top