Contribute
Register

[Guide] Dell XPS 9560 Mojave VirtualSMC, I2C Trackpad, Clover UEFI Hotpatch

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,806
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Alright Ladies

I'm sharing my entire Bootable Disk. To help anyone trying to pinpoint why it's working from memory I have done the following but I also did many other things and reversed many others - (for me my dock worked first go so I did not ask any questions)

Configuration:
XPS 9560, 4k, i7, 32GB RAM, 1TB HD, 97Wh battery, MCB14,1 Configuration, Vents taped, Vrams padded - Undervolt GPU -100mv, Undervolt Processor -135mv - Battery performance shithouse at 5 hours maximum (which is still better than windows for some reason, i gave up)

Dual Boot Windows 10 - In windows 10 Speedshift is enabled, custom GPU frequency curve via Afterburner undervolt as above with Turbo Clocks limits disabled and locked, All core boost at 3.8gHz - I get 6000 in 3Dmark Firefight (whatever it's called) benchmark

thunderbolt drivers from intel installed via intel driver updater I have thunderbolt icon in my windows 10 tray when a thunderbolt device is connected

all updates were run in windows prior to the connection of the dock - in windows. Restarted into windows multiple times

Cleaned NvRam like 4 times after

Then ran mac os and installed SwitchResX and configured everything to work. Everything works including coming back from sleep. However it does it's screen turn-off, turn-on, turn-off dance for 20 seconds before being usable. Good Enough

Oh right my folder. Here. If someone can share how they got iCloud to work without Ethernet I would appreciate it very much. Like seriously would go a long way

please us site attachments

also only the clover folder should only be needed

You need to have your hardware profile filled out as per rules (the ones you agreed to when signing up here)

please read the faq for proper hardware profile setup:
 
Joined
Oct 8, 2018
Messages
36
Motherboard
Gigabite X570 AorusPro WiFi
CPU
Ryzen 3900x OC 4.5gHz
Graphics
RedDevil 6900xt
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
please us site attachments

also only the clover folder should only be needed

You need to have your hardware profile filled out as per rules (the ones you agreed to when signing up here)

please read the faq for proper hardware profile setup:

Sorry matey, I agreed to them and read them like I read iTunes User Agreement statement or 'Mein Kampf'

I've fixed me' hardware profile
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,806
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Sorry matey, I agreed to them and read them like I read iTunes User Agreement statement or 'Mein Kampf'

I've fixed me' hardware profile
don't forget to edit your post and use site attachments. thanks :)
 
Joined
Sep 11, 2019
Messages
2
Motherboard
Dell XPS 9560
CPU
i5 7300HQ
Graphics
HD 630
Hey does anyone else get stability issues or is that just me? Like for some reason when I use chrome and photoshop at the same time or even do an itunes backup on my iPhone, the system just crashes and I can't click on anything. Is it because I didn't fake my 7300HQ properly? Like I just copied the kext folder over from the download and it shows as an i5 on my hackintosh. Thank you!
 
Joined
Jul 8, 2016
Messages
6
Motherboard
Dell Precision 5520
CPU
i7-7820
Graphics
HD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Dual 4k @60hz each confirmed to work over TB16 Dock Station using DisplayPort and MiniDisplay Port cables. This is both for MacOS and Windows. If anyone wants to use the dock in that configuration is perfect. Make sure you update all Bios, drivers etc... in Windows before trying to get the dock to work!

Did you manage to get TB16's ethernet / usb working?
 
Joined
Oct 8, 2018
Messages
36
Motherboard
Gigabite X570 AorusPro WiFi
CPU
Ryzen 3900x OC 4.5gHz
Graphics
RedDevil 6900xt
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Did you manage to get TB16's ethernet / usb working?

Sadly no USB A no USB C. My Samsung T5 is not recognised over USB-C. I have a mechanical keyboard and even it won't work through the USB A in the dock. Phone wont even charge through one of the "powered" ports

It does however work in windows, so it's not a faulty product

My next laptop is likely to be an Apple one. As much fun as this was, dedicated graphics acceleration is now becoming very important and for some reason there are no Windows laptops with AMD graphics cards out there

What we have is an overpowered macbook air with an amazing screen, a shitty battery, slow USB ports, poor quality control and amazing technical support from Dell. Also a crippled two lane thunderbolt connection which I'm a little salty about. Still; it taught me a lot and it was fun at times
 
Joined
Dec 20, 2018
Messages
741
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
Joined
Nov 9, 2018
Messages
69
Motherboard
Dell XPS 9560 - YH90J
CPU
I7-7700HQ
Graphics
GTX 1050, HD 630
Sadly no USB A no USB C. My Samsung T5 is not recognised over USB-C. I have a mechanical keyboard and even it won't work through the USB A in the dock. Phone wont even charge through one of the "powered" ports

It does however work in windows, so it's not a faulty product

My next laptop is likely to be an Apple one. As much fun as this was, dedicated graphics acceleration is now becoming very important and for some reason there are no Windows laptops with AMD graphics cards out there

What we have is an overpowered macbook air with an amazing screen, a shitty battery, slow USB ports, poor quality control and amazing technical support from Dell. Also a crippled two lane thunderbolt connection which I'm a little salty about. Still; it taught me a lot and it was fun at times

i understand your feelings :p
But why a shitty battery? The 97 whr are more than enough.
my Wlan and Bluetooth are currently broken (DW 1830, ordered a 1560 today) and the Bluetooth can’t be turn off. it somehow uses energy all the time.
so I get to 6-7 Hours of batterylife.

if I take out my Wireless Card it’s increasing 40-60 minutes.

and i checked my battery level.

currently my Battery has only less then 75 percent of its original power.
soo it’s Kind of Good :)

And what do you mean with slow USB ports? :3
 
Joined
Dec 20, 2018
Messages
741
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
i understand your feelings :p
But why a shitty battery? The 97 whr are more than enough.
my Wlan and Bluetooth are currently broken (DW 1830, ordered a 1560 today) and the Bluetooth can’t be turn off. it somehow uses energy all the time.
so I get to 6-7 Hours of batterylife.

if I take out my Wireless Card it’s increasing 40-60 minutes.

and i checked my battery level.

currently my Battery has only less then 75 percent of its original power.
soo it’s Kind of Good :)

And what do you mean with slow USB ports? :3
did you try masking pin 54 and 55 on the dw1830? sounds like the issue I was having with dw1830. maybe try masking the Wifi/ bluetooth disable lines
 
Joined
Oct 8, 2018
Messages
36
Motherboard
Gigabite X570 AorusPro WiFi
CPU
Ryzen 3900x OC 4.5gHz
Graphics
RedDevil 6900xt
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
i understand your feelings :p
But why a shitty battery? The 97 whr are more than enough.
my Wlan and Bluetooth are currently broken (DW 1830, ordered a 1560 today) and the Bluetooth can’t be turn off. it somehow uses energy all the time.
so I get to 6-7 Hours of batterylife.

if I take out my Wireless Card it’s increasing 40-60 minutes.

and i checked my battery level.

currently my Battery has only less then 75 percent of its original power.
soo it’s Kind of Good :)

And what do you mean with slow USB ports? :3

I dont know aye. I have gone through ridiculous lengths of dimming the screen so it's almost impossible to see; disabling bluetooth and undervolting the GPU and CPU at the lowest settings anyone really has and I still get at absolute best 6hrs. Usually around 3 hrs if I use it as if it was plugged in

It's not much better in windows. Yet my battery is showing 83% and 'excellent' condition

I have the DW1560 here: https://www.ebay.com.au/itm/Broadcom-BCM94352Z-DW1560-NGFF-802-11AC-Wifi-Bluetooth-4-0-For-Mac-Hackintosh/182313496812?ssPageName=STRK:MEBIDX:IT&_trksid=p2057872.m2749.l2649 do you think this is culprit?

Over USB C I only get upload and download rates of 50mb/second instead of 350mb/second I do in windows

Have I mentioned how salty I am over crippled two lane Thunderbolt port?
 
Top