Contribute
Register

[Guide] Dell XPS 9560 Mojave VirtualSMC, I2C Trackpad, Clover UEFI Hotpatch

Joined
Jul 15, 2019
Messages
11
Motherboard
Dell XPS 9560
CPU
i7-7700HQ
Graphics
GTX 1050/HD 630
Mac
MacBook Air
Mobile Phone
Android
Thanks again sir, got FV2 working with your help. Only issue that I'm facing is that the trackpad isn't working at the Preboot FileVault screen. Other than that, fully functioning. :thumbup:
Sorry for the late reply! I am glad that you were able to enable FV. The trackpad works fine for me in the preboot Filevault screen. The cursor is a little bit 'jumpy' but it certainly works. I am not fully sure what to suggest but for sure the touchpad is able to work.
 
Joined
Feb 25, 2012
Messages
300
Motherboard
GA-Z370N-WIFI
CPU
i5-8600K
Graphics
RX 460
Mac
MacBook Pro, Mac mini
Mobile Phone
Android, iOS
When I try to install Combo Jack I get Permission Denied.
Chmod doesn't help (and doesn't give error either)
I have @ symbol in the end of permissions of each file in the folder
When I create new file and chmod it to 755 it doesn't have that @ symbol and runs fine

1565720991368.png


I can still run install.sh with bash install.sh, but ComboJack won't launch since it keeps these broken permissions on installed files

I've tested it on two XPS 9560 laptops (Mojave) and both have same problem
I've tested it on MacBook (Mojave) and even with @ install.sh runs fine
Anyone has any clue what's going on?
 
Joined
Jul 25, 2013
Messages
370
Motherboard
Asus X99 Deluxe / U3.1
CPU
i7-5820K
Graphics
RX 580
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac Pro
Classic Mac
iMac, Power Mac, Xserve
Mobile Phone
Android, iOS
When I try to install Combo Jack I get Permission Denied.
Chmod doesn't help (and doesn't give error either)
I have @ symbol in the end of permissions of each file in the folder
When I create new file and chmod it to 755 it doesn't have that @ symbol and runs fine

View attachment 421664

I can still run install.sh with bash install.sh, but ComboJack won't launch since it keeps these broken permissions on installed files

I've tested it on two XPS 9560 laptops (Mojave) and both have same problem
I've tested it on MacBook (Mojave) and even with @ install.sh runs fine
Anyone has any clue what's going on?
Is your VerbStub.kext already injected with Clover? VerbStub.kext must be detected for script to run. You should simply be able to chmod +x the install.sh script and run as root. Have you tried using the ./install.sh flag? This marks to the bash session that the install.sh command is already compiled and executes it.
 
Joined
Feb 25, 2012
Messages
300
Motherboard
GA-Z370N-WIFI
CPU
i5-8600K
Graphics
RX 460
Mac
MacBook Pro, Mac mini
Mobile Phone
Android, iOS
VerbStub.kext must be detected for script to run.
Which script? install.sh?

You should simply be able to chmod +x the install.sh script and run as root.
Yes, I should, but that's not what is happening, that's why I wrote about it :)

Have you tried using the ./install.sh flag
Yes, I used correct path, or else file wouldn't run after fixing permissions

This marks to the bash session that the install.sh command is already compiled and executes it.
Waaat? -=8-[o]
 
Last edited:
Joined
Feb 25, 2012
Messages
300
Motherboard
GA-Z370N-WIFI
CPU
i5-8600K
Graphics
RX 460
Mac
MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Chmod doesn't help (and doesn't give error either)
I have @ symbol in the end of permissions of each file in the folder
Ok got it solved. @ stands for extended attributes which can be checked with xattr <file>
Attribute that produces permission denied is com.apple.quarantine, which macOS adds to downloaded files to prevent malware from running without user confirmation on first run.
Running xattr -d com.apple.quarantine * in ComboJack Installer installer folder got installer and Combo Jack working
P.S. I still wonder
1. How did I have it running before without going through this?
2. How can MacBook (Mojave 10.14.6) have install.sh running without com.apple.quarantine removal?
1565768401268.png
 
Last edited:
Top