Contribute
Register

[Guide] Dell XPS 9560 Mojave VirtualSMC, I2C Trackpad, Clover UEFI Hotpatch

Status
Not open for further replies.
Joined
Jun 24, 2014
Messages
288
Motherboard
ASUS Maximus VII Hero
CPU
i7 4790k
Graphics
HD 4600 + GTX 970
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Thank you so much blazinsmokey for replying, it is greatly appreciated. So to answer your questions

Yes the Dock works fine in windows
I plug it in before i power on the laptop then turn on the power
I have followed the BIOS settings to a T on the link that you provided on the guide
The Dock is fully updated via Windows.

I . have included my boot.log from Clover if that helps? No mind you that boot.log is from when i am at home with no dock plugged in, not sure that matters.

Plug it in when you reach clover boot screen. Give it a second or so then boot into macOS.
 
Joined
Jul 21, 2019
Messages
43
Motherboard
Dell XPS 15
CPU
i7 7700HQ
Graphics
UHD 630 - GTX 1050 (Not recognized by MACOSX)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
So tried doing what you suggested. stopped clover screen from auto booting into MacOS, plugged in the dock waited 3 seconds then continued the boot process with Clover. Once system was fully up, tried plugging in a known good USB and it didnt recognize the USB :(

I've included the boot log file again after connecting the USB-C Dock. Going to double check all my settings again.
 

Attachments

  • bootlog.txt
    61.7 KB · Views: 69
Joined
Jul 21, 2019
Messages
43
Motherboard
Dell XPS 15
CPU
i7 7700HQ
Graphics
UHD 630 - GTX 1050 (Not recognized by MACOSX)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
**Update**

So it looks like i missed 2 settings in the BIOS (VERY VERY important ones :) ) the lightning Pre boot support and boot support turned OFF.....Now the dock recognised my Video outputs perfectly. I am still having a few issues but I am getting there. Here are the only issues i have :)

1. No USB working on the Dock (I can live with that as the laptop has USB's available, But would be nice if it worked)
2. Ethernet on Dock is seen on Network page as "USB 10/100/1000 LAN" and says cable unplugged when the cable is plugged in and shows activity (works fine in windows)

This has been a great learning experience for me. I am so thankful that there is a great community available to help when help is needed :) again you guys rock!!!!!
 
Joined
Jul 21, 2019
Messages
43
Motherboard
Dell XPS 15
CPU
i7 7700HQ
Graphics
UHD 630 - GTX 1050 (Not recognized by MACOSX)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
1 other question. The dell keyboard how do you get the command key? I’ve tried the windows key + C to copy but it doesn’t work. What is the dell keyboard keys to do a copy or paste?
 
Joined
Oct 8, 2018
Messages
36
Motherboard
Gigabite X570 AorusPro WiFi
CPU
Ryzen 3900x OC 4.5gHz
Graphics
RedDevil 6900xt
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Mine is ALT +


1 other question. The dell keyboard how do you get the command key? I’ve tried the windows key + C to copy but it doesn’t work. What is the dell keyboard keys to do a copy or paste?
 
Joined
Jul 25, 2019
Messages
12
Motherboard
Dell XPS 9560
CPU
i7-7700HQ
Graphics
HD Graphics 630
Can anyone share how their EFI folder is listed for FileVault with the new Clover version? Been at it for a few days that I have remembered the commands to unlock and decrypt the drive @_@
 
Joined
Jul 15, 2019
Messages
20
Motherboard
Dell XPS 9560
CPU
i7-7700HQ
Graphics
GTX 1050/HD 630
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Can anyone share how their EFI folder is listed for FileVault with the new Clover version? Been at it for a few days that I have remembered the commands to unlock and decrypt the drive @_@

What do you by 'listed'?

If I am understanding your question, then maybe the following screenshot will help. This is my own EFI folder, which I use to boot my Filevault drive every day.
 

Attachments

  • Screenshot 2019-08-05 at 18.06.34.png
    Screenshot 2019-08-05 at 18.06.34.png
    1,021.7 KB · Views: 68
Joined
Jul 25, 2019
Messages
12
Motherboard
Dell XPS 9560
CPU
i7-7700HQ
Graphics
HD Graphics 630
What do you by 'listed'?

If I am understanding your question, then maybe the following screenshot will help. This is my own EFI folder, which I use to boot my Filevault drive every day.

Sorry about that, I was tired and flustered at that time lol. This helps a ton, thanks!
 
Joined
Aug 6, 2019
Messages
6
Motherboard
Dell Xps 9560
CPU
i7-7700
Graphics
GTX 1050, Intel HD 630
Hi Guys,
Yesterday I successfully managed to install a hackintosh on my 9560. Its my first time and Im loving it.
I used another Clover to install the hackintosh and now I want to update to the V3.4 Clover mentioned in this post.

Im a newbie to hackintosh and it would be really helpful if someone can help me on how to update the kexts and others files provided in Clover V3.4 zip.

Any help is appreciated. Thank you.
 
Status
Not open for further replies.
Top