Contribute
Register

[Guide] Dell XPS 9560 Mojave VirtualSMC, I2C Trackpad, Clover UEFI Hotpatch

Status
Not open for further replies.
Joined
Jun 24, 2014
Messages
288
Motherboard
ASUS Maximus VII Hero
CPU
i7 4790k
Graphics
HD 4600 + GTX 970
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
NOTE for install with v3.4 you need to add HFSPlus.efi driver or you won't see the install partition. It isn't necessary for post install. Had another user confirm it from the other forum. Sorry about that guys.

Thank you sir, I didn't do the SSDTs. I'll get to that later tonight. Is it just a simple replace or is it much more if you don't mind me asking.

Yes, delete, copy and paste, acpi/patched, then pick your TB/USB-c ssdt of your choosing.
 
Joined
Jul 21, 2019
Messages
43
Motherboard
Dell XPS 15
CPU
i7 7700HQ
Graphics
UHD 630 - GTX 1050 (Not recognized by MACOSX)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
So i am now typing this on my Dell XPS Hackintosh :) after install my DW1560 card. My only issue is the Dell XPS TB15 dock. I have no clue how to get that to work, can anyone explain to me how to get that to work as a USB-C device?
 
Joined
Jul 21, 2019
Messages
43
Motherboard
Dell XPS 15
CPU
i7 7700HQ
Graphics
UHD 630 - GTX 1050 (Not recognized by MACOSX)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
THx that worked perfectly for the track pad. But still no love from the dock. Turns our i have a TB16 dock but i still cant get that thing to work:( its a little frustrating, that is the last piece i need and id be windows free!
 
Joined
Jul 15, 2019
Messages
20
Motherboard
Dell XPS 9560
CPU
i7-7700HQ
Graphics
GTX 1050/HD 630
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Hmmm, I can report success with the WD15/K17A dock - which uses USB-C and not TB.

@Libertov : Blazinsmokey proposes 3 different methods to implementing Thunderbolt and USB-C in his guide. Can you clarify which of these methods you are currently using?

To recap from the guide:

Code:
You can only use 1 of the 3 methods and each has it's quirks

When changing methods, you need to clear nvram possibly multiple times and also shutting down completely helps.

Method 1 (included default)
Using both SSDT-TB3-9560.aml and SSDT-TYPC-9560.aml
Basically a combination/cleanup both below, TB3 not tested or confirmed but USB-C works like PCI Express card

Method 2 (KNNSpeeds original method)
Using only SSDT-TYPC.aml
USB-C should work like a PCI Express card, Thunderbolt should work but no hot plug and system will crash if you unplug while still booted up. Thunderbolt needs to be plugged in at boot with devices on.

Method 3 (https://www.tonymacx86.com/threads/in-progress-ssdt-for-thunderbolt-3-hotplug.248784/)
Using only SSDT-TB3-V1.aml
It's Method 1 at the link.
Hot plug works one device at a time but 9560 users have reported it's flaky.
USB-C doesn't work at all.
 
Joined
Jul 21, 2019
Messages
43
Motherboard
Dell XPS 15
CPU
i7 7700HQ
Graphics
UHD 630 - GTX 1050 (Not recognized by MACOSX)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
So I wanted to use SSDT-TYPC.aml. I do not have the SSDT-TYPC-9560.aml in my Clover v3.4 Download i only had the SSDT-TYPC.aml file. I placed that in the Clover\ACPI\Patched DIR, but i am not sure what else i need to do to get it to work.

Do i have an older version of the file? Are there any steps that need to be done after placing the file in the patched dir?

Benni thank you for taking some time to help me :) it is greatly appreciated
 
Joined
Jun 24, 2014
Messages
288
Motherboard
ASUS Maximus VII Hero
CPU
i7 4790k
Graphics
HD 4600 + GTX 970
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
So I wanted to use SSDT-TYPC.aml. I do not have the SSDT-TYPC-9560.aml in my Clover v3.4 Download i only had the SSDT-TYPC.aml file. I placed that in the Clover\ACPI\Patched DIR, but i am not sure what else i need to do to get it to work.

Do i have an older version of the file? Are there any steps that need to be done after placing the file in the patched dir?

Benni thank you for taking some time to help me :) it is greatly appreciated
3.4 has the correct files and it is down to 2 methods now, my experimental method is not a good idea and there were TB issues.

After it's in the patched directory it should just work as long as there aren't any files conflicting and it's a clean install.

Does the dock work in Windows?
When are you plugging in your device to see if it works?
Have you update to latest BIOS and make sure your BIOS has correct TB settings as linked in the guide?
Have you updated Thunderbolt firmware using Windows? (this may help or it may not)
 
Joined
Jul 21, 2019
Messages
43
Motherboard
Dell XPS 15
CPU
i7 7700HQ
Graphics
UHD 630 - GTX 1050 (Not recognized by MACOSX)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thank you so much blazinsmokey for replying, it is greatly appreciated. So to answer your questions

Yes the Dock works fine in windows
I plug it in before i power on the laptop then turn on the power
I have followed the BIOS settings to a T on the link that you provided on the guide
The Dock is fully updated via Windows.

I . have included my boot.log from Clover if that helps? No mind you that boot.log is from when i am at home with no dock plugged in, not sure that matters.
 

Attachments

  • bootlog.txt
    61 KB · Views: 82
Status
Not open for further replies.
Top