Contribute
Register

[Guide] Dell XPS 9560 Mojave VirtualSMC, I2C Trackpad, Clover UEFI Hotpatch

Status
Not open for further replies.
Joined
Jun 24, 2014
Messages
287
Motherboard
ASUS Maximus VII Hero
CPU
i7 4790k
Graphics
HD 4600 + GTX 970
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Thx for your help.
In my case I needed to walk the long way:
Reinstalled Windows, updated BIOS and TB 3 firmware, clean installed Mojave and finally, after everything was back, I cloned my old system from my external backup back to the internal disk.
I don´t know why F11 or any other route i tried was not succsseful...

Without any TB3 SSDT, I couldn´t daisy chain my two devices, just the satellite connects.
I use now SSDT-TB3-V1 and both devices work great. I can unplug them without a system crash but hotplug doesn´t work reliable and when it works it just shows the Satellite device, not the Appollo...

I use 14.5 right now. In High Sierra 13.6 i had the trackpad working perfectly like a real apple track, the multi gestures like three finger drag are sadly gone in 14.5.
Any idea how I get it back?

Thanks for the info, I think I may revisit that SSDT and see what we can do about TYPE-C working with that SSDT.

If your config is like mine, fix track pad, rebuilding kext cache and permissions should do the trick.
 
Joined
Jun 4, 2017
Messages
112
Motherboard
Asus X299 WS SAGE
CPU
i9 10940x
Graphics
vega 64
Is anyone have success with three- and four-finger gestures ?
 
Joined
Oct 8, 2018
Messages
36
Motherboard
Gigabite X570 AorusPro WiFi
CPU
Ryzen 3900x OC 4.5gHz
Graphics
RedDevil 6900xt
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Is anyone have success with three- and four-finger gestures ?

Yeah. Virtually everyone in this thread - all gestures work by default
The only weird behaviour is hardware click. If you find that it plays up then change your double click speed
 
Joined
Jun 4, 2017
Messages
112
Motherboard
Asus X299 WS SAGE
CPU
i9 10940x
Graphics
vega 64
Yeah. Virtually everyone in this thread - all gestures work by default
The only weird behaviour is hardware click. If you find that it plays up then change your double click speed

is anything special needed to do in order to make it work?
four-finger up guest doesn't show desktops for me (but with external apple trackpad - do)
also two-finger back/forward in safari also not working
ps. i'm using blazinsmokey's latest clover
 
Joined
Jun 24, 2014
Messages
287
Motherboard
ASUS Maximus VII Hero
CPU
i7 4790k
Graphics
HD 4600 + GTX 970
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
is anything special needed to do in order to make it work?
four-finger up guest doesn't show desktops for me (but with external apple trackpad - do)
also two-finger back/forward in safari also not working
ps. i'm using blazinsmokey's latest clover

Try rebuilding kextcache and repair permissions and then reboot.
 
Joined
Jun 4, 2017
Messages
112
Motherboard
Asus X299 WS SAGE
CPU
i9 10940x
Graphics
vega 64
Try rebuilding kextcache and repair permissions and then reboot.

thanks! i've missed this thing. is there are any way to make f1-f12 work as function keys by default? i have this option in BIOS, but under mac os i need to use fn+fX combinations :(
 
Last edited:
Joined
Nov 17, 2018
Messages
26
Motherboard
Dell XPS 15 9560 - 1.10.1 - Clover
CPU
i7-7700HQ
Graphics
HD 630
Hi. I need more info. Too many factors here.
How old is your battery?
Do you use your laptop mostly on battery?
After boot, in activity monitor, is there any app or daemon running in the background pumping energy?
What are your bios power setting? battery profile? Mine is adaptive.
Was it always like that or suddenly your battery capacity drastically decreased?
If you have windows, is the battery life the same?

1) If you have windows installed on another partition (or disk) do this to check your actual battery capacity:


If your capacity is above 90Wh, don't proceed to full discharge. just do a cmos reset (see below).

Do this once maximum and read carefully. Respect the 3 to 5 hours necessary to cool down the battery after full discharge.

2) Once done before switching on your laptop, disconnect the battery and do a cmos reset by holding power button 1 to 2 min to fully discharge the mobo capacitors.

3) Do a full test at idle disabling sleep and report the time until nearly full discharge.

4) remove ADP1 ssdt in patched folder. reboot. clean nvram at clover screen. reboot. put back ssdt. reboot. clean nvram, reboot, shut down. Reboot.

This improved my battery life. In my case it was a new battery that needed just to be calibrated.

5) If all of this fails. Try a clean install.

Thanks for detailed answer, was soo busy unable to look into this. My battery would be 1yr and something old and haven't been using it mostly on battery. I have checked bios and had adaptive set and it also says my battery life is excellent and that is 100% charged. Don't have windows never really used it went removed straight as I was getting this lap only for hackintoshing :).

I think it went down drastically would believe before it would be aronund 5-6hrs maybe even 7hrs kinda close to what it would be. Well I see I had been fans going crazy last while is there anything I should check with undervaluing? or maybe fans are dirty and need a bit clean up? something else I should look at? I usually do simple stuff Firefox some terminal open few other windows ram might be half used nothing to extensive really no gaming at all. Cheers!
 
Joined
Jul 25, 2013
Messages
416
Motherboard
Asus X99 Deluxe
CPU
E5-2697v3
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. Xserve
Mobile Phone
  1. Android
  2. iOS
thanks! i've missed this thing. is there are any way to make f1-f12 work as function keys by default? i have this option in BIOS, but under mac os i need to use fn+fX combinations :(

Hardware function keys are defined by an SSDT, be sure you have your ACPI tables injected via Clover.
 
Joined
Jun 4, 2017
Messages
112
Motherboard
Asus X299 WS SAGE
CPU
i9 10940x
Graphics
vega 64
For those who needs for function keys act as function keys (without fn+fX pressing) - in BIOS Setup -> POST behavior -> Fn lock options select "Lock Mode Enable/Secondary".
 
Joined
Feb 23, 2012
Messages
19
Motherboard
Lenovo X1 Yoga Gen 4
CPU
i7-10510U
Graphics
UHD 620
I have the same laptop as blazinsmokey, but with a SK Hynix 512GB drive. I am unable to get to the macOS installer. It gets to the "still waiting for root device" line and just sits until it times out. I've tried 5 different USB drives in all the USB ports. I've tried USB2 and USB3. At a loss as to why this is happening. I see this in other forums, but since nobody here in this thread seems to have it, I'm not sure why its happening.
 
Status
Not open for further replies.
Top