Contribute
Register

[Guide] Dell XPS 9560 Mojave VirtualSMC, I2C Trackpad, Clover UEFI Hotpatch

Joined
Nov 9, 2018
Messages
65
Motherboard
Dell XPS 9560 - YH90J
CPU
I7-7700HQ
Graphics
GTX 1050, HD 630
Hey guys,

@blazinsmokey i have tested your new V3.3 Clover folder. I have a few Problems.

I replaced my whole Clover folder with yours. Changed BoardSerialNumber and so on back to mine.

The problems I have now.

First is battery life. on idle my cpu never gets down to 800 MHz. When I use Jardenlius (Git repo) CPUFriend + CPUFriendDataProvider Kext I have 9 hours and on idle it stays on 800 MHz. Watt usage is 1-2W.

Second Problem. If I plug in my iPhone via USB-C to Lightning. The Battery drains extremely fast (Could it be that its trying to fast charge it with more Power? 29 Watt?).

And my iPhone isn't recognized when its plugged in via USB-C or USB-A cable. iTunes, Photos and so on don't see it.
But its charging :)

So and the last one is Bluetooth. I have a DW1830 Wifi/Bluetooth Module. And its not connecting to my bluetooth devices. Fixed this with Jardenlius Args for boot with clover: abm_firstpolldelay=16000 bpr_probedelay=100 bpr_initialdelay=300 bpr_postresetdelay=300

Do you have these bugs too?
 
Joined
Dec 27, 2012
Messages
103
Motherboard
Dell XPS 9560 FHD
CPU
i7-7700HQ
Graphics
HD 630
Mac
  1. MacBook
Mobile Phone
  1. iOS
Hi @LeLunZ how are you?

First is battery life. on idle my cpu never gets down to 800 MHz. When I use Jardenlius (Git repo) CPUFriend + CPUFriendDataProvider Kext I have 9 hours and on idle it stays on 800 MHz. Watt usage is 1-2W.

With Clover 3.2 and 3.3 i report idle at 800 Mhz with also 1 to 2 watt core consumption. Battery wise it’s more 6 hours, 8 hours being a maximum.

And my iPhone isn't recognized when its plugged in via USB-C or USB-A cable. iTunes, Photos and so on don't see it.
But its charging :)

My iphone 6 is detected without any issues via usb.

Did you cleared nvram many times as value can stick between changes?
 
Last edited:
Joined
Nov 9, 2018
Messages
65
Motherboard
Dell XPS 9560 - YH90J
CPU
I7-7700HQ
Graphics
GTX 1050, HD 630
Hi @LeLunZ how are you?



With Clover 3.2 and 3.3 i report idle at 800 Mhz with also 1 to 2 watt core consumption. Battery wise it’s more 6 hours, 8 hours being a maximum.



My iphone 6 is detected without any issues via usb.

Did you cleared nvram many times as value can stick between changes?

@mazakiss i am fine thx, and you?

Hmm, i cleared nvram with nvram -c and with clover F11 many times.

I will do a clean reinstall of my Hackintosh because I want to see if its fixing the iTunes/Netflix Bug I have. If its fixes the other issues I will let you know.
 
Joined
Jun 24, 2014
Messages
288
Motherboard
ASUS Maximus VII Hero
CPU
i7 4790k
Graphics
HD 4600 + GTX 970
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
@mazakiss i am fine thx, and you?

Hmm, i cleared nvram with nvram -c and with clover F11 many times.

I will do a clean reinstall of my Hackintosh because I want to see if its fixing the iTunes/Netflix Bug I have. If its fixes the other issues I will let you know.

As of now currently, for USB-C, I would use method 2 in the readme which is KNNSpeed's. Maybe go that method if you want iPhone to USB-C.

No issues with idle, still hits 800Mhz frequently. I have been docked most the time so I can't confirm battery but I did do overnight sleep test so we know the laptop is sleeping well.

No bluetooth issues here. Maybe it's specific to the DW1830. I'm using DW1560.
 
Joined
Nov 17, 2018
Messages
26
Motherboard
Dell XPS 15 9560 - 1.10.1 - Clover
CPU
i7-7700HQ
Graphics
HD 630
That’s interesting, since I only installed Mojave and knew now they had the correct drivers I never used kext2patch/IONVMeFamily on my install.
While things are working great, I wonder If changing file sector has an implication as far as battery life is concerned.

Does any other people using kext2patch/IONVMeFamily has noticed an increasing battery life when switching?

From reading all over the internet, even on windows most xps owners equiped with the 97Wh battery also report an average 7 to 9 hours of autonomy so considering this our hack has great battery life. I mean it’s a 45W CPU so battery life is closer to most gaming laptop.

@blazinsmokey like you I managed to find a 14,1 smbios mbp dump done with Darwin Dumper. The issue is except looking at the ACPI tables I don’t know if it could help solving type-c and tb implementation since these dumps haven’t been done with a type-c/tb adapter plugged in.

I have a co-worker who own a mbp 13,3 will it help if I managed to get its IOReg with my adapter and dell TB16 plugged in?

Sorry might have been confusing. I have very very bad battery life, its around 3hrs..and fans going crazy (maybe because ff is eating like 50% of 32gb ram...) but non the less it was never that great. I believe while for some time that i have removed kext2patch for ssd i think it was better. i should try and see if there is difference. non the less i never had 7hrs. its never quite actually.
 
Joined
Nov 17, 2018
Messages
26
Motherboard
Dell XPS 15 9560 - 1.10.1 - Clover
CPU
i7-7700HQ
Graphics
HD 630
As of now currently, for USB-C, I would use method 2 in the readme which is KNNSpeed's. Maybe go that method if you want iPhone to USB-C.

No issues with idle, still hits 800Mhz frequently. I have been docked most the time so I can't confirm battery but I did do overnight sleep test so we know the laptop is sleeping well.

No bluetooth issues here. Maybe it's specific to the DW1830. I'm using DW1560.
I have dw1830 and my bluetooth is coming unavailable often. It actually does not happen when plugged in, but will happen pretty much immediately when on battery of closed lid in sleep. When back have to shutdown (not even reboot helps) to get it back. Or also if i had headphones connected and close lid comes unavailable this one bugs me alot...before your last power update it came better that is atleast on plug it works pretty much stable...before it would almost never work.
 
Joined
Dec 27, 2012
Messages
103
Motherboard
Dell XPS 9560 FHD
CPU
i7-7700HQ
Graphics
HD 630
Mac
  1. MacBook
Mobile Phone
  1. iOS
Sorry might have been confusing. I have very very bad battery life, its around 3hrs..and fans going crazy (maybe because ff is eating like 50% of 32gb ram...) but non the less it was never that great. I believe while for some time that i have removed kext2patch for ssd i think it was better. i should try and see if there is difference. non the less i never had 7hrs. its never quite actually.

I have the big 97Wh battery and 32 Go RAM and get 6 to 8 hours of battery.

I have dw1830 and my bluetooth is coming unavailable often. It actually does not happen when plugged in, but will happen pretty much immediately when on battery of closed lid in sleep. When back have to shutdown (not even reboot helps) to get it back. Or also if i had headphones connected and close lid comes unavailable this one bugs me alot...before your last power update it came better that is atleast on plug it works pretty much stable...before it would almost never work.

Use Jettison app for this or this script from @arehep XPS 9360 guide here: https://www.tonymacx86.com/threads/...smc-i2c-trackpad-clover-uefi-hotpatch.267161/ does exactly the same, preventing USB device to be hard mounted when sleeping.

@LeLunZ retested my 2 USB ports with Clover 3.3 and my iphone 6 is charging and launching itunes on both ports.

Cheers.
 
Joined
Feb 25, 2012
Messages
312
Motherboard
GA-Z370N-WIFI
CPU
i5-8600K
Graphics
RX 460
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
  2. iOS
I've been using the newest Kaby Lake config from your later post and have had the most stable experience I've had with my XPS 15, even when it was on Sierra. I do still get the screen flicker with this config, as expected, but I've had no crashes during sleep in over a week. Tonight I will swap to the Skylake spoof and see if I experience the crashes again.
Tried it for a couple of weeks and I still get daily crashes.
I keep loosing Word documents after writing them for a few hours.
It looks like kernel panic prevents saving filesystem cache to disk and makes autosave incapable of doing what it should.
Loosing few hours work drives me nuts. I'll have to give up on XPS if I won't find a solution.
Does everyone experience this with XPS or am I lucky?
 
Joined
Dec 27, 2012
Messages
103
Motherboard
Dell XPS 9560 FHD
CPU
i7-7700HQ
Graphics
HD 630
Mac
  1. MacBook
Mobile Phone
  1. iOS
Tried it for a couple of weeks and I still get daily crashes.
I keep loosing Word documents after writing them for a few hours.
It looks like kernel panic prevents saving filesystem cache to disk and makes autosave incapable of doing what it should.
Loosing few hours work drives me nuts. I'll have to give up on XPS if I won't find a solution.
Does everyone experience this with XPS or am I lucky?
Hi @dmitry_matora .
Nope no crash or kernel panic except with usb-c and thunderbolt. I use office on mac without issues too.

You have the 4k touchscreen version, right?

Did you add the correct boot args for it? Framebuffers for 4K are already added.

Anyone with 4K screens has the same issues?

Maybe do a clean nvram whether doing f11 at clover boot or better use cleanNvram.efi from UEFI bios then readd clover bios boot entry and reboot to osx.
 
Last edited:
Top