Contribute
Register

[Guide] Dell XPS 9560 Mojave VirtualSMC, I2C Trackpad, Clover UEFI Hotpatch

Joined
Jan 28, 2019
Messages
13
Motherboard
Dell XPS 15 9560
CPU
i7-7700HQ
Graphics
HD630
Mac
MacBook Pro
Mobile Phone
Android
Huh, AFAIK OSX did not update (automatic updates are turned off) and I did not open clover config, so that should not have updated, but OSX is missing from Clover on boot.

It's also missing from clover when I boot from my USB installer I used last week.

Any ideas?
 
Joined
Mar 11, 2015
Messages
10
Motherboard
DELL XPS 15
CPU
i7-7700
Graphics
UHD 630
Mac
MacBook Pro
Mobile Phone
Android
  • You should be able to create a macOS Mojave Clover USB installer and replace EFI with mine, with little adjustments.....
hi Blazinsmokey
Thanks forse the guide... Which are the Little adjustements That I have to do with the EFI after replacement?
 
Joined
Feb 11, 2019
Messages
7
Motherboard
Dell Precision 5520
CPU
i7-7820HQ
Graphics
Quadro M1200
Mac
MacBook Pro
Mobile Phone
Android
I have successfully installed Mojave on my Dell Precision 5520. Thank you for the great guide! I've ordered a Dell DW1560 to replace my intel WiFi card. Until it's arrived I don't have wifi or bluetooth, so for the time being I'd like to be able to use wired ethernet. I have gotten this to work using my Dell dock + a kext I've found that supports the dock its networking hardware.

I'd like to be able to use my Dell D59GG USB-C to ethernet adapter, or my Dell DA200 USB-C hub (they came with the laptop). The internet tells me both should work with MacOS. I prefer those options because the dock is a bit much to take with me. It seems like the problem is that the Thunderbolt 3 hardware isn't detected properly. MacOS says "Thunderbolt: No hardware was found.", in the System Report. Has anyone found a solution for this, by any chance?
 
Joined
Apr 7, 2018
Messages
5
Motherboard
Dell XPS 9560
CPU
7700HQ
Graphics
HD 630 - GTX 1050
Classic Mac
Power Mac
Mobile Phone
Android
Thank you so much for this guide. I finally got my triple boot (Mojave - Kubuntu - Win10) setup to work. Like Bram77, I’m still waiting for my DW1560; I just use HoRNDIS in the meantime. Should I expect any issues after swapping the wifi card, or will my current install handle that just fine? Also, what kind of battery life are you guys getting? It feels somewhat shorter than Linux and Windows for me.
 
Joined
Sep 26, 2018
Messages
18
Motherboard
Dell Precision 5520 - Clover
CPU
i7-7820HQ
Graphics
HD 630/ M1200 1920x1080
Mobile Phone
Android, iOS
I have successfully installed Mojave on my Dell Precision 5520. Thank you for the great guide! I've ordered a Dell DW1560 to replace my intel WiFi card. Until it's arrived I don't have wifi or bluetooth, so for the time being I'd like to be able to use wired ethernet. I have gotten this to work using my Dell dock + a kext I've found that supports the dock its networking hardware.

I'd like to be able to use my Dell D59GG USB-C to ethernet adapter, or my Dell DA200 USB-C hub (they came with the laptop). The internet tells me both should work with MacOS. I prefer those options because the dock is a bit much to take with me. It seems like the problem is that the Thunderbolt 3 hardware isn't detected properly. MacOS says "Thunderbolt: No hardware was found.", in the System Report. Has anyone found a solution for this, by any chance?
BArm77, I've got the same laptop (5520) and docking station. I have not tried the DP port there but everything else works fine without being reported in MacOS. I use Clover 2.1 version. The only issue I have is the audio is configured only for the headphones jack and not coming out of internal speakers. Do you have the same?
 
Joined
Feb 11, 2019
Messages
7
Motherboard
Dell Precision 5520
CPU
i7-7820HQ
Graphics
Quadro M1200
Mac
MacBook Pro
Mobile Phone
Android
Thank you @InertiaSelling! The HoRNDIS tip saved the day!

@bbst: I'm using the Clover 3 folder. I've only tested the DP port and LAN port via the docking station and they both work perfectly. I did have to install this driver for ethernet to start working (although MacOS did see the ethernet port, it didn't work): http://download.sharkoon.com/0012-RTUNICv1.0.17.zip

The internal speakers in my laptop work fine, right out of the box (thanks to the provided kext files, I suppose).

I had to place the VoodooPS2 kext in /Library/Extensions for my keyboard to function after a cold boot (without reboot).

Once I've received my DW1560 everything that's important will work. For now an USB bluetooth stick and HoRNDIS + my android phone cover what's missing. Very happy with this thread and my Precision 5520!

edit: @blazinsmokey I think the thread title should say "[Guide] Dell XPS 9560/Precision 5520....". The only significant difference (in regards to the subject) between the two devices is the wifi/bluetooth card. The GPU can be ignored, since in both cases they don't work anyway.
 
Last edited:
Joined
Sep 26, 2018
Messages
18
Motherboard
Dell Precision 5520 - Clover
CPU
i7-7820HQ
Graphics
HD 630/ M1200 1920x1080
Mobile Phone
Android, iOS
Thank you @InertiaSelling! The HoRNDIS tip saved the day!

@bbst: I'm using the Clover 3 folder. I've only tested the DP port and LAN port via the docking station and they both work perfectly. I did have to install this driver for ethernet to start working (although MacOS did see the ethernet port, it didn't work): http://download.sharkoon.com/0012-RTUNICv1.0.17.zip

The internal speakers in my laptop work fine, right out of the box (thanks to the provided kext files, I suppose).

I had to place the VoodooPS2 kext in /Library/Extensions for my keyboard to function after a cold boot (without reboot).

Once I've received my DW1560 everything that's important will work. For now an USB bluetooth stick and HoRNDIS + my android phone cover what's missing. Very happy with this thread and my Precision 5520!

edit: @blazinsmokey I think the thread title should say "[Guide] Dell XPS 9560/Precision 5520....". The only significant difference (in regards to the subject) between the two devices is the wifi/bluetooth card. The GPU can be ignored, since in both cases they don't work anyway.
@Bram77: I also used RTUNIC for Ethernet.
Do you have Speakers listed under Output in Sound settings? I have only Headphones. I wonder if this is because I installed the ComboJack pack. I really don't need it but maybe it screwed up the output somehow. Have you installed it too?
 
Joined
Feb 11, 2019
Messages
7
Motherboard
Dell Precision 5520
CPU
i7-7820HQ
Graphics
Quadro M1200
Mac
MacBook Pro
Mobile Phone
Android
@bbst I do have internal speakers listed. I started applying the ComboJack patch but decided against it halfway through the process, because it could make my perfectly functioning audio not work anymore :). I use bluetooth headphones anyway.
 
Joined
Sep 26, 2018
Messages
18
Motherboard
Dell Precision 5520 - Clover
CPU
i7-7820HQ
Graphics
HD 630/ M1200 1920x1080
Mobile Phone
Android, iOS
@bbst I do have internal speakers listed. I started applying the ComboJack patch but decided against it halfway through the process, because it could make my perfectly functioning audio not work anymore :). I use bluetooth headphones anyway.
thanks. I guess it does break it.
 
Joined
Dec 29, 2018
Messages
1
Motherboard
Asrock Deskmini 310w
CPU
i3-8100
Graphics
UHD 630
Does the type-c and thunderbolt3 hot plug work perfectly at 10.14.3?
I installed 10.14.3 and the hot plug is not working.
 
Last edited:
Top