Contribute
Register

[GUIDE] Dell XPS 9530

Joined
Jul 3, 2014
Messages
934
Motherboard
Dell XPS 9360 (KabyLake R)
CPU
Intel i7 8550U
Graphics
Intel UHD 620
Mac
MacBook, MacBook Pro
Mobile Phone
Android
Kenia,

The Dell XPS 9530 does not allow to disable the Intel integrated graphics separately.
So I cannot really help you here.

Additionally I run dual boot with Windows 8.
So I really only use the Nvidia 3D graphics in Windows 8 for gaming and all other things using the Intel HD4600 in OS X.

Note: I suggested you enable the VGA on HD4000 to fulfill your requirements
(http://www.tonymacx86.com/mavericks...ng-osx-no-optimus-need-help-3.html#post857748)
 
Joined
Aug 26, 2012
Messages
38
Motherboard
Dell XPS 9530 (Haswell)
CPU
Intel i7 4712HQ
Graphics
Intel HD 4600 / Nvidia GT750M
Mac
MacBook
Classic Mac
Mobile Phone
Android, iOS
Thank you the-darkvoid for your guides !

Do you plan to update to Yosemite when it will be release ?

I found you on another "forum" but you leave it because you got no answer... I don't have your hability and yours skills to hack a computer, but I very appreciate what you do !
 
Joined
Jul 3, 2014
Messages
934
Motherboard
Dell XPS 9360 (KabyLake R)
CPU
Intel i7 8550U
Graphics
Intel UHD 620
Mac
MacBook, MacBook Pro
Mobile Phone
Android
Still waiting on my Dell XPS to be repaired, hopefully it will not be long though.

After that I will try and finish the guide for Mavericks.

Any future OS X version I will only look at once its officially released (Also abiding by forum rules).
 
Joined
Dec 6, 2010
Messages
41
Motherboard
ASUS P5K Premium Wifi-AP
CPU
Intel Core 2 Quad Q6600
Graphics
ASUS nVidia GeForce GT 430
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
Kenia,

The Dell XPS 9530 does not allow to disable the Intel integrated graphics separately.
So I cannot really help you here.

Additionally I run dual boot with Windows 8.
So I really only use the Nvidia 3D graphics in Windows 8 for gaming and all other things using the Intel HD4600 in OS X.

Note: I suggested you enable the VGA on HD4000 to fulfill your requirements
(http://www.tonymacx86.com/mavericks...ng-osx-no-optimus-need-help-3.html#post857748)
I contacted EmylDinesh the author of the topic itself on the other forum you suggested to me but unfortunately he couldn't enable it as well...VGA port is detected but the display has no signal...and I understood that he's not willing to continue the project..
I'm not enough experienced to do it myself...
 
Joined
Aug 26, 2012
Messages
38
Motherboard
Dell XPS 9530 (Haswell)
CPU
Intel i7 4712HQ
Graphics
Intel HD 4600 / Nvidia GT750M
Mac
MacBook
Classic Mac
Mobile Phone
Android, iOS
the-darkvoid, there is 3 folders on the amiflash.zip (AFUWIN v4.xx). So, which version are you using please ?

For the more, the AFUWINx64.exe you supply with your patched bios is not working because some files are missing.

And the command "afuwinx64 bios_patched.bin /GAN" is not working because the argument GAN is not reconized.

Can you help me for this please ?

Thanks :D
 
Joined
Jul 3, 2014
Messages
934
Motherboard
Dell XPS 9360 (KabyLake R)
CPU
Intel i7 8550U
Graphics
Intel UHD 620
Mac
MacBook, MacBook Pro
Mobile Phone
Android
mopi,

From http://www.ami.com/Support/amibiossupport/, click the AFUWIN v4.xx link.
This will download a file called amiflash.zip.

Extract the file and navigate to "/amuflash/aptio/afuwin/afuwin64.zip".
Extract "afuwin64.zip"

Now execute "afuwingui.exe" and save the current bios to a ROM backup file.

Once you are ready to flash a new ROM, open a command prompt and execute:
"afuwinx64.exe BIOS.ROM /GAN".

Note that the /GAN switch is undocumented and does not show up in the help text.
 
Joined
Aug 26, 2012
Messages
38
Motherboard
Dell XPS 9530 (Haswell)
CPU
Intel i7 4712HQ
Graphics
Intel HD 4600 / Nvidia GT750M
Mac
MacBook
Classic Mac
Mobile Phone
Android, iOS
Oh, yes, you're right ! Sorry :D
I had tried with the dos version (with a usb boot key) and GAN was not reconized.

I flashed my laptop by mistake with semeliel's modded bios, fortunalty, it's working like a charm !

Thank you for your help.

I think I will install Maverick, then wait for yours next instructions...

I'm very happy because this laptop is very beautiful, and if it's works with OS X, it will be perfect !
Yet Another time, thank you very much !

[edit : Windows was talking about 2 computers with the same serial number and ask me to activated my Windows ?!
The BIOS contains some identification data as TAG and other stuff. Forthemore, I have not the top-tier model.
Definitly, I suggest to use your OWN modded bios]
 
Last edited:
Joined
Aug 26, 2012
Messages
38
Motherboard
Dell XPS 9530 (Haswell)
CPU
Intel i7 4712HQ
Graphics
Intel HD 4600 / Nvidia GT750M
Mac
MacBook
Classic Mac
Mobile Phone
Android, iOS
Hey, the-darkvoid,
did you replace the wifi/bluetooth card BEFORE installing Maverick ?

I'm waiting for 10 minutes, and I'm stuck on the error :

init
probe
start
[IOBluetoothHCIController][staticBluetoothHCIControllerTransportShowsUp] -- Received Blootooth Controller register service notification -- 0x3000
[IOBluetoothHCIController][start] -- completed
**** [IOBluetoothHCIControllerUSBTransport][configurePM] -- ERROR -- waited 30 seconds and still did not commandWakeup() notification -- 0x3000 ****
[IOBluetoothHCIController][hardwareSetupComplete] -- Failed setup: 0xFF02 (kBluetoolthSynchHCIRequestTimedOutWaitingToBeSent)
REQUIERE_NO_ERR Failure : 0xFF02 - file: /sourceCache/IOBluetoothFamily_kexts/IOBluetoothFamily-4260.4.1/Core/Family/HCI/IOBluetoothFamily.cpp:24451

**** [IOBluetoothHCIController][protectedBluetoothHCIControllerTransporterShowsUp] -- Error!! -- Something went wrong in the setup process. Could not communicate with Bluetooth Transport successfully -- 0x0000 -- 0xbeef ****

Thanks


[edit : it's seems to be a trouble with the video card but I try some stuff like ig-platform-id but no result...
Please, Could someone share his EFI partition with correct config.plist and other stuff ?

I use to used Chameleon and i'm a bit lose... Thanks !]
 
Joined
Aug 26, 2012
Messages
38
Motherboard
Dell XPS 9530 (Haswell)
CPU
Intel i7 4712HQ
Graphics
Intel HD 4600 / Nvidia GT750M
Mac
MacBook
Classic Mac
Mobile Phone
Android, iOS
Ok,
So Finally I succefully installed Maverick 10.9.4 on my Dell XPS 9530.

I used the config.plist (hd4600 desktop) from the Clover Guide of this forum.

Forthemore, I replaced the wifi card with the BCM94352Z. It's working OOTB in Windows 8.1, and It's seems that I need to patch IO80211Family.kext (AirPortBrcm4360.kext plugin) and do some stuff on DSDT for Mac OS X. So I will do that later... [edit : for the wifi, there is only two fix to use and inject the good wifi id]

I just want to share you that this BCM94352Z is reconized on the laptop (so no blacklist on dell as the-darkvoid says). No pin hack or something like that.

There is just a few thing with disapointed me, but it's not important : the metal cover is not designed for this card, so, a wire is not covered. I don't think this will be easilly unplug, but what a pity.

BCM94352Z.jpg
 
Joined
Aug 26, 2012
Messages
38
Motherboard
Dell XPS 9530 (Haswell)
CPU
Intel i7 4712HQ
Graphics
Intel HD 4600 / Nvidia GT750M
Mac
MacBook
Classic Mac
Mobile Phone
Android, iOS
Thank you very much the-darkvoid for all of your work ! You rocks ! Any news about your laptop ? Hope it will come back to you soon. I think you are waiting for it for a long time :/

I think you will be happy to know that the wifi card you choose is a very good choice (working OTB on Windows 8.1), and working correctly on Maverick after patching the kext I previously noticed, and the config.plist.

I'm currently sending this post on the laptop and I've nothing else the BCM94352Z...
Capture d’écran 2014-08-25 à 00.22.36.jpg

I let you the pleasure to finish yours guides when you will receive your laptop.
 
Top