Contribute
Register

[Guide] Dell XPS 8930 Big Sur 11.4 (upgraded from Catalina 10.15.7), RX580/UHD630, OpenCore

Joined
Jan 24, 2021
Messages
40
Motherboard
Dell XPS 8930
CPU
i9-9900K
Graphics
RX 570
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Thanks a lot, really appreciated. Yes, not a big deal for the 800 MHz but I’m used to get the lowest multiplier on my other Hacks so…

I’ve tried the CPUFriend and CPUFriendFriend kexts but it didn’t made any difference!

You’re right about the top and CPU fans, they tends to roar like a jet engine when the processor is stressed a bit.

I’ve tried iMac19,2 because one of the built to order version came with an i7 8700…

I think your top priority is to upgrade / replace the stock cooling system with the Dell upgraded one.

CPU heatsink: https://www.ebay.fr/itm/234590929474
CPU fan: https://www.ebay.fr/itm/234488360722
Top chassis fan and assembly (to replace the tiny 9cm fan) : https://www.ebay.fr/itm/234644431357
+Add a silent 12 cm fan in the bottom front of the case.
 
Joined
Jan 24, 2021
Messages
40
Motherboard
Dell XPS 8930
CPU
i9-9900K
Graphics
RX 570
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Hello !
Update : Opencore 0.8.6 100% OK with our XPS 8930 under Ventura... :)
 
Joined
Jan 4, 2015
Messages
512
Motherboard
Dell XPS 8930
CPU
i7-8700 / Z370
Graphics
RX 460
Mac
  1. MacBook Pro
Finally, done!

XPS 8930 i7 8700, Radeon Pro WX5100, 32 Gb DDR4, MacOS Big Sur 11.7.2. SMBIOS is iMacPro1,1 as it’s the way for me to be able to watch movies in TV. I had to fight a bit to:

- get rid of the loooong boot process: -disablegfxfirmware boot arg;
- be able to use TV and iTunes without crashing: wegnoigpu boot arg. The igpu can’t be disabled in the BIOS and it causes some conflicts with Whatevergreen…
 
Joined
Jan 4, 2015
Messages
512
Motherboard
Dell XPS 8930
CPU
i7-8700 / Z370
Graphics
RX 460
Mac
  1. MacBook Pro
Hmmm, crash with the Radeon Pro WX5100. The card runs quite hot and probably that some video process caused a reboot… Tried Geekbench 4 and bam, instant reboot. Fortunately, I had a little ugly Dell RX460 as a spare. Almost same performance and it run cooler! Also, reverted back to Clover 5148 before discovering the GPU was (probably) the culprit.
 
Last edited:
Joined
Jan 24, 2021
Messages
40
Motherboard
Dell XPS 8930
CPU
i9-9900K
Graphics
RX 570
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
I am extremely satisfied with the Radeon RX570 : it runs cool and is more than enough to drive 2 displays (one in 4K, the other in 1080p).
I didn't get exactly your point of watching movies in TV that would require another SMBIOS... Could you please explain this a little bit ? :)
 
Joined
Jan 4, 2015
Messages
512
Motherboard
Dell XPS 8930
CPU
i7-8700 / Z370
Graphics
RX 460
Mac
  1. MacBook Pro
I am extremely satisfied with the Radeon RX570 : it runs cool and is more than enough to drive 2 displays (one in 4K, the other in 1080p).
I didn't get exactly your point of watching movies in TV that would require another SMBIOS... Could you please explain this a little bit ? :)
If I do not add -wegnoigpu as boot arg, trying to watch a purchased movie in TV= instant crash of TV…

As for SMBIOS, I didn’t succeeded to watch same purchased movies with, as example, 19,2. Simply no screen or black screen with stuck play button… Tried a bunch of stuff: applegva plist options, UnfairGVA=… boot args (from 1 to 7). No go!

Which SMBIOS did you choose?

Thanks,

Patrice

***Anyway, running fine since one week on OC 0.8.3.

*** Ordered two brackets from eVilBay: one to replace the 92mm top fan (with a 120mm) and one to add a 120 mm in front, using a splitter connected with the top fan. Also ordered three Noctua fans: 1x80 mm to replace the CPU fan and two 120mm, obviously for top and front.

Computer is quite noisy when CPU is stressed!
 
Last edited:
Joined
Jan 4, 2015
Messages
512
Motherboard
Dell XPS 8930
CPU
i7-8700 / Z370
Graphics
RX 460
Mac
  1. MacBook Pro
I am extremely satisfied with the Radeon RX570 : it runs cool and is more than enough to drive 2 displays (one in 4K, the other in 1080p).
I didn't get exactly your point of watching movies in TV that would require another SMBIOS... Could you please explain this a little bit ? :)
Perfectly happy too with my RX 460. As for your suggested CPU heat sink replacement: looking on the official Dell forums, those that installed the blower fan and heat sink didn’t experienced a lot of difference (lower CPU temp and noise) than with the 80 mm with standard heat sink like mine. However, upgrading the chassis fan and adding a front one, they noticed a big difference! Lower temps and noise.

***Still definitely throttling a bit, Cinebench CPU test. Once it reaches 95 as I can see.

I hope the extra ventilation will help. If I remove the side cover, no throttling!

The best would be to put the board inside another case with an upgraded CPU cooler (I already have one)...

***Not that much happy, finally, see my latest post!
 
Last edited:
Joined
Jan 4, 2015
Messages
512
Motherboard
Dell XPS 8930
CPU
i7-8700 / Z370
Graphics
RX 460
Mac
  1. MacBook Pro
Hmmm! I've received the fans from Amazon and unfortunately, the 80 mm AF-8 is not enough for the CPU. The computer was idling in the 60's...! Put back the old one after reapplying thermal paste. They made a botched job at Dell, there was too much paste with bubbles everywhere. Now idling at 41-42. Even reach 35 when just waking from sleep or doing nothing for a while...

Awaiting the two brackets for the two Noctua's 120mm.
 
Joined
Jan 4, 2015
Messages
512
Motherboard
Dell XPS 8930
CPU
i7-8700 / Z370
Graphics
RX 460
Mac
  1. MacBook Pro
Well, this video convinced me to buy the Dell blower cooler:

I'll order it ASAP!
 
Joined
Jan 4, 2015
Messages
512
Motherboard
Dell XPS 8930
CPU
i7-8700 / Z370
Graphics
RX 460
Mac
  1. MacBook Pro
Anybody noticed some lags after wake from sleep with Radeon cards? @Skyfoxxp ? @dandelionclock ? Not that obvious unless you make a benchtest like Basemark (metal), GFXBench (metal), Cinebench (OpenGL) or GLView (OpenGL). Scores are dropping by half... Big Sur, Mojave or Monterey.

However, OpenCL benchs (GeekBench free, LuxMark) don't show any difference before or after sleep. The only way to regain performance is to reboot... and no sleep!

Now running a lowly GT740 and no benchtest difference before or after sleep??? NVidia seems unaffected.

It's like the combination of "my machine" Hackintoshed and the Radeon Polaris cards is buggy.

I will have to try the UHD 630. My only brief try gave me lit screen but no image. Surely some frammebuffer tailoring as I use two Acer LCD's with DVI output only. So, I have to use, for my RX460, a DVI to HDMI cable for one of them. Unfortunately, I have to also use a DVI to DP adapter for the other screen with the UHD 630.

I would guess however that there would be no performance lag after sleep.

My other build, Z390 with an RX560, doesn't exhibit this behavior.

I've tried everything:

- clean install of Mojave, Big Sur. Lags after wake;
- replacing RAM sticks with spares, same;
- booting with bare minimum stuff, only the hack SSD, the GPU, Keyboard and mouse, same!
- a different LCD, mouse and keyboard, no change!
- downgrading BIOS from 1.1.26 to 1.1.24 and even, 1.1.15, no difference;
- different versions of kexts, ACPI patches, bootloaders (Clover, OC 0.6.9, 0.8.3, 0.8.5, 0.8.8), no dice!

Performance is fine before or after sleep in Windows 11 with the RX460 and also an WX5100 (this one, being also Polaris based, behave the same and lags in benches and visually after sleep in MacOS).

I've ordered a cheap HP RX5500 from EvilBay but I doubt I'll face the same...

That's really a strange one as I see users in this thread with RX580 or RX570 and you do not seem to suffer this bug.

Remember, it's not that obvious until you test bench the card after sleep...

Not a lot of Hackintosh builds on the XPS 8930 documented on the web except here.

Thanks!

Patrice
 
Top