Contribute
Register

[Guide] Dell XPS 15 9560 MacOS 10.14.1 (all models)

Joined
Jan 11, 2019
Messages
23
Motherboard
Dell XPS 9560
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050
Mobile Phone
iOS
possible that your sensor kexts are not matched with your FakeSMC by looking at your kextcache output

remove the sensor kexts to see how it boots, if you really need those, then download fresh ones with FakeSMC.kext

typically, SortedOrder is not needed with hotpatching

also check the laptop guide for updated config.plist as they have more property values for mojave
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
What's the difference between the *Sensors.kext and FakeSMC_*Sensors.kext?
Does it bring any risk of some throttling not being applied when needed?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
15,400
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
What's the difference between the *Sensors.kext and FakeSMC_*Sensors.kext?
Does it bring any risk of some throttling not being applied when needed?
just try removing all sensor kexts, they can give you information but not really needed to make a hack work
 
Joined
Jan 11, 2019
Messages
23
Motherboard
Dell XPS 9560
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050
Mobile Phone
iOS
just try removing all sensor kexts, they can give you information but not really needed to make a hack work
Removed all of them, no success with the FakeSMC =/
 
Last edited:
Joined
Oct 10, 2017
Messages
4
Motherboard
Dell XPS 15 9560 Signature Edition
CPU
i7-7700HQ
Graphics
HD630
Has anyone tried this with 10.14.2? I am unable to get 10.14.1 and stuck with 10.14.2
I haven't had time to update my specs but it seems we have the same computer.

I managed to changing the install it after enabling USB Injection and USB Permission in Clover.

Also changed the ig-platform-id to this:

So I figured out most of my issues. macOS now boots, I can get to the desktop. Turns out that if you are on Intel HD 630 that your ig-platform-id has to be changed to 0x59120000.

The only other issues I have is my DW1560 not working and it won't sleep when I close the lid.
 
Last edited:
Joined
Jan 11, 2019
Messages
23
Motherboard
Dell XPS 9560
CPU
i7-7700HQ
Graphics
HD 630 + GTX 1050
Mobile Phone
iOS
Joined
Jan 28, 2019
Messages
13
Motherboard
Dell XPS 15 9560
CPU
i7-7700HQ
Graphics
HD630
Mac
MacBook Pro
Mobile Phone
Android
Couple questions.

Big one, I cannot get the WiFi card to work and I am using the same card as OP. I am using 10.14.2. Any ideas on what I can try?

Lastly, it says there is no track pad and I don't seem to be able to adjust the track pad mouse speed?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
15,400
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Couple questions.

Big one, I cannot get the WiFi card to work and I am using the same card as OP. I am using 10.14.2. Any ideas on what I can try?

Lastly, it says there is no track pad and I don't seem to be able to adjust the track pad mouse speed?
As per rules, please update your hardware profile to allow others to help you easier
https://www.tonymacx86.com/account/

please read the faq for proper hardware profile setup:
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Jan 28, 2019
Messages
10
Motherboard
Dell XPS 9560
Mobile Phone
Android
Hi everyone,

I am on the Dell XPS 15 9560 4k. I cannot boot from the USB. I don't get the USB show up in UEFI list on boot menu. I get it on the Legacy menu though.

If I plug in the USB, I see another UEFI entry, but it is for my SSD, not the USB.

If I try and boot from the legacy drive, I get "selected boot device failed".

Any ideas?

Edit: I managed to get past this error!

I select boot install Mojave. I get the apple logo, it disappears and then my machine restarts.

Are there any logs I can look at?

Any ideas?

Edit: I managed to update a few items in the config.plist to get past the randomseed error (https://www.tonymacx86.com/threads/solved-macos-high-sierra-reboot-on-end-randomseed.254893/).

Now I am just stuck on the circle with a cross through it. I am trying with 10.14.3. That is the difference I have done compared to the guide (because I can't download Mojave 10.14.1).

Any ideas? Any help would really help!
 
Last edited:
Joined
Mar 11, 2015
Messages
10
Motherboard
DELL XPS 15
CPU
i7-7700
Graphics
UHD 630
Mac
MacBook Pro
Mobile Phone
Android
Confirming that I could update my 9560 to 10.14.3 straight from Software Update, no issues so far.
Changes from original tutorial to make it 100% working:

-VoodooI2C for better touchpad: https://github.com/alexandred/VoodooI2C

hi edbr.. same machine for me
have you used the 2.1.4 release for VoodooI2C ?
is really better the touchpad ? have I to use Kextbeast to install all the seven Kexts to L\E ?
 
Top