Contribute
Register

[Guide] Dell XPS 15 9560: 4K Touch, 1TB SSD, 32GB RAM, 100% AdobeRGB

Status
Not open for further replies.

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Would enabling SSDT-RMDGPU remove usage of the dGPU on OS X and Windows 10 if on a dual boot? Is there a way to shut off the dGPU only when booting into OS X?

edit: for the 9560

ACPI edits/patches/etc you do with Clover (in ACPI/patched, config.plist/ACPI, etc) do not affect Windows.
 
Joined
Sep 27, 2013
Messages
56
Motherboard
Dell 05FFDN (XPS 15 9560)
CPU
i7-7700HQ
Graphics
Intel(R) HD Graphics 630 / NVIDIA GeForce GTX 1050 (Disabled)
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
  2. iOS
Fair warning to those that picked up on the newly today released BIOS update (1.8.0).

Updated to it and it kept panicking, hanging with graphical glitches even outside of OSes (both Windows and macOS).

Not sure if its only my machine, but I even downgraded and updated it again to make sure that it was nothing gone wrong during installation, but same kept happening on 1.8.0.

Downgraded back to 1.7.1 with no issues there. System is stable again.
 
Joined
Jul 25, 2013
Messages
393
Motherboard
Asus X99 Deluxe
CPU
E5-2697v3
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. Xserve
Mobile Phone
  1. Android
  2. iOS
Fair warning to those that picked up on the newly today released BIOS update (1.8.0).

Updated to it and it kept panicking, hanging with graphical glitches even outside of OSes (both Windows and macOS).

Not sure if its only my machine, but I even downgraded and updated it again to make sure that it was nothing gone wrong during installation, but same kept happening on 1.8.0.

Downgraded back to 1.7.1 with no issues there. System is stable again.

Looks like the BIOS update was pulled. I updated to 1.7.2 yesterday and am fine on my end.
 
Joined
Oct 5, 2015
Messages
57
Motherboard
Dell Precision 5510 (clover)
CPU
i7 6820hq/Intel Chipset
Graphics
Intel HD 530, NVidia M1000M, 3840x2160
I thought I should point out in this thread that VoodooI2C provides better multitouch gestures for the trackpad than VoodooPS2 on the XPS 15 than VoodooPS2 does. It also provides full multitouch gestures for the USB touchscreen which is a nice addition.

The following are the installation instructions for VoodooI2C: https://voodooi2c.github.io/#Installation/Installation

The XPS15 requires VoodooI2C.kext and VoodooI2CHID.kext injected with Clover, along with the necessary DSDT patches outlined in the above guide.

When you said better multitouch gestures, when exactly did that entail? Like smoother scrolling/pinchzooming?
 
Joined
Nov 8, 2014
Messages
131
Mac
Classic Mac
Mobile Phone
When you said better multitouch gestures, when exactly did that entail? Like smoother scrolling/pinchzooming?
Check the 9360 thread for reports on functionality on a similar device. There is no current support for pinch to zoom but there will be when we finish support for native multitouch (by simulating the magic trackpad 2).
 
Joined
Nov 22, 2016
Messages
2
Audio was working with the ComboJack fix but I mistakenly updated through the appstore yesterday and caused a kernel panic. I reinstalled OS from recovery and re-implemented the ComboJack fix but now I'm not getting the pop-up like before. These are my system logs now regarding verbstub. Can't see verbstub in IORegistery anywhere.

2018-03-04 01:22:14.115879-0400 0x72 Default 0x0 0 kernel: Kext com.XPS.VerbStub - library kext com.apple.kpi.iokit not compatible with requested version 16.6.
2018-03-04 01:22:14.115883-0400 0x72 Default 0x0 0 kernel: Can't load kext com.XPS.VerbStub - failed to resolve library dependencies.
2018-03-04 01:22:14.115886-0400 0x72 Default 0x0 0 kernel: Kext com.XPS.VerbStub failed to load (0xdc00800e).
2018-03-04 01:22:14.115888-0400 0x72 Default 0x0 0 kernel: Failed to load kext com.XPS.VerbStub (error 0xdc00800e).
2018-03-04 01:22:14.189424-0400 0x72 Default 0x0 0 kernel: Couldn't alloc class "VerbStubResidency"
Any help would be much appreciated.

I figured it out. I'm running version 16.5 of iokit and libkern.

For anyone having a similar issue, do:
kextstat | grep -e 'kpi.iokit' -e 'kpi.libkern'

If your version is 16.5 go into the Info.plist within the VerbStub.kext and edit the values from 16.6 to 16.5 and then follow KNNSpeed's instructions.
 
Joined
Oct 1, 2012
Messages
43
Motherboard
Dell XPS 15" 9560 (Clover)
CPU
Intel i7-7700HQ
Graphics
HD 630 / GTX 1050
Hi, i've created the bootable usb with Clover EFI. I'm booting it up with F12 > Clover EFI part > OSX Install but i can't see the SSD disk. I'have the latest firmware from Dell. I seen that in the main post he refers on BIOS 1.3/1.4/1.5... i have 1.8.1 right now so maybe i should downgrade something?
 
Joined
Oct 2, 2011
Messages
13
Motherboard
Gigabyte X99 UD4
CPU
i7 5820k
Graphics
NVidia gtx 970
Thanks for the guide

I have this laptop and a hacktoshi desktop.

just to confirm No Wifi without a usb dongle, and Nvidia video card won't work right?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi, i've created the bootable usb with Clover EFI. I'm booting it up with F12 > Clover EFI part > OSX Install but i can't see the SSD disk. I'have the latest firmware from Dell. I seen that in the main post he refers on BIOS 1.3/1.4/1.5... i have 1.8.1 right now so maybe i should downgrade something?

Can't see the disk where? (Clover?, Disk Utility?, somewhere else?)

You need to be specific with questions (no one here is clairvoyant) and provide problem reporting files.
See FAQ, "Problem Reporting".
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Oct 1, 2012
Messages
43
Motherboard
Dell XPS 15" 9560 (Clover)
CPU
Intel i7-7700HQ
Graphics
HD 630 / GTX 1050
I've a question about the 4k resolution.

I've managed to install Clover on the EFI partition and High Sierra but if i go to the Preferences>Display panel i only can scale the resolution to 1920x1080 (more space).

Is there any method, with the cpu-integrated graphic card, to get the 4k double-res of 3840x2160 like in Windows 10?
 
Status
Not open for further replies.
Top