Contribute
Register

[Guide] Dell XPS 13 9360 on MacOS Sierra 10.12.x - LTS (Long-Term Support) Guide

Joined
Apr 2, 2013
Messages
417
Motherboard
Dell XPS 13 (9360)
CPU
i7-8550u (8th Generation) Kalby Lake - R
Graphics
Intel UHD 620
Mac
  1. MacBook Pro
Seeing as boxing day is normally replete with family and excess food + boxsets, was worth doing something else for a change. OC 0.6.4 with MBP16,3

@egore - it's a first step, but keen to get your benchmarks, compared with my previous build. Also let me know if you spot any anomalies, misbehaviour, etc...
Excellent! We all appreciate it. I will give it a try a bit later today.
 
Joined
Apr 2, 2013
Messages
417
Motherboard
Dell XPS 13 (9360)
CPU
i7-8550u (8th Generation) Kalby Lake - R
Graphics
Intel UHD 620
Mac
  1. MacBook Pro
Seeing as boxing day is normally replete with family and excess food + boxsets, was worth doing something else for a change. OC 0.6.4 with MBP16,3

@egore - it's a first step, but keen to get your benchmarks, compared with my previous build. Also let me know if you spot any anomalies, misbehaviour, etc...
One clarifying question...are there any changes to the previously shared variables? I have those in place, so it should be an easy update to this EFI. Thanks again.
 
Joined
Sep 19, 2011
Messages
391
Motherboard
XPS 13 9360
CPU
i7-8550U
Graphics
UHD 620
Mac
  1. MacBook Pro
Variables haven't changed between OC builds; helps baseline performance better especially across different SMBIOS versions.

Let me know how this build works for you wrt my previous release.
 
Joined
Apr 2, 2013
Messages
417
Motherboard
Dell XPS 13 (9360)
CPU
i7-8550u (8th Generation) Kalby Lake - R
Graphics
Intel UHD 620
Mac
  1. MacBook Pro
Unfortunately, I'm unable for some reason to log into iCloud with the latest configuration. On attempts, results in iCloud_unsupported_device
 
Joined
Jan 24, 2020
Messages
4
Motherboard
Dell XPS 13 9360 (OpenCore)
CPU
i7-7660U
Graphics
Intel Iris 640, 3200 x 1800
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Hello, I'm working on a 9360 that I just picked up, can't get the USB drive to get to the installer; trying for OC 0.6.6 and Big Sur 11.2.

Here's the CPU/GPU:

CPU: i7-7660U (Kaby Lake)
GPU: Intel Iris Plus 640
Screen: QHD+ (3200x1800)
Configured with SMBIOS for a MacBook Pro 14,1

Thankfully this isn't my first hackintosh, I have desktop running OC 0.6.5 that works really well, been on OC since 0.5.6.

For this XPS 13 I followed the Dortania guide for Opencore 0.6.6 very closely. My suspicion is that the framebuffer failing and causing a hang. Here are the settings I have and the output.

Last line shows
MacBook-Pro.local com.apple.xpc.launchd[1] (com.apple.displaypolicyd.##) <Warning>:Service exited with abnormal code 1

I've tried a few other platform IDs but nothing seems to work. Any ideas? I really appreciate it!
 

Attachments

  • Screen Shot 2021-02-17 at 11.00.29 AM.png
    Screen Shot 2021-02-17 at 11.00.29 AM.png
    30.4 KB · Views: 32
  • IMG_5124.JPG
    IMG_5124.JPG
    2.9 MB · Views: 35

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,271
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hello, I'm working on a 9360 that I just picked up, can't get the USB drive to get to the installer; trying for OC 0.6.6 and Big Sur 11.2.

Here's the CPU/GPU:

CPU: i7-7660U (Kaby Lake)
GPU: Intel Iris Plus 640
Screen: QHD+ (3200x1800)
Configured with SMBIOS for a MacBook Pro 14,1

Thankfully this isn't my first hackintosh, I have desktop running OC 0.6.5 that works really well, been on OC since 0.5.6.

For this XPS 13 I followed the Dortania guide for Opencore 0.6.6 very closely. My suspicion is that the framebuffer failing and causing a hang. Here are the settings I have and the output.

Last line shows
MacBook-Pro.local com.apple.xpc.launchd[1] (com.apple.displaypolicyd.##) <Warning>:Service exited with abnormal code 1

I've tried a few other platform IDs but nothing seems to work. Any ideas? I really appreciate it!
please read the faq for proper hardware profile setup:
 
Joined
Jan 24, 2020
Messages
4
Motherboard
Dell XPS 13 9360 (OpenCore)
CPU
i7-7660U
Graphics
Intel Iris 640, 3200 x 1800
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
please read the faq for proper hardware profile setup:
Sorry about that, I updated my profile.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,271
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Sorry about that, I updated my profile.
the message you are getting usually relates to your unsupported nvidia card

try -wegnoegpu boot argument
 
Joined
Jan 24, 2020
Messages
4
Motherboard
Dell XPS 13 9360 (OpenCore)
CPU
i7-7660U
Graphics
Intel Iris 640, 3200 x 1800
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Sure thing, I'll give that a try. This model didn't come with an Nvidia GPU, I think that's only the XPS 15, but I'll reinstall my Windows NVMe and double-check.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,271
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Sure thing, I'll give that a try. This model didn't come with an Nvidia GPU, I think that's only the XPS 15, but I'll reinstall my Windows NVMe and double-check.
also you are posting in someone's guide that the person spent a long time in setting up, you have come along and posted here saying you followed a guide from another website.....?

maybe follow this guide here or create your own post?
 
Top