Contribute
Register

[Guide] Dell XPS 13 9360 on MacOS Sierra 10.12.x - LTS (Long-Term Support) Guide

Joined
Jun 12, 2020
Messages
4
Motherboard
XPS9360
CPU
i5-8250U
Graphics
Intel HD Graphics 620
@moenchp I actually used the second link you posted, but building from the first was able to get it working (albeit slowly). Thanks for the heads up!

Cool good to hear. Would it be possible to post the kext? Anything else I have to do?
 
Joined
Jul 20, 2014
Messages
723
Motherboard
Asrock X299 Creator
CPU
i9 10900X
Graphics
RX 5700XT
Hello
I have XPS 9360 with an i7-7500U and I was wondering witch SMBios suits the best ?
MacBookPros 14 have 7th gen i7 CPU
And the MacbookPro 14,1 hasn't got any Touch ID.
Could it be the right one ?
Why many Choose MacBookPro 15,2 ?
Thanks in advance
 
Joined
Sep 19, 2011
Messages
393
Motherboard
XPS 13 9360
CPU
i7-8550U
Graphics
UHD 620
Mac
  1. MacBook Pro
Hello
I have XPS 9360 with an i7-7500U and I was wondering witch SMBios suits the best ?
MacBookPros 14 have 7th gen i7 CPU
And the MacbookPro 14,1 hasn't got any Touch ID.
Could it be the right one ?
Why many Choose MacBookPro 15,2 ?
Thanks in advance

MBP15,2 works better for 8th gen processors (such as the 8550U) as they're based on that generation.

For 7th gen I'd use MBP14,1. Make sure you use the right CPUFriend kext as that's what makes the major difference rather than the smbios.
 
Joined
Jul 20, 2014
Messages
723
Motherboard
Asrock X299 Creator
CPU
i9 10900X
Graphics
RX 5700XT
Joined
Jul 20, 2014
Messages
723
Motherboard
Asrock X299 Creator
CPU
i9 10900X
Graphics
RX 5700XT
Another trouble I have is the sound speaker :
Low sound are good
Loud sound are saturated (my be it's not the correct word )

It seems to me that the sound volume is adds to itself .... I'm wrong ?
I use AppleALC.kext and my Sound device is :

<dict>
<key>PciRoot(0x0)/Pci(0x1F,0x3)</key>
<dict>
<key>layout-id</key>
<integer>13</integer>
</dict>
</dict>

How to solve this ? any ideas ?
Thanks
 
Last edited:
Joined
Feb 1, 2011
Messages
56
Motherboard
Dell XPS 13 9360
CPU
Intel i7 8550U
Graphics
Intel UHD 620
With the introduction of OpenCore, I've now committed an OpenCore configuration to the repository.
It would be good to get some feedback from users to see how well it works and what can be improved.

Just moving from High Sierra via Clover to 10.15.4 via OC 0.5.9. Bought a new SSD, so I didn't mess with my stable High Sierra install. After install, I put it in an enclosure, so I can boot via USB for further testing.

I have the same system as yours, used your OC folder from your git-hub repo.

Followed the OpenCore guide to get bluetooth working.

I have a couple of remaining issues:

AppleALC is causing kernel_task to use massive amount of cpu.
Internet sharing via WiFi from USB ethernet adapter doesn't work (worked on High Sierra).
 
Joined
Feb 20, 2019
Messages
50
Motherboard
Dell XPS 9360
CPU
i5-7200U
Graphics
HD 620
Does anyone have a working webcam on Catalina 10.15.4? Mine is working for 30 secs after boot, then displays only a black square. Camera light turns on tho.

Using latest Darkvoid repo with UVCFaceTimeHD.kext in clover.
 
Joined
Sep 19, 2011
Messages
393
Motherboard
XPS 13 9360
CPU
i7-8550U
Graphics
UHD 620
Mac
  1. MacBook Pro
Another trouve I have is the sound speaker :
Low sound are good
Loud sound are saturated (my be it's not the correct word )

It seems to me that the sound volume is adds to itself .... I'm wrong ?
I use AppleALC.kext and my Sound device is :

<dict>
<key>PciRoot(0x0)/Pci(0x1F,0x3)</key>
<dict>
<key>layout-id</key>
<integer>13</integer>
</dict>
</dict>

How to solve this ? any ideas ?
Thanks

I think the exact phrase you're looking for is 'audio is clipped' (Pourquoi le son sature-t-il?).
I have the same issue with one of my 9360s and I suspect the speaker has actually been physically distorted by it as it's now sounding wonky on Linux and windows.

Previously I used a patched AppleHDA kext, but I noticed this happened when I switched to AppleALC.

If anyone else is experiencing this please let me know and I'll try and dig deeper.
 
Joined
Jul 20, 2014
Messages
723
Motherboard
Asrock X299 Creator
CPU
i9 10900X
Graphics
RX 5700XT
I think the exact phrase you're looking for is 'audio is clipped' (Pourquoi le son sature-t-il?).
Yes The sound is clipped .... but only the Loud parts ➧ thus the feeling the sound adds to itself and so it naturally clipped

I have the same issue with one of my 9360s and I suspect the speaker has actually been physically distorted by it as it's now sounding wonky on Linux and windows.
I haven't got any Windows installed to test .... good point
Thanks

EDIT
I installed Windows 10
The sound is as bas as MacOS !!
Speakers seems to be physically damaged.
I'll try to replace them with new ones
Thanks
 
Last edited:
Top