Contribute
Register

[Guide] Dell XPS 13 9360 on MacOS Sierra 10.12.x - LTS (Long-Term Support) Guide

Joined
Dec 29, 2010
Messages
7
Motherboard
Dell XPS 9360
CPU
i7-8550U
Graphics
UHD 620
Mac
MacBook Pro
Mobile Phone
iOS, Other
DELETED
 
Last edited:
Joined
Dec 29, 2010
Messages
7
Motherboard
Dell XPS 9360
CPU
i7-8550U
Graphics
UHD 620
Mac
MacBook Pro
Mobile Phone
iOS, Other
Sorry a small question on CABC - I have a DELL XPS 9360 FHD with Sharp 1449 screen.

I've disabled CABC with the firmware update but got the FW update failed looping with messages "loop:1, err:1"... did anyone see a similar thing ? Last DELL Intel driver was installed. CABC seems disabled even if the update failed... but I'm a bit OCD about failed FW updates...
I saw that... Using the last driver by Intel I saw that error
The latest driver from Dell doesn't install, don't know why
You need to use the driver from Dell, but no the last one, but the one before.
 
Joined
Dec 29, 2010
Messages
7
Motherboard
Dell XPS 9360
CPU
i7-8550U
Graphics
UHD 620
Mac
MacBook Pro
Mobile Phone
iOS, Other
I'm having problems using one-key-hdcpi
Going back from sleep, the screen appears smaller and on the left superior corner
I have tried different configurations (with and without EDID, with and without correction for sleep) but the result is the same
By the way, I'm using a FHD screen and i7 8550 and MacOS Catalina 10.15.2
Beside of that, working with only small problems (even when I'm using the original Samsung PM961 disk with 512 bytes format)

Thanks!
 
Joined
Mar 29, 2012
Messages
49
Motherboard
Dell XPS 9360
CPU
i5-7200U
Graphics
HD 620
I saw that... Using the last driver by Intel I saw that error
The latest driver from Dell doesn't install, don't know why
You need to use the driver from Dell, but no the last one, but the one before.
Thanks! Can you find put the right version so I can try ? Do you have the same display ?
 
Joined
Apr 4, 2013
Messages
127
Motherboard
ASUS MAXIMUS VI Impact
CPU
i5-4670K
Graphics
GTX 770
Mac
MacBook
Mobile Phone
Android, iOS
I have an Apple USBC to Ethernet adapter, was wondering if it should be visible under the Thunderbolt section in System Information. It does work
in Ubuntu FWIW
For me it works, but it's non hotswappable
 
Joined
Jan 16, 2020
Messages
13
Motherboard
asus
CPU
intel i5
Graphics
onboard
Wish I had seen your messages before @PastilloAr and @cele_82 . I had the same error (installed the graphic drivers from Intel instead of Dell because it complained about not being the right one). Had the loop;1:err1; too. Unfortunately I have a blank screen ever since and think from what I've read that I have to change the screen altogether.

Do you know if it's fixable?
Do you think a QHD screen would still work for hackintosh? Thanks
 
Joined
Dec 29, 2010
Messages
7
Motherboard
Dell XPS 9360
CPU
i7-8550U
Graphics
UHD 620
Mac
MacBook Pro
Mobile Phone
iOS, Other
Wish I had seen your messages before @PastilloAr and @cele_82 . I had the same error (installed the graphic drivers from Intel instead of Dell because it complained about not being the right one). Had the loop;1:err1; too. Unfortunately I have a blank screen ever since and think from what I've read that I have to change the screen altogether.

Do you know if it's fixable?
Do you think a QHD screen would still work for hackintosh? Thanks
As far as I understand, QHD screen worked for Darkvoid (https://github.com/the-darkvoid/XPS9360-macOS) and others. Mine is FHD.
I don't know if the problem is fixable or you have to change the screen.... maybe you can try connecting an external screen to retry the update, using the correct driver.
 
Joined
Mar 29, 2012
Messages
49
Motherboard
Dell XPS 9360
CPU
i5-7200U
Graphics
HD 620
Did you format your NVME right? Did you enable TRIM and SSD power management?

I run a M2 SSD, so can’t comment on this topic. Skip through this thread, there is a lot of valuable stuff hidden somewhere in the middle. But I remember reading some posts last year about NVME power management, so this maybe your culprit.
What SSD model is yours ? NVMe fix is helping a little with general temperature stuff but not so much in overall power.


Also with your settings... can you remind me why formatting to 4k sectors is important ? I left my disk with 512b


Lastly, did you do any undervolting ? Is it worth ?
 
Last edited:
Top