Contribute
Register

[Guide] Dell XPS 13 9360 on MacOS Sierra 10.12.x - LTS (Long-Term Support) Guide

Joined
Aug 10, 2012
Messages
448
Motherboard
Asus Rog Strix Z370-G GAMING (WI-Fi AC)
CPU
i7-8700K
Graphics
RX 580
Mobile Phone
iOS
https://www.tonymacx86.com/threads/guide-dell-xps-13-9360-on-macos-sierra-10-12-x-lts-long-term-support-guide.213141


This is documented elsewhere in this topic and on the forum. There are some cases where state S3 resets watchdog and some of the run-time EFI variables, hence why you see reversion on wakeup.

The best method is to run stability tests with voltageshift and apply the optimal voltage settings to EFI. Once this is done you'll have permanent undervolting across all OSes.
Ok I used search funktion and searched for VoltageShift and back in 240`s in this thread I found some conversation between you and TheDarkvoid where he's claiming that its not working due to something about setup_var unlocking overclock.
That´s bull "excuse me" not true
I can assure you that its working.But you have to use a sysdef that support HWP and in config.plist enable Plugintype and HWP
I use MB 9,1 and its working flawlessly
I also made a CPUFriendDataProvider.kext using the Board-ID plist ( Mac-9AE82516C7C6B903.plist) (MB 9,1) and copied that together with CpuFriend.kext to EFI/Clover/Kexts/Other where Lilu.kext is located to

But the issue about not working after wake from sleep is not documented by other than me as far as I know

BTW i don´t want Windoze on my laptop. I have it on my main rig because I´m doing a lot off support/troubleshooting to Windows users.
Mostly backup essential files an a fresh install
Going Bald´s guide https://www.tonymacx86.com/threads/guide-multibooting-uefi.197352/
is outdated according to dual boot on a single HD Mojave
check this:https://hackintoshpro.com/dual-boot-hackintosh/
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,134
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I tried adding more kexts to L/E, but to no avail. Is there a list of kexts I need in L/E that shouldn't be in Clover? I followed the guides instructions for the L/E kexts.
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Aug 11, 2016
Messages
116
Motherboard
Asus Z170I PRO Gaming
CPU
i5 6600k
Graphics
GTX 1060
Cant update from 10.14 to 10.14.2, I dont know what is causing this problem; appleACPICPU stalls.
Only happens once I have to reboot into "Mojave Install", I can still boot the normal mac partition.
Attached my Clover folder, problem report files and a screenshot.


Edit: Turns out I just had to let it run for 20min and it finally booted into the update installer.
 

Attachments

Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,134
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Cant update from 10.14 to 10.14.2, I dont know what is causing this problem; appleACPICPU stalls.
Only happens once I have to reboot into "Mojave Install", I can still boot the normal mac partition.
Attached my Clover folder, problem report files and a screenshot.


Edit: Turns out I just had to let it run for 20min and it finally booted into the update installer.
You're missing important kexts in EFI/Clover/kexts/Other.
One example is AppleBacklightFixup.kext... it is not in kexts/Other, but yet you have PNLF from SSDT-PNLF.aml.
This will lead to awkward black screens during system updates.
 
Joined
Oct 24, 2018
Messages
14
Motherboard
XPS13 9360
CPU
i7-7560U
Graphics
Iris Plus 640
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Maybe a bricked DW 1560 ?
I´m using that and it works on my XPS 9350
Have you checked that the very small connectors are correctly attached ?
It`s not easy to do that, you have to be very careful.You can brick the antennacable connectors if you try to force them
Your kextcache output proves kexts are not installed correctly.
All kexts you need must be installed to the system volume.
Read post #2 of the Clover guide for details:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

No BT controller on the USB bus. Perhaps you failed to enable it in BIOS, or forgot to disable fast boot, or the hardware you have installed is defective (test in Windows), or your USB configuration is wrong.
Update: Bluetooth does not show up in Ubuntu live USB, therefore card is bricked. Have another one on the way.
 
Joined
Aug 10, 2012
Messages
448
Motherboard
Asus Rog Strix Z370-G GAMING (WI-Fi AC)
CPU
i7-8700K
Graphics
RX 580
Mobile Phone
iOS
Joined
Apr 21, 2016
Messages
1,346
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
iOS
I'm guessing I was too wordy, so TLDR; version is this: I have a clean install of Mojave, on an XPS 9360 with i7-8550, 8GB RAM, and FHD screen. Cannot get I2C kext to allow proper trackpad usage; specifically right click is inoperable, although works fine under Windows 10. Have a clone of Dark-Void's repository with only minor config.plist edits related to boot order and unique SystemID.

Any help would be invaluable, I've spent many hours on this.
There's a bug in VoodooI2C that prevents right click from working (even when you set secondary click to right click in SysPrefs).
You may set it to 2F tap.

BTW, FakePCIID.kext + FakePCIID_Broadcom_WiFi.kext may be replaced with AirportBrcmFixup.kext.
 
Joined
Apr 2, 2013
Messages
399
Motherboard
Dell XPS 13 (9360)
CPU
i7-8550u (8th Generation) Kalby Lake - R
Graphics
Intel UHD 620
Mac
MacBook Pro
I2C configuration.

How are you all configuring the trackpad CP to have full functionality using the I2C kext? Smart zoom, zoom in and out, rotate, ...all of it. Thanks much!
 
Joined
Sep 19, 2011
Messages
342
Motherboard
XPS 13 9360
CPU
i7-8550U
Graphics
UHD 620
Mac
MacBook Pro
https://www.tonymacx86.com/threads/guide-dell-xps-13-9360-on-macos-sierra-10-12-x-lts-long-term-support-guide.213141


Ok I used search funktion and searched for VoltageShift and back in 240`s in this thread I found some conversation between you and TheDarkvoid where he's claiming that its not working due to something about setup_var unlocking overclock.
That´s bull "excuse me" not true
I can assure you that its working.

But the issue about not working after wake from sleep is not documented by other than me as far as I know
For voltage settings to persist across cold boot (S5) and wake (S3) you need to enable these options in BIOS using setup_var (or the custom bios I am building at the moment, to be released soon). Otherwise settings will only persist in runtime if you use voltageshift. This is not an OS-specific condition, it is a run-time variable that gets reset if the undervolt & overclock variables are not set.
 
Last edited:
Joined
Aug 10, 2012
Messages
448
Motherboard
Asus Rog Strix Z370-G GAMING (WI-Fi AC)
CPU
i7-8700K
Graphics
RX 580
Mobile Phone
iOS
https://www.tonymacx86.com/threads/guide-dell-xps-13-9360-on-macos-sierra-10-12-x-lts-long-term-support-guide.213141


For voltage settings to persist across cold boot (S5) and wake (S3) you need to enable these options in BIOS using setup_var (or the custom bios I am building at the moment, to be released soon). Otherwise settings will only persist in runtime if you use voltageshift. This is not an OS-specific condition, it is a run-time variable that gets reset if the undervolt & overclock variables are not set.
That sounds really strange to me cause it is really working no matter if it´s a cold boot/reboot/wake from sleep.
Without undervolt the voltage to cpu is idle about 0.6300 but as you can se here:

Skærmbillede 2018-12-12 kl. 15.35.53.png
Undervolt about 0.5400 no matter boot/reboot/wake

Also running CleanMyMac 4.1 without uv temperature peak at 92 degrees with uv 77
My overall temp.is also lower and about 15% better battery life.
????
 
Last edited:
Top