Contribute
Register

[Guide] Dell XPS 13 9360 on MacOS Sierra 10.12.x - LTS (Long-Term Support) Guide

Joined
Mar 20, 2013
Messages
71
Motherboard
XPS 13 9360-Clover
CPU
I7-8550U
Graphics
Integrated QHD+
Mobile Phone
iOS
I ran into the same issue with audio & Bluetooth post-install.

To solve the audio issue, the method I used was to clone darkvoid's repository & execute the XPS9360.sh script using the --patch-hda argument.

Still haven't got Bluetooth working, unfortunately.

Did you do anything for the DSDT files besides just them over from the Github? Just wondering if we have to compile/generate them like the post install of this guide.
 
Joined
Feb 11, 2018
Messages
4
Motherboard
Dell XPS 13 9360 - 2.9.0
CPU
i7-7560U
Graphics
UHD 640 (3200x1800)
Mac
MacBook Pro
Last edited by a moderator:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Nov 16, 2013
Messages
58
Mac
iMac, Mac mini
Mobile Phone
Android, iOS
@jkbuha, did you face issues with bluetooth on your latest mojave config?
I have a strange behavior with apple devices like magic mouse, and keyboard, they just failed on pairing attempt and then non-visible at all.
 
Joined
Sep 19, 2011
Messages
354
Motherboard
XPS 13 9360
CPU
i7-8550U
Graphics
UHD 620
Mac
MacBook Pro
@jkbuha, did you face issues with bluetooth on your latest mojave config?
I have a strange behavior with apple devices like magic mouse, and keyboard, they just failed on pairing attempt and then non-visible at all.
No - magic mouse, keyboard et al work well with bluetooth on my rig.
 
Joined
Nov 24, 2018
Messages
10
Motherboard
XPS 13
CPU
I7-8550U
Graphics
Intel 620
To
Just installed Mojave on my 9360. I used @the-darkvoid GitHub for kexts. My Audio and Bluetooth don't work. My machine has a i7 8550u and a DW1830 card. The card uses the same kexts as the DW1560 so I thought the WiFi/BT would work fine with the Kexts from the GitHub. As for Audio, the GitHub has some audio files but I'm not sure how to use them. Any help would be appreciated. Also just to verify I did this correctly, post install I just copied over the DSDT as is from the GitHub. Is there anything else I need to do?
get audio working with DarkVoid latest repo I had to load the config.plist in clover, then select "boot" and add a custom flag with "alcid=11" That worked for me. Make sure you have a space between the last flag and this one. This is assuming you took his repo "as is" and didn't do any other audio patching/tweaks.
 
Joined
Nov 17, 2016
Messages
51
Motherboard
Dell XPS13 9360 - Clover
CPU
i5-7200U
Graphics
HD 620, 1920x1080
Mac
MacBook Pro
Mobile Phone
Android
Hi guys, I'm having some issue trying to install sierra on my xps. I installed latest BIOS (.10), patched DVMT to 64M (I think, I'm not sure how to check it but now the installer is starting while before patching it was rebooting) and formatted the ssd for handling 4k blocks. Now I have the killer and intel wifi cards so I need to order the BCM one, but I'm trying to get something working before wasting another 30€ for the card. So question number one, is it possible to get a working machine without the correct card? Of course wifi/bt won't work, but I'd like to boot the machine before buying.

Second, I'm not sure if I'm doing everything the correct way. I picked a 32gb usb, fat32'ed 2 partitions, one for the EFI and one for macOS installer. Installed clover in UEFI mode, then (and here probably I'm wrong) removed the generated BOOT and CLOVER folders and added the one from the OP of this thread. Tried booting from clover, everything started, formatted to GUID Partition Map and started installing macOS. At the end of the process the xps SHOULD reboot, then restart the installation from where it was left. In my case it rebooted and the installation restarted from the beginning, so I can't complete the installation process. My main issue is that I can't read logs or check why nothing is working since the only log disappears in less than a second and then the xps reboots. I tried adding verbose and the flag to avoid reboot after kernel panic, but it's still rebooting. Do you guys know any way to read "old" logs from clover? Or anyone know what's going on with my pc?

Thanks!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi guys, I'm having some issue trying to install sierra on my xps. I installed latest BIOS (.10), patched DVMT to 64M (I think, I'm not sure how to check it but now the installer is starting while before patching it was rebooting) and formatted the ssd for handling 4k blocks. Now I have the killer and intel wifi cards so I need to order the BCM one, but I'm trying to get something working before wasting another 30€ for the card. So question number one, is it possible to get a working machine without the correct card? Of course wifi/bt won't work, but I'd like to boot the machine before buying.

Second, I'm not sure if I'm doing everything the correct way. I picked a 32gb usb, fat32'ed 2 partitions, one for the EFI and one for macOS installer. Installed clover in UEFI mode, then (and here probably I'm wrong) removed the generated BOOT and CLOVER folders and added the one from the OP of this thread. Tried booting from clover, everything started, formatted to GUID Partition Map and started installing macOS. At the end of the process the xps SHOULD reboot, then restart the installation from where it was left. In my case it rebooted and the installation restarted from the beginning, so I can't complete the installation process. My main issue is that I can't read logs or check why nothing is working since the only log disappears in less than a second and then the xps reboots. I tried adding verbose and the flag to avoid reboot after kernel panic, but it's still rebooting. Do you guys know any way to read "old" logs from clover? Or anyone know what's going on with my pc?

Thanks!
Follow the Clover guide linked from the FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html

Although you should read the FAQ for an overview of issues, the Clover guide is linked from the first question: "Q. Where do I start?", just after the bold face "Clover Guide".
Here is a direct link, just to be clear:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Also, your profile must be filled out with complete details as requested in the FAQ, again under "Q. Where do I start?". All seven details requested are equally important.

And if you have an issue (after following the guide), or on any other problem, you must provide a detailed description of the problem including information that helps us understand what you're doing. Always attach "Problem Reporting" files as per FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html
The required files and data are fully detailed in the last question in the FAQ:
"Q. What are typical "Problem Reporting" files?"
 
Top