Contribute
Register

[Guide] Dell XPS 13 9360 on MacOS Sierra 10.12.x - LTS (Long-Term Support) Guide

Joined
Feb 1, 2018
Messages
30
Motherboard
Dell XPS 13 9360 - Clover UEFI
CPU
i5-7200U
Graphics
HD 620 @ 1920*1080
Mobile Phone
  1. Android
Hello,

Recently I updated my Clover and some SSDT files, kexts from darkvoid and have the following issues:

- Audio not working (Worked fine before the update)
- Touchpad not working (Worked fine before the update), if I rolled back to my backup Clover, it works again.

AppleALC, AppleHDA and CodecCommander are loaded as seen from kextstat
Running ioreg -l|grep layout-id gives me layout-id=<07000000>
I guess it is the problem but Idk how to modify it
 

Attachments

  • debug_5891.zip
    2.2 MB · Views: 93
Joined
Jul 3, 2014
Messages
934
Motherboard
Dell XPS 9360 (KabyLake R)
CPU
Intel i7 8550U
Graphics
Intel UHD 620
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
AppleALC, AppleHDA and CodecCommander are loaded as seen from kextstat
Running ioreg -l|grep layout-id gives me layout-id=<07000000>
I guess it is the problem but Idk how to modify it

Remove AppleALC from Clover kexts and run XPS9360.sh --patch-hda to create an AppleHDA injector.
Layout ID when using AppleHDA injector should be 0x000001
 
Joined
Jul 9, 2018
Messages
3
CPU
Intel i5-7200u
Graphics
Intel hd 620
Mac
  1. MacBook
I tried looking through the entire thread and i couldnt seem to find how to change the ownership and permission of the kext inside the sle postinstall folder. Not only that but it does not specify if to change the permissions of the entire folder or just the 2 files that are added into it. It would be helpul if soemone got back to me. Ive been stuck here for the last 24 hours. I’m also running Mac OS high Sierra 10.13.6 through the clover file dark void made. I boot into Mac fine the only things that don’t work are the track pad and the audio. If this step isn’t necessary for this Mac OS please let me know.
 
Last edited:
Joined
Jul 3, 2014
Messages
934
Motherboard
Dell XPS 9360 (KabyLake R)
CPU
Intel i7 8550U
Graphics
Intel UHD 620
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
Hello,

Recently I updated my Clover and some SSDT files, kexts from darkvoid and have the following issues:

- Audio not working (Worked fine before the update)
- Touchpad not working (Worked fine before the update), if I rolled back to my backup Clover, it works again.

AppleALC, AppleHDA and CodecCommander are loaded as seen from kextstat
Running ioreg -l|grep layout-id gives me layout-id=<07000000>
I guess it is the problem but Idk how to modify it

If using AppleALC, you should be using layout ID 0x38 (56). If using my script with AppleHDA injector kext, the layout ID is 0x01 (1).
 
Joined
Jul 3, 2014
Messages
934
Motherboard
Dell XPS 9360 (KabyLake R)
CPU
Intel i7 8550U
Graphics
Intel UHD 620
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
I tried looking through the entire thread and i couldnt seem to find how to change the ownership and permission of the kext inside the sle postinstall folder. Not only that but it does not specify if to change the permissions of the entire folder or just the 2 files that are added into it. It would be helpul if soemone got back to me. Ive been stuck here for the last 24 hours. I’m also running Mac OS high Sierra 10.13.6 through the clover file dark void made. I boot into Mac fine the only things that don’t work are the track pad and the audio. If this step isn’t necessary for this Mac OS please let me know.

Use a kext utility, such as Kext Utility
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,149
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I tried looking through the entire thread and i couldnt seem to find how to change the ownership and permission of the kext inside the sle postinstall folder. Not only that but it does not specify if to change the permissions of the entire folder or just the 2 files that are added into it. It would be helpul if soemone got back to me. Ive been stuck here for the last 24 hours. I’m also running Mac OS high Sierra 10.13.6 through the clover file dark void made. I boot into Mac fine the only things that don’t work are the track pad and the audio. If this step isn’t necessary for this Mac OS please let me know.

See FAQ for correct kext install procedures and locations:
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html
 
Joined
Jul 9, 2018
Messages
3
CPU
Intel i5-7200u
Graphics
Intel hd 620
Mac
  1. MacBook
Ok i have another dumb question and i cant seem to find the answers on here. So i made the bootsbke usb drive i installed 10.13.6 with the darkvoid clover file. Now im in the operating system and i make a clover bootloader for my hardrive and switch out the cloverfile with the one from darkvoid. Idk if this is the right procedure because i try to reboot and boot from the ssd and it enters into a kernal panic. And i have to restart all over. Is this caused because i dont install the proper kext before rebooting or is it something to do with the clover bootloader that i made? I just made a standard uefi clover booloader and i also tried the nvram one but neirher worked. Sorry im such a noob at this. This is barely my second day trying this
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,149
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Ok i have another dumb question and i cant seem to find the answers on here. So i made the bootsbke usb drive i installed 10.13.6 with the darkvoid clover file. Now im in the operating system and i make a clover bootloader for my hardrive and switch out the cloverfile with the one from darkvoid. Idk if this is the right procedure because i try to reboot and boot from the ssd and it enters into a kernal panic. And i have to restart all over. Is this caused because i dont install the proper kext before rebooting or is it something to do with the clover bootloader that i made? I just made a standard uefi clover booloader and i also tried the nvram one but neirher worked. Sorry im such a noob at this. This is barely my second day trying this

No one can help you when you fail to attach problem reporting files.

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.

Also, your profile needs fixing as per FAQ. Please do so before your next reply.
 
Joined
May 16, 2016
Messages
5
Motherboard
XPS 13 9360R Clover
CPU
i5-8250u
Graphics
UHD 620
Mobile Phone
  1. Android
Bought this exact laptop, 9360 (i5 8250, QHD Touch). The hackinstosh made me bite the bullet. After reading page 5 or 6 where someone asked if it could be used as a daily driver with hackintosh and you said no, unless you're a programmer. Do you think now it can be a reliable daily hackintosh?

Bought it to use at university but have until September to get everything working without issues.
 
Joined
Apr 12, 2011
Messages
13
Motherboard
Dell XPS 9360R QHD+ Touch
CPU
i7-8550U
Graphics
HD620
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Bought this exact laptop, 9360 (i5 8250, QHD Touch). The hackinstosh made me bite the bullet. After reading page 5 or 6 where someone asked if it could be used as a daily driver with hackintosh and you said no, unless you're a programmer. Do you think now it can be a reliable daily hackintosh?

Bought it to use at university but have until September to get everything working without issues.

This was a long time ago, I use my XPS as a daily driver, works perfect, I study something with engineering so I mainly use it for Matlab and Simulink. Works fine, if you study something with media design I would buy an external usb mouse, because the trackpad is not perfect, for normal usage it is fine :)
 
Top