Contribute
Register

[Guide] Dell XPS 13 9350 macOS 10.12.1

Status
Not open for further replies.
Joined
Jul 31, 2016
Messages
44
Motherboard
Dell XPS 13 9350
CPU
i5 6200U
Graphics
HD 520
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@Sevinkroff could be on to something.
OS X package pwr0 is twice higher than on Windows 10 based on intel power gadget. 1.25+ vs 0.65+

I unplugged the laptop this morning. With very light use, KeepingYouAwake on, activity monitor, intel power gadget on, I got more than 4 hours use with the battery is still at 50%.
 
Joined
Jul 13, 2013
Messages
37
Motherboard
Dell XPS 15 9570 4K
CPU
i7-8750H
Graphics
UHD 630 + GTX 1050 Ti
How do you measure battery life? Just actual use?
Is the activity monitor reliable for checking battery remaining?

I definitely was able to use more than four hours - the whole day, with battery still juiced up. I did browsing, reading PDF files using Preview. But that was with "El Capitan 10.11.6", and without a functioning wifi card.

I also just booted into Windows. Everything is still there.

No, I measure battery life through the battery icon. I also installed a third party "Coconut" battery app in case it was just OS X reporting incorrect battery life, however coconut also provided very similar values of around 4hrs. I also don't have a functioning wifi/bluetooth card right now.

Do you have QHD or FHD screen?
 
Last edited:
Joined
Feb 11, 2016
Messages
6
Mac
Classic Mac
Mobile Phone
Power consumption under OS X with HWP enabled - 1.95W @ 0.49GHZ at idle:
c03f861c42.jpeg


Power consumption under Windows - 0.56W @ 1GHZ at idle:
c041a48285.jpg


Technically OS X should be providing better battery life, however it has almost 4x increased power consumption even though its reaching and staying at lower frequencies.

Any ideas?
 
Last edited:
Joined
Nov 25, 2016
Messages
6
Motherboard
DELL XPS 13 9350
CPU
Intel Core i7-6560U @ 2,2 GHz
Graphics
Intel Iris 540
Meanwhile some good news. Got working sleep and hibernation on our laptop!:headbang:
Thanks to @syscl many previous bugs were fixed and are still being fixed, but they aren so numerous remaining.

The v2 changelog:
Sleep works
Hibernation works
HWP fully works (from 0.5GHz up to 3.2GHz automatic frequency scaling)
CPU sensors fully works
Trackpad fully works(gestures/prefpane)
Keyboard was adapted to our layout
Now two verisions, one for late 2015 i5-6200U/i7-6500U, the other for early 2016 i7-6560U
Only one line difference, but should work. Well, I hope so:beachball:
That is all for now. ZIPs added to the original post.

Bit by bit we're gonna make this machine work as designed!

For v3 I'll need two owners of different wlan modules: one with DW1820A and the other one with DW1560. Would be nice if you get working the modules simply by adding kext patches to clover config. If so, we ll be ready to a truly universal solution for the whole 9350 linea.

I replaced the contents of my EFI/CLOVER folder with the contents of Ready to run v2 Iris 540 package using a freshly installed macOS, but it hangs on thre loading screen, the bar gets entirely filled, but it never goes any further. It did work with the v1 package during installation, but after replacing these files and restarting I can't get in.

IMG_20161222_160151.jpg

Anyone had luck with the v2 package? Any ideas what could be going on? Thanks.
 
Joined
Jul 10, 2011
Messages
68
Motherboard
Dell XPS 9360
CPU
Intel Core i7-7560U @ 2,4 GHz
Graphics
Intel Iris 640 FHD
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Very relevant for this tutorial:
Dell SMBios Truncation Workaround
Testing it, bu it laks one of the important feature, that me bothers more than the already fixed things - the need to change it again to a shorter one to be able to install an update. Till now I do not really see any major benefit from it. Rather cosmetic ones...

Any ideas what could be going on? Thanks.
posted a solution few posts ago.
 
Joined
Oct 20, 2011
Messages
41
Motherboard
DELL XPS 9550
CPU
i7-6700HQ
Graphics
HD 530 / GTX960M
Mobile Phone
  1. Android
Testing it, bu it laks one of the important feature, that me bothers more than the already fixed things - the need to change it again to a shorter one to be able to install an update. Till now I do not really see any major benefit from it. Rather cosmetic ones...
About updates - you can easily use this solution https://pikeralpha.wordpress.com/2016/12/16/installing-updates-from-sucatalog-gz/
For me works perfectly, no more changes of SMBIOS for updates. Just cook install.pkg with macOS update and install as normal application.
 
Joined
Nov 25, 2016
Messages
6
Motherboard
DELL XPS 13 9350
CPU
Intel Core i7-6560U @ 2,2 GHz
Graphics
Intel Iris 540
posted a solution few posts ago.

Right. Sorry about that.

Remove every FakeSMC-related kexts and use the one from v1. Already fixed that in v3, but testing it for now.

Now I am able to log in :)

Looking forward to v3. Thank you for the amazing job.

I don't want to be annoying, but it is easy for a noob like me to get lost between so many posts, some outdated. Fortunately for us, in this thread we all have the same hardware. Is there a "ready to run" solution for the audio? If the patching is done depending on the codecs, here we have the same codecs, right?

Another one: should I copy the kexts from the EFI partition to the Library/Extensions folder? Why?

I truly appreciate your patience guys.
 
Last edited:
Joined
Dec 24, 2016
Messages
3
Funny. Looks almost same as mine :) https://github.com/goodwin/SMBIOSResolver
But even originally it is not my authorship - so better to keep authors in header.

It's not the same, I tried to build your SMBIOSResolver, and placed it under SLE, but no effect. BootCamp still crash, ioreg still shows wrong type. But syscl's version is correct, with right ioreg information and BootCamp can open flawlessly!

I noticed he has credit Voodoo project...already
 
Joined
Jul 10, 2011
Messages
68
Motherboard
Dell XPS 9360
CPU
Intel Core i7-7560U @ 2,4 GHz
Graphics
Intel Iris 640 FHD
Mac
  1. MacBook Air
Mobile Phone
  1. Android
Right. Sorry about that.



Now I am able to log in :)

Looking forward to v3. Thank you for the amazing job.

I don't want to be annoying, but it is easy for a noob like me to get lost between so many posts, some outdated. Fortunately for us, in this thread we all have the same hardware. Is there a "ready to run" solution for the audio? If the patching is done depending on the codecs, here we have the same codecs, right?

Another one: should I copy the kexts from the EFI partition to the Library/Extensions folder? Why?

I truly appreciate your patience guys.
Audio is not ready for daily use right now. They are two semi-working solutions at the moment, but one require installation to SLE, the other one make AppleHDA overloading the CPU and destroying the filesystem on macOS partition. The same is also true for hibernation.
The main issue with the two of the tested audio solutions is the lack of correct headphone jack operation. So I'm waitng for the developers to fix it up so I can produce the v3 out. Which I think gonna be the lastest one for Sierra till they aren't any other fixes out.


They are many "camps" of hackintoshers with different "ideology". The classic way is to use the kexts installed into SLE. Active developement of CLOVER bootloader offered us the possibility to not install the kexts into SLE leaving the installed macOS intact. For me the last option is more attractive as I consider it as more "native" way. However I'm not claiming it is the right and the only working solution. Remember Steve Jobs statement that concurrence is the driving force for the innovation. Even if it's more a collaboration here. So more developers are involved, more approaches used result in more chances to get a fully working hackintosh:thumbup:
 
Status
Not open for further replies.
Top