Contribute
Register

[Guide] Dell XPS 13 9350 macOS 10.12.1

Status
Not open for further replies.
Joined
Mar 20, 2016
Messages
1
Motherboard
Dell XPS 13 9350
CPU
i7 6500U
Graphics
Intel HD 520 w/ qHD
Mobile Phone
  1. iOS
Can you create a step-by-step guide for us noobs?
 
Joined
Nov 17, 2013
Messages
39
Motherboard
Dell XPS 13 9350
CPU
i7 6560U
Graphics
Intel Iris HD 540
Mac
  1. MacBook Pro
I can confirm issues happening with updating to 10.12.1. In /Library/Updates there is a FirmwareUpdate, FullBundleUpdate and macOS10.12.1.pkg. If I run all three installers individually it spits out that there are other additional components needed to complete installation and doesn't perform any installation. I tried to play around and see if SMBios data was the culprit by changing from MacBook Pro 12,1 to 11,1 and verifying the firmware version that was set in config.plist was the most recent and that did not work.

I did not manage to retrieve a log before reboot but I was able to grab it from the Installer log. It shows
Code:
Oct 27 01:54:06 Ilhans-MacBook-Pro Installer[501]: Failed install preflight: Error Domain=PKInstallErrorDomain Code=109
"The package “macOSUpd10.12.1.pkg” requires additional components and cannot be installed independently. Contact the software manufacturer for assistance." UserInfo={NSURL=file://localhost/Library/Updates/031-86699/macOSUpd10.12.1.pkg, PKInstallPackageIdentifier=com.apple.pkg.update.os.10.12.1.16B2555,
NSLocalizedDescription=The package “macOSUpd10.12.1.pkg” requires additional components and cannot be installed independently. Contact the software manufacturer for assistance.}
Oct 27 01:54:06 Ilhans-MacBook-Pro Installer[501]: Install failed.
Oct 27 01:54:06 Ilhans-MacBook-Pro Installer[501]: IFDInstallController D230 state = 8
Oct 27 01:54:06 Ilhans-MacBook-Pro Installer[501]: Displaying 'Install Failed' UI.
Oct 27 01:54:06 Ilhans-MacBook-Pro Installer[501]: 'Install Failed' UI displayed message:'The package “macOSUpd10.12.1.pkg” requires additional components and cannot be installed independently. Contact the software manufacturer for assistance.'.

If it helps, I also managed to upload an image of the installer as well
View media item 187718
 
Last edited:
Joined
Jul 19, 2015
Messages
42
Motherboard
Dell XPS 13 9350
CPU
6200U
Graphics
HD520
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
I can confirm issues happening with updating to 10.12.1. In /Library/Updates there is a FirmwareUpdate, FullBundleUpdate and macOS10.12.1.pkg. If I run all three installers individually it spits out that there are other additional components needed to complete installation and doesn't perform any installation. I tried to play around and see if SMBios data was the culprit by changing from MacBook Pro 12,1 to 11,1 and verifying the firmware version that was set in config.plist was the most recent and that did not work.

I did not manage to retrieve a log before reboot but I was able to grab it from the Installer log. It shows
Code:
Oct 27 01:54:06 Ilhans-MacBook-Pro Installer[501]: Failed install preflight: Error Domain=PKInstallErrorDomain Code=109
"The package “macOSUpd10.12.1.pkg” requires additional components and cannot be installed independently. Contact the software manufacturer for assistance." UserInfo={NSURL=file://localhost/Library/Updates/031-86699/macOSUpd10.12.1.pkg, PKInstallPackageIdentifier=com.apple.pkg.update.os.10.12.1.16B2555,
NSLocalizedDescription=The package “macOSUpd10.12.1.pkg” requires additional components and cannot be installed independently. Contact the software manufacturer for assistance.}
Oct 27 01:54:06 Ilhans-MacBook-Pro Installer[501]: Install failed.
Oct 27 01:54:06 Ilhans-MacBook-Pro Installer[501]: IFDInstallController D230 state = 8
Oct 27 01:54:06 Ilhans-MacBook-Pro Installer[501]: Displaying 'Install Failed' UI.
Oct 27 01:54:06 Ilhans-MacBook-Pro Installer[501]: 'Install Failed' UI displayed message:'The package “macOSUpd10.12.1.pkg” requires additional components and cannot be installed independently. Contact the software manufacturer for assistance.'.

If it helps, I also managed to upload an image of the installer as well
View media item 187718


My computer can't update mac 10.12.1.

please see:https://www.tonymacx86.com/threads/cannot-update-to-10-12-1.205738/#post-1357878 ..
 
Joined
Jul 19, 2015
Messages
42
Motherboard
Dell XPS 13 9350
CPU
6200U
Graphics
HD520
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
I can confirm issues happening with updating to 10.12.1. In /Library/Updates there is a FirmwareUpdate, FullBundleUpdate and macOS10.12.1.pkg. If I run all three installers individually it spits out that there are other additional components needed to complete installation and doesn't perform any installation. I tried to play around and see if SMBios data was the culprit by changing from MacBook Pro 12,1 to 11,1 and verifying the firmware version that was set in config.plist was the most recent and that did not work.

I did not manage to retrieve a log before reboot but I was able to grab it from the Installer log. It shows
Code:
Oct 27 01:54:06 Ilhans-MacBook-Pro Installer[501]: Failed install preflight: Error Domain=PKInstallErrorDomain Code=109
"The package “macOSUpd10.12.1.pkg” requires additional components and cannot be installed independently. Contact the software manufacturer for assistance." UserInfo={NSURL=file://localhost/Library/Updates/031-86699/macOSUpd10.12.1.pkg, PKInstallPackageIdentifier=com.apple.pkg.update.os.10.12.1.16B2555,
NSLocalizedDescription=The package “macOSUpd10.12.1.pkg” requires additional components and cannot be installed independently. Contact the software manufacturer for assistance.}
Oct 27 01:54:06 Ilhans-MacBook-Pro Installer[501]: Install failed.
Oct 27 01:54:06 Ilhans-MacBook-Pro Installer[501]: IFDInstallController D230 state = 8
Oct 27 01:54:06 Ilhans-MacBook-Pro Installer[501]: Displaying 'Install Failed' UI.
Oct 27 01:54:06 Ilhans-MacBook-Pro Installer[501]: 'Install Failed' UI displayed message:'The package “macOSUpd10.12.1.pkg” requires additional components and cannot be installed independently. Contact the software manufacturer for assistance.'.

If it helps, I also managed to upload an image of the installer as well
View media item 187718


Solve . use smbios :IMAC17.1 . update mac10.12.1.
 
Joined
Oct 6, 2016
Messages
61
Motherboard
Dell XPS 13 9350 (Clover)
CPU
i7-6560U (100-series)
Graphics
Intel Iris 540/3200 x 1800
I have trouble using your clover folder, each time the computer go on sleep, it shut down. Some time it shutdown when waking from sleep.
 
Joined
Jul 10, 2011
Messages
68
Motherboard
Dell XPS 9360
CPU
Intel Core i7-7560U @ 2,4 GHz
Graphics
Intel Iris 640 FHD
Mac
  1. MacBook Air
Mobile Phone
  1. Android
As the new MacbookPro 13" with no touchbar is a perfect copy of our xps might suppose that the correct ID would be probably the MacBookPro13,1 and for correct support we might start from macOS 10.12.1 which might have native support for iris 540 graphics and thunderbolt 3 ports
 
Joined
Jul 15, 2016
Messages
60
Motherboard
Dell V33HM
CPU
i7-6500u
Graphics
Intel® HD Graphics 520
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
During Verbose mode - my laptop hangs half-way on a random line (i.e. different line every time) generally half way through a word or sentence. Any ideas as to why this might be? Also does anyone know if the SAMSUNG PM951 NVMe m.2 SSD is compatible with any of the kexts out there for NVMe? I've tried patching my own kext for the HackrNVMEFamily.kext and caused a KP but perhaps I was doing something wrong. If someone could link me to guides on how to add kexts to clover, I'd follow that.
 
Joined
May 4, 2014
Messages
52
Mac
Classic Mac
Mobile Phone
During Verbose mode - my laptop hangs half-way on a random line (i.e. different line every time) generally half way through a word or sentence. Any ideas as to why this might be? Also does anyone know if the SAMSUNG PM951 NVMe m.2 SSD is compatible with any of the kexts out there for NVMe? I've tried patching my own kext for the HackrNVMEFamily.kext and caused a KP but perhaps I was doing something wrong. If someone could link me to guides on how to add kexts to clover, I'd follow that.
Try and just inject the patches via Clover, patching the KEXT itself never worked for me...

As the new MacbookPro 13" with no touchbar is a perfect copy of our xps might suppose that the correct ID would be probably the MacBookPro13,1 and for correct support we might start from macOS 10.12.1 which might have native support for iris 540 graphics and thunderbolt 3 ports
Definitely worth a look! Would anyone know how to generate valid SMBIOS values for this model (assuming it isn't in Clover Configurator yet!)

I have trouble using your clover folder, each time the computer go on sleep, it shut down. Some time it shutdown when waking from sleep.
Have you created the ACPI patches yourself? Which model do you have?
 
Joined
Jul 15, 2016
Messages
60
Motherboard
Dell V33HM
CPU
i7-6500u
Graphics
Intel® HD Graphics 520
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Try and just inject the patches via Clover, patching the KEXT itself never worked for me...
How would I go about injecting via clover? And I seem to have been impatient before - apparently I just turned my laptop off too fast in frustration when the apple logo would fade out assuming it's restarting. I'm Still getting KP with any and all NVMe kexts but removing those allows me to open up the System Folder. I've tried in both AHCI and Disabled (or None) in terms of SATA configuration. I also successfully converted my Windows to ACHI - not that that matters...

The kexts that are causing problems are IONVMeFamily and both (either one at a time) of HackrNVMeFamily-10_12_0.kext (which I patched myself) and HackrNVMeFamily-10_11_6.kext which was found in Helicos' CLOVER folder. Also, final note, the CLOVER folder provided by maxexcloo seems to crash at start up every time (not KP, just crash and if in non-verbose mode, show a prohibited sign that would "screen refresh every 45s~ish")

EDIT: That being said, I also kinda might have scrapped your clover config.plist... No hard feelings? :lol:
 
Joined
May 4, 2014
Messages
52
Mac
Classic Mac
Mobile Phone
Pending Update (Not Uploaded):
  • Updated Clover to Clover_v2.3k_r3882
  • Updated Wireless Patches for 10.12.1
  • 10.12.1 Fixes Volume Hotkeys
  • SMBIOS Changed To iMac17,1
  • Removed [sys] Fix PNOT/PPNT Patch (Post)
  • Recreate Power Management SSDT (Post)
  • Recreate NVMe Patch KEXT (Post)
  • Re-Added InjectKexts Detect Mode (Post)
  • More Detailed Notes
This update needs testing (I have to wait for a vanilla 10.12.1 update to download), if anyone has contributions let me know!
I will upload once I am satisfied with stability!
 
Last edited:
Status
Not open for further replies.
Top