Contribute
Register

[Guide] Dell XPS 13 9350 macOS 10.12.1

Status
Not open for further replies.
Joined
Mar 1, 2011
Messages
28
Motherboard
msi p67a-gd65
CPU
i7-2600k
Graphics
xfx 6870
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. eMac
  2. iBook
  3. iMac
  4. Power Mac
  5. PowerBook
Mobile Phone
  1. Android
  2. iOS
I tried to use your clover since my spects are similar, but I cant get pass the first completed apple logo loading screen (the screen right after you hit 'boot into macos sierra installation'. My specs are the same except I got 16 gb of ram and 500 gb of ssd
What exactly happens? Do you get the no smoking symbol sometime after boot? Does it halt at the apple logo? Do you get no apple logo at all? It could be the method you use to create the Mac OS USB installer.
 
Joined
Mar 21, 2013
Messages
60
Motherboard
XPS13 9360
CPU
i7-8550u
Graphics
uhd620
I have the same spec of 9350 but I can't see my SSD in the Disk Utility after I enter the installation. I am using the clover folder provided in #1 and my SSD is XP941. Anyone have any idea?
 
Joined
Mar 21, 2013
Messages
60
Motherboard
XPS13 9360
CPU
i7-8550u
Graphics
uhd620
I have the same spec of 9350 but I can't see my SSD in the Disk Utility after I enter the installation. I am using the clover folder provided in #1 and my SSD is XP941. Anyone have any idea?
If I start the installation from disk rather than from USB, I will get a "still waiting for root devices" and a stop sign.... It seems that it does not recognize my M.2
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
If I start the installation from disk rather than from USB, I will get a "still waiting for root devices" and a stop sign.... It seems that it does not recognize my M.2

What kind of M.2 SSD?
 
Joined
Mar 1, 2011
Messages
28
Motherboard
msi p67a-gd65
CPU
i7-2600k
Graphics
xfx 6870
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. eMac
  2. iBook
  3. iMac
  4. Power Mac
  5. PowerBook
Mobile Phone
  1. Android
  2. iOS
XP941. I believe it is a ACHI SSD as I don't need any NVMe patch for El Capitan.
I was having problems with an AHCI ssd as well. Did you create your own DSDT/SSDT's, or are you using another users files? It most likely makes a difference from what i've seen. I have since made my own files specific for my laptop. However I returned the SSD.
 
Joined
Mar 21, 2013
Messages
60
Motherboard
XPS13 9360
CPU
i7-8550u
Graphics
uhd620
I was having problems with an AHCI ssd as well. Did you create your own DSDT/SSDT's, or are you using another users files? It most likely makes a difference from what i've seen. I have since made my own files specific for my laptop. However I returned the SSD.
I haven't include any DSDT/SSDT yet. May be I could try it first.
Did that help you with the installation?
 
Joined
Mar 21, 2013
Messages
60
Motherboard
XPS13 9360
CPU
i7-8550u
Graphics
uhd620
Check your ACPI configuration.
But is there any difference in ACPI setting between 10.11 and 10.12? Since I can boot with El Capitan but cannot even install Sierra.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I haven't include any DSDT/SSDT yet. May be I could try it first.
Did that help you with the installation?

Make sure your config.plist ACPI settings are correct for having no files in ACPI/patched.

But is there any difference in ACPI setting between 10.11 and 10.12? Since I can boot with El Capitan but cannot even install Sierra.

ACPI settings in config.plist depend on the content in ACPI/patched.
 
Status
Not open for further replies.
Top