Contribute
Register

[Guide] Dell XPS 13 9350 macOS 10.12.1

Status
Not open for further replies.
Joined
May 4, 2014
Messages
52
Mac
Classic Mac
Mobile Phone
@maxexcloo, do you have tips if after changing kexts or config.plist, the mac wont boot, what should we do? Can the safe mode enough to fix, or must use installer and terminal to fix it from there?
I'm not sure, maybe you can boot off a Clover USB stick with fixed configs and KEXTs? I don't typically install to the internal disk until I'm completely certain!

Which one the one on page 1 or page 10?
Either should work fine. See the following post for information on the Page 10 Clover ZIP.

Yes, I thought so too but in my case, I forgot to put NVME kext in the SSD, and it turns out working just fine, is there any consequences later ?
The Clover KEXT Patches should work fine, just be careful with updates (it's recommended you remove them and use the KEXT post install!)

And maxexcloo, how do you get your audio work? Are we must run audio_cloverALC-120.command.zip ? Or it will be handled just with config.plist and the kext?
All you have to do is install cloverHDA.kext post install, it should work!
 
Joined
May 4, 2014
Messages
52
Mac
Classic Mac
Mobile Phone
I am testing my updates from this post. So far:
  • Using my Clover directory the laptop boots perfectly first time off a fresh 10.12.1 installation USB.
  • First stage install off USB completed with no issues!
  • Second stage install off internal disk completed with no issues!
  • Post installation wizard completed fine, booted into desktop!
  • Installed KEXTs.
  • On reboot EVERYTHING works excepting WiFi and the issues listed on the main page (nothing major).
  • Investigating WiFi!
  • Will keep updating as time goes on...
 
Last edited:
Joined
May 4, 2014
Messages
52
Mac
Classic Mac
Mobile Phone
Is anyone aware of a way to make WiFi with the DW1560 work on 10.12.1?
Also, are the following patches even needed under 10.12.1?
Code:
<key>AppleRTC</key>
<true/>
<key>AsusAICPUPM</key>
<true/>
<key>KernelLapic</key>
<true/>
<key>KernelPm</key>
<true/>
 
Joined
Mar 1, 2011
Messages
28
Motherboard
msi p67a-gd65
CPU
i7-2600k
Graphics
xfx 6870
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. eMac
  2. iBook
  3. iMac
  4. Power Mac
  5. PowerBook
Mobile Phone
  1. Android
  2. iOS
Yeah i cant get the DW1560 to work under 10.12.1 either. Could it be smbios related? I've seen that happen before when using an ivy bridge SMBIOS for a MBA.
 
Last edited:
Joined
May 4, 2014
Messages
52
Mac
Classic Mac
Mobile Phone
Continuing the update theme from this post:
  • Readded Boot Graphics Glitch
  • Readded BCM94352-Airport-Extreme-skvo
Short of WiFi everything is perfect with my latest release, once I solve it I'll package and release it all!

EDIT: Testing potential WiFi patch:
  • Removed FakePCIID KEXTs
  • Adding toleda's ssdt_arpt Patches
 
Last edited:
Joined
May 4, 2014
Messages
52
Mac
Classic Mac
Mobile Phone
Yeah i cant get the DW1560 to work under 10.12.1 either. Could it be smbios related? I've seen that happen before when using an ivy bridge SMBIOS for a MBA.
I'm using MacBook9,1 as my SMBIOS, I really think it's the best SMBIOS for this model (due to the truncation bug on MacBookPro), I don't know how to fix it though, did you ever have it working (and which SMBIOS and macOS version did you have?)...
 
Joined
Mar 1, 2011
Messages
28
Motherboard
msi p67a-gd65
CPU
i7-2600k
Graphics
xfx 6870
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. eMac
  2. iBook
  3. iMac
  4. Power Mac
  5. PowerBook
Mobile Phone
  1. Android
  2. iOS
I cant get my DW 1560 to show up on 10.12.0 or 10.12.1 I've been using the macbook 9,1 smbios and the imac 17,1 smbios. However this whole time i've been doing this over USB because I still cant get my PM951 to show up.With the ionvmefamilyborg kext and without it. I have my bios set to SATA. Is there any specific DSDT patch i have to do? I am on bios 1.44, i7-6560u (iris 540) 4k touch, Samsung PM951.
 
Joined
May 4, 2014
Messages
52
Mac
Classic Mac
Mobile Phone
Finally after over a month of work I'm finally ready to call the XPS 13 9350 a suitable daily driver with Sierra 10.12.1, what a ride!

Update Log:
  • Updated Wireless Patches for 10.12.1
  • 10.12.1 Fixes Volume Hotkeys
  • Removed [sys] Fix PNOT/PPNT Patch (Post)
  • Recreate NVMe Patch KEXT (Post)
  • Re-Added InjectKexts Detect Mode (Post)
  • More Detailed Notes
  • Updated To Clover_v2.3k_r3911
  • MacBook9,1 SMBIOS
  • Added HWPEnable
  • Removed SSDT PM Patch
  • Disabled Mouse In Clover
  • Skylake Menu Bar Glitch Fix
  • Readded Boot Graphics Glitch
  • Readded BCM94352-Airport-Extreme-skvo
  • Added toleda's SSDT-ARPT-RP06-4352
  • Readded AppleRTC, AsusAICPUPM, KernelLapic, KernelPm
Pushing to main post now!
 
Last edited:
Joined
Mar 1, 2011
Messages
28
Motherboard
msi p67a-gd65
CPU
i7-2600k
Graphics
xfx 6870
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. eMac
  2. iBook
  3. iMac
  4. Power Mac
  5. PowerBook
Mobile Phone
  1. Android
  2. iOS
I think it's time to buy me a ring then, because I got the SSD recognized!

As it turn's out it's a stupid idea to use someone else's SSDTs. (Who would have thought? :lol:)

Anyway, I deleted everything in the Clover AHCI Folder, set DropTables to false and followed azlvda's suggestion and removed all MatchBuild and MatchOS.

The full Clover Folder is attached. Everyone with a XPS 9350, PM951 and HD520 trying to install 10.12.1 should just be able to copy it to their Install EFI Clover folder.
IT WORKED FOR ME TOO!
 
Status
Not open for further replies.
Top