Contribute
Register

[Guide] Dell XPS 13 9343 Sierra

Joined
Apr 5, 2019
Messages
16
Motherboard
B360M-D3H
CPU
i3-8100
Graphics
UHD630
could it be related to the ssd or the APFS?
I'd try a different SSD. I replaced mine as soon as I got it mainly because I couldn't configure it with more than 256GB during checkout. I'm running a Samsung 850 Evo.
 
Joined
Oct 18, 2012
Messages
113
Motherboard
Dell XPS 9360
CPU
i7-7500
Graphics
hd620
a greeting to all, bring my clover folder for those who want to try. my 9343 is i7 but I think it can work with i5 too. everything works fine with Mojave (volume f2-f3 ,bright fnf11-fnf12,sleep fnins)and also tested with catalina beta .good luck, ciao
 

Attachments

  • Archivio.zip
    4.4 MB · Views: 267
Joined
Oct 9, 2018
Messages
10
Motherboard
Dell XPS 13 9343
CPU
i7
Graphics
HD 5500
a greeting to all, bring my clover folder for those who want to try. my 9343 is i7 but I think it can work with i5 too. everything works fine with Mojave (volume f2-f3 ,bright fnf11-fnf12,sleep fnins)and also tested with catalina beta .good luck, ciao
Is this your complete Clover folder ? With this Clover won´t boot at all for me. Did you installed the catalina beta on an hfs+ or on an afps formated drive ?
 
Joined
Oct 18, 2012
Messages
113
Motherboard
Dell XPS 9360
CPU
i7-7500
Graphics
hd620
this clover is for Mojave on hfs+, for Catalina apfs and replace kext smcvirtual with fakesmc and enjoy
 
Joined
Jan 23, 2011
Messages
106
Motherboard
Dell xps 13 9343
CPU
i5-5200U/0TM99H
Graphics
Intel HD 5500,UHD + Touch Screen
Well, I thought I was good but audio keeps dropping off.

I thought it may have been an issue with VoodooHDA so swapped to AppleALC and injected 23 as others have.

I didn't realise I still needed to probe it with a linux live usb so booted into that and Mojave was fine. This lasted a couple of reboots then dropped out again. Rather than mess with my config, I tried Ubuntu 18.04 live usb but it's not coming back.

I had removed CodecCommander incase that was messing with it (and saw avatecer wasn't using it).

Also tried the AFGlowPowerState and ResetHDA options with no luck (turned them back off afterward).

Code:
<key>Audio</key>
        <dict>
            <key>AFGLowPowerState</key>
            <false/>
            <key>Inject</key>
            <integer>23</integer>
            <key>ResetHDA</key>
            <false/>

I've attached IOReg and Audio details from when it was last working.
We are on the same boat. I have the same issue and I don't know how to fix it besides booting with live ubuntu usb. Check my files for comparison.
 

Attachments

  • debug_1055.zip
    5.6 MB · Views: 118
Joined
Oct 18, 2012
Messages
113
Motherboard
Dell XPS 9360
CPU
i7-7500
Graphics
hd620
config.plist devices id inject 13 no 23,other folder insert applealc.kext, if you have 23 on dsdt replace 13
 
Joined
Jan 23, 2011
Messages
106
Motherboard
Dell xps 13 9343
CPU
i5-5200U/0TM99H
Graphics
Intel HD 5500,UHD + Touch Screen
config.plist devices id inject 13 no 23,other folder insert applealc.kext, if you have 23 on dsdt replace 13
layout-id 23 is for our model as per apleALC change log
  • Added ALC288 layout-id 23 for Dell XPS 9343 by yyfn
 
Joined
Oct 9, 2018
Messages
10
Motherboard
Dell XPS 13 9343
CPU
i7
Graphics
HD 5500
a greeting to all, bring my clover folder for those who want to try. my 9343 is i7 but I think it can work with i5 too. everything works fine with Mojave (volume f2-f3 ,bright fnf11-fnf12,sleep fnins)and also tested with catalina beta .good luck, ciao
The APFS drivers are a problem. Colver doesn't boot if i have them in my folder. After a little bit of research it seems like more people with our device have this problem. Dont know whats the problem right now.
 
Joined
Sep 13, 2011
Messages
73
Motherboard
Dell XPS 13 9343 QHD
CPU
i7-5500U
Graphics
HD 5500
Mobile Phone
  1. Other
I'm running a QHD 9343 with an i7 and none of the EFI dumps provided seems to work. I'm running out of ideas, only the older Sierra-era Clover bootloaders seem to bring up a GUI. Any suggestions? Are APFS drivers a cause for this?
 
Joined
Sep 13, 2011
Messages
73
Motherboard
Dell XPS 13 9343 QHD
CPU
i7-5500U
Graphics
HD 5500
Mobile Phone
  1. Other
I managed to load the APFS driver manually:
1) Change file extension of the ApfsDriverLoader to something other than .efi (like "nonefi")
2) Boot into Clover
3) Start the shell
4) fs0:
5) cd EFI/CLOVER/drivers64UEFI
6) load ApfsDriverLoader.nonefi
7) exit

This way the after exiting the shell Clover will show the APFS drives.

A way this could work in the long run and keeping a vanilla installation:
1) Use the shell as the bootloader (add entry in the BIOS setup)
2) set up a startup.nsh startup script to load the driver and then clover
 
Last edited:
Top