Contribute
Register

Guide Dell Optiplex 9030 All in One

Joined
Aug 13, 2017
Messages
169
Motherboard
Dell Inspiron 3670 DT
CPU
i7-9700K
Graphics
UHD 630 / RX570
Mobile Phone
  1. iOS
hi guys and thank you minihack for your awesomely detailed description. I almost don't dare to ask for 10.15.5 support because I don't even get to the install screen (neither with config.plist from post #1 nor #3 but I tried #3 despite the fact that it should only be used for post-installation but it was the only one left and did not produce the black screen in verbose mode). May I ask for sharing the efi folder? How did you manage to get to the install screen? Any updates for 10.15.5(6 in the future?)? As with 10.15.5, it stops at the line with crosses/plusses. Which port do you recommend for the thumbdrive? It's the HD4600 model that I use.
TIA!
I'm using 10.15.5 just fine. Attached is my EFI folder, but config.plist has serial numbers removed, so generate/use your own.
 

Attachments

  • EFI.zip
    8.3 MB · Views: 80
Last edited:
Joined
Aug 1, 2016
Messages
176
Motherboard
HP Probook 430 G2
CPU
i5 5200
Graphics
HD 5500
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I'm using 10.15.5 just fine. Attached is my EFI folder, but config.plist has serial numbers removed, so generate/use your own.
Hi Hat-Trick and thank you so much for your reply! Unfortunately, I cannot pull it off with your folder. Even adding hfsplus.efi doesn't do the trick claiming that it won't be working on this platform. Reason: OVNGWR. Is this the post-installation efi? I would be very thankful for further information. Which version did you come from? Is a clean fresh installation of 10.15.5 even possible with your folder? Thank you so much in advance.
 
Joined
Aug 13, 2017
Messages
169
Motherboard
Dell Inspiron 3670 DT
CPU
i7-9700K
Graphics
UHD 630 / RX570
Mobile Phone
  1. iOS
Hi Hat-Trick and thank you so much for your reply! Unfortunately, I cannot pull it off with your folder. Even adding hfsplus.efi doesn't do the trick claiming that it won't be working on this platform. Reason: OVNGWR. Is this the post-installation efi? I would be very thankful for further information. Which version did you come from? Is a clean fresh installation of 10.15.5 even possible with your folder? Thank you so much in advance.
As you can see, I chimed in on post #7 and installed 10.15.4 in the beginning, and updated to 10.15.5. So, yes, the EFI above is a post-install (working) EFI folder.

I think I still have my USB installer, so let me check and if so, I will post that EFI folder.
 
Joined
Aug 1, 2016
Messages
176
Motherboard
HP Probook 430 G2
CPU
i5 5200
Graphics
HD 5500
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Do you remember what you have changed? Because the way minihack recommends (latest clover + guide) doesn't work out. Is it crucial that the drivers (not kexts) are being located in the old-fashioned folder structure? One combo does seem to pave the way to the installation screen (unibeast 10.3.0 + 10.15.0 Catalina) but the last step of the installation comes to a halt with a garbled loading screen. So sad. A helping hand would be much appreciated.
 
Joined
Aug 13, 2017
Messages
169
Motherboard
Dell Inspiron 3670 DT
CPU
i7-9700K
Graphics
UHD 630 / RX570
Mobile Phone
  1. iOS
Do you remember what you have changed? Because the way minihack recommends (latest clover + guide) doesn't work out. Is it crucial that the drivers (not kexts) are being located in the old-fashioned folder structure? One combo does seem to pave the way to the installation screen (unibeast 10.3.0 + 10.15.0 Catalina) but the last step of the installation comes to a halt with a garbled loading screen. So sad. A helping hand would be much appreciated.
I could not find the installer, and the one Catalina installer I do have freezes part way though if I use it to start an installation.

I know I pretty much followed the directions in the post and at least got through the installation, though.
 
Joined
Aug 1, 2016
Messages
176
Motherboard
HP Probook 430 G2
CPU
i5 5200
Graphics
HD 5500
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
may I dare to update all my questions for 10.15.6? Didn't expect that to happen so soon.
Update: using guide from #1 with 10.15.6 also causes black screen after hitting enter button. Not even verbose mode can show anything for a troubleshooting attempt because of the screen simply turning black. I'm at a loss. How did you people do that? Even worse, current unibeast (10.3.0) cannot create the installer automatically. Manual setup doesn't yield different results. The worst machine I ever had to deal with.
 
Last edited:
Joined
Aug 1, 2016
Messages
176
Motherboard
HP Probook 430 G2
CPU
i5 5200
Graphics
HD 5500
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
ref: Release v5.0 r5116
Thanks for the guide. I inherited an i7-4790S 9030 AIO and with the help of this guide installed Catalina 10.15.4.

Everything works as described in post #1.
One more request if I may - I would like to reproduce the very exact usb thumb drive you created with 10.15.4. Which Clover version did you use? Your post was May 14. Is it possible that you used Clover Release v5.0 r5116 which was uploaded on May 6? I would be very thankful if you could help me with this. What type of thumb drive did you use? Kensington used to prove as a reliable foundation for installers. TIA
 
Joined
Aug 13, 2017
Messages
169
Motherboard
Dell Inspiron 3670 DT
CPU
i7-9700K
Graphics
UHD 630 / RX570
Mobile Phone
  1. iOS
ref: Release v5.0 r5116

One more request if I may - I would like to reproduce the very exact usb thumb drive you created with 10.15.4. Which Clover version did you use? Your post was May 14. Is it possible that you used Clover Release v5.0 r5116 which was uploaded on May 6? I would be very thankful if you could help me with this. What type of thumb drive did you use? Kensington used to prove as a reliable foundation for installers. TIA
It looks like I probably used r5102-UEFI.

I wish I could say for sure which USB drives I used. I run an IT business and my shop has all sorts of stuff in it, with all sorts of things going on at any one time. My "normal" USB thumb drives I use are Sandisk Ultra Flair (USB 3.0) and Samsung BAR Plus (USB 3.0).
 
Joined
Aug 1, 2016
Messages
176
Motherboard
HP Probook 430 G2
CPU
i5 5200
Graphics
HD 5500
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
It looks like I probably used r5102-UEFI.

I wish I could say for sure which USB drives I used. I run an IT business and my shop has all sorts of stuff in it, with all sorts of things going on at any one time. My "normal" USB thumb drives I use are Sandisk Ultra Flair (USB 3.0) and Samsung BAR Plus (USB 3.0).
Thank you for this information. As I was looking for the 5102 version I realised that the current clover version (5120) I use is labelled as "pre-release". Maybe that is the reason why 10.15.6 won't work (yet). Thanks to you I stumbled over the GitHub page again. I guess I have to change my mind and sit and wait until the pre-release status is updated. In the meantime I welcome any other piece of information to get this thing airborne. Anyone in here he would like to experiment with open core?

update1: label "pre-release" has been changed to "latest release". Interesting: OpenCore features have been included. Heaven is sending us a sign for our Dells?

update2: my Sandisk drives don't seem to make a difference. I used your 5102 release (and 10.15.4 of course) and it causes a black screen as per guide in post 1. I'm kinda lost here.
BTW why did you (have to) remove your EFI folder and strike through your comment on the attached file/folder? Why is it that so many kexts from tonymac's download section have disappeared?
 
Last edited:
Joined
Jul 20, 2020
Messages
8
Motherboard
T430S
CPU
i7
Graphics
Intel HD
If you figure it out please post the solution, I have done this on a Lenovo T430s laptop easily, but I am just getting a black screen on this dell... :(
 
Top