Contribute
Register

[Guide] Dell Inspiron 15 7559 (skylake)

Joined
May 14, 2020
Messages
31
Motherboard
asus m5a99
CPU
8320e
Graphics
rx580 with 10.15.4
Here is a screenshot by screenshot tutorial now it is very important you use this exact clover as it install legacy properly and is before the O.C merger.
Use this clover pkg, it is only used for accessing the legacy boot grey menu not for actual efi usage****
Remember, when using the usb for clover i.e. USB1, make sure you select legacy boot usb in bios and as soon as you see 7 unplug the clover usb!
 

Attachments

  • Clover_r5118 (1).pkg.zip
    14.4 MB · Views: 71
Last edited:
Joined
May 14, 2020
Messages
31
Motherboard
asus m5a99
CPU
8320e
Graphics
rx580 with 10.15.4
The last step after you are sure everything is stable, is to have a working macOS install on the laptop and install the specified clover efi settings in your macOS efi, but before shutting down, move these 3 corrupted files to the top of the efi partition and MAKE SURE to replace the efi folder with your proper open core efi. Again, do this after you have been able to successfully get to the grey screen over and over and open your open core efi successfully. This crazy multi step process was the only way I could get big sur on my 7559s as Open Core is pretty much needed for Big Sur. Getting 11.1 was actually easier on my AMD 8320e machine as this bios issue is so weird on the Dell 7559 and is why some get stuck on ---** on clover and black screens on Open Core.
 

Attachments

  • Archive.zip
    351.5 KB · Views: 57
Last edited:
Joined
Apr 11, 2021
Messages
11
Motherboard
Dell 7559
CPU
i5-6300HQ
Graphics
GTX 960M
Here is a screenshot by screenshot tutorial, now it is very important you use this exact clover, as it creates a legacy (7) boot device properly and is before the O.C merger.
The clover usb requires booting with lagecy, right?
 
Joined
Jul 14, 2019
Messages
71
Motherboard
Dell 7559
CPU
i7-6700HQ
Graphics
GTX 960M
I have found a way to get UEFI to boot and work every single time on the 7559 i5 non 4k and i7 full 4k. It involves using the boot maintenance manager grey screen as it is called. If you need help let me know. I now have a flawless open core big sur on both of my dell 7559s. A way to test this, is to have a legacy configured open core or clover usb. Make sure it flashes 7 before going to whichever, now boot your dell as you normally would but right when you see 7, unplug the usb. This will take you to the grey screen I am talking about, and it is the key to stable UEFI open core on these machines. Once you are at this screen with another blank usb thumb-drive that only has the UEFI efi file on it, without it being partitioned( if it is partitioned with say legacy mbr clover or opencore, it will just attempt to boot from this opencore or clover installation incorrectly) plugged in, navigate to your uefi opencore and boot it. This is done by opening the boot maintenance manager folder, and then selecting boot from file, then navigating to your opencore.efi file. I used a legacy thumb-drive to remove and a nonbootloader-formatted UEFI thumb-drive with the opencore efi folder just sitting in it and it worked great. A way to finalize this is to corrupt the legacy boot, boot0, and boot1f32 files, I did so by using all the clover legacy boot files in my opencore efi hdd efi partition. This way it always boots to the grey screen. This is convoluted at first but it was the only way I could progress from legacy only to UEFI with the newest 7559 bios and no battery ribbon unplug. The only problem is the grey screen is extremely small on the 4k model.
Hi. Does your combo jack work fine? (auido+mic). Mine sometimes doesn't work after waking from sleep and then I have to restart a couple of time until it works.
 
Joined
May 14, 2020
Messages
31
Motherboard
asus m5a99
CPU
8320e
Graphics
rx580 with 10.15.4
Hi. Does your combo jack work fine? (auido+mic). Mine sometimes doesn't work after waking from sleep and then I have to restart a couple of time until it works.
Yes it does! A good DSDT and SSDT as well as this weird step fixes a lot!
 
Joined
Jul 14, 2019
Messages
71
Motherboard
Dell 7559
CPU
i7-6700HQ
Graphics
GTX 960M
Yes it does! A good DSDT and SSDT as well as this weird step fixes a lot!
What fix are you using for the combo jack? Verbstub.kext or something else? If you can post your OC folder that would be of great help.
Thanks.
 
Joined
May 14, 2020
Messages
31
Motherboard
asus m5a99
CPU
8320e
Graphics
rx580 with 10.15.4
I don’t think my efi is any special I modified another users efi if you look in my post history. This is what fixed my combo jack!
 

Attachments

  • ComboJack-master.zip
    643.7 KB · Views: 39
Top