Contribute
Register

[Guide] Dell Inspiron 15 7559 (skylake)

Joined
Dec 12, 2020
Messages
4
Motherboard
Dell 7559
CPU
i7-6700HQ
Graphics
HD 530
Mac
  1. MacBook Pro
Try to use my config (for me works everything correctly):
I can't boot with your EFI in BigSur, but I can boot with the EFI of @slipanot. To fix your brightness control you have to patch SSDT-PNLF.aml or you use any?
 
Joined
Apr 12, 2018
Messages
44
Motherboard
Dell Inspirion 7559 (OpenCore)
CPU
i7-6700HQ/HM170
Graphics
HD530, UHD (3840x2160)
I can't boot with your EFI in BigSur, but I can boot with the EFI of @slipanot. To fix your brightness control you have to patch SSDT-PNLF.aml or you use any?
@slipanot disabled security boot, it’s not a good idea, better if you fix security boot option. Read my post to the end there is a link to instructions on how to fix it.
if it's too complicated then just set Disabled on Misc —> Security —> SecureBootModel
 
Last edited:
Joined
Sep 27, 2016
Messages
182
Motherboard
Gigabyte Aorus z390 Elite
CPU
i7-9700K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
Thank you all! I finished move to OpenCore and BigSur.
At the moment, fixed all issues actual for me except 4k@48Hz.
This config is a compilation of the config from the first post and @slipanot config
What is added or changed:
1. alcid = 16 - need to work 2.1 speaker with subwoofer
2. alc-verb_jack_fix or ALCPlugFix-Swift - two methods for fix hotplug headphones jack
3. enabled SSD trim by deafult
4. changing igpu device property (4k@60Hz on Catalina, 4k@48Hz on Big Sur, HDMI, 2048Mb VRAM)
5. SSDT-DGPU.aml - Nvidia dGPU off
6. SSDT-BTNB.aml - Backlight fn buttons work together with patch:
change Method _Q80 to XQ80, pair with SSDT-BTNB.aml
change Method _Q81 to XQ81, pair with SSDT-BTNB.aml
7. Using MacBookPro13,2 (required for working HDMI and Big Sur correctly and smoothly (BigSur had a lot of lags with MacBookPro13,3)

Not used and not tested by me:
1. Built-in card reader (before I used Sinetek-rtsx.kext but stability and speed did not suit me)
3. DRM on Safari

Also I disabled SMCDellSensors.kext as it causes sound lags for me.

If you have Secure Boot Violation error read this post:
I noticed your not using the EDID patch in your config list. Are you able to get the internal screen working in Big Sur without it?
 
Joined
Apr 12, 2018
Messages
44
Motherboard
Dell Inspirion 7559 (OpenCore)
CPU
i7-6700HQ/HM170
Graphics
HD530, UHD (3840x2160)
@slipanot, yes, display working in Big Sur without EDID:
1608033854858.png
 
Joined
Apr 12, 2018
Messages
44
Motherboard
Dell Inspirion 7559 (OpenCore)
CPU
i7-6700HQ/HM170
Graphics
HD530, UHD (3840x2160)
@slipanot yes, 48hz, it seems so far this issue cannot be solved in Big Sur. We are waiting for new Lilu and WhateverGreen.
 
Joined
May 15, 2020
Messages
45
Motherboard
Dell Inspiron 15 7559
CPU
i7 6700k
Graphics
530
Mac
  1. Mac Pro
After recover the windows 10 boot (hda), I lost the OSX (hdb). Neither clover or OC sees the osx partition.
I'm installing everything again.
Thoughs how to use windows 10 and osx with opencore without problems?
Thanks
 
Last edited:
Joined
May 15, 2020
Messages
45
Motherboard
Dell Inspiron 15 7559
CPU
i7 6700k
Graphics
530
Mac
  1. Mac Pro
Try to use my config (for me works everything correctly):
Greetings, I had some problems with that EFI
When I boot with HDMI plugged, my laptop screen goes blanc.
The OC boots creen resolution goes too big
I'm using Bios 1.2.4, and tested 2.9, 3.0 and 3.1
I have some UEFI and Legacy issues, sometimes boots, sometimes does not.
My 7559 is i7 non 4k.
Thanks

In time, Bios 1.3.1.
I have to boot, change do Legacy, then reboot and change do UEFI (without legacy), after that the system boots ok.
 
Last edited:
Joined
Apr 12, 2018
Messages
44
Motherboard
Dell Inspirion 7559 (OpenCore)
CPU
i7-6700HQ/HM170
Graphics
HD530, UHD (3840x2160)
The OC boots creen resolution goes too big
Yes, since my config for 4k display, you should change UIScale to 1 for fhd screen
You had a config where everything worked 3 days ago. Why change something?
 
Joined
May 15, 2020
Messages
45
Motherboard
Dell Inspiron 15 7559
CPU
i7 6700k
Graphics
530
Mac
  1. Mac Pro
Yes, since my config for 4k display, you should change UIScale to 1 for fhd screen
You had a config where everything worked 3 days ago. Why change something?
The Win10 messed with my osx partition, I don't know how.
I had do reinstall everything, then tested your efi, and the wifi and bluetooth works better than mine.
My only issue now is the boot, it's only works manually, booting with F12, selecting the uefi set, just if is settled wiith Legacy, no UEFI works.
 
Top