Contribute
Register

[Guide] Dell Inspiron 15 7559 (skylake)

Joined
May 14, 2020
Messages
31
Motherboard
asus m5a99
CPU
8320e
Graphics
rx580 with 10.15.4
Thats good. Can you check if you are able to get 60Hz refresh rate or 48 Hz?
You can check here:
On my 4k I only get 49hz which is okay because thats the pixel clock patch I used previously to make 4k work on macos. Cdfon and a pixel clock patch was needed befor in Catalina for my 4k set, but in Big sur I had to do the edid patch and I think the python patcher locks the refresh rate to 49hz but at least it displays. My i5 1080p 7559 gets 60hz. Both are 60hz in linux and windows. Do you know of anyway to patch the backlight keys properly or force max brightness on boot? Also thank you so much for all of the help!!!
 
Last edited:
Joined
Jul 14, 2019
Messages
69
Motherboard
Dell 7559
CPU
i7-6700HQ
Graphics
GTX 960M
On my 4k I only get 49hz which is okay because thats the pixel clock patch I used previously to make 4k work on macos. Cdfon and a pixel clock patch was needed befor in Catalina for my 4k set, but in Big sur I had to do the edid patch and I think the python patcher locks the refresh rate to 49hz but at least it displays. My i5 1080p 7559 gets 60hz. Both are 60hz in linux and windows. Do you know of anyway to patch the backlight keys properly or force max brightness on boot? Also thank you so much for all of the help!!!
Same here. I get 48 Hz too. The brightness works fine for me using Fn + F11/F12 (I am using the Opencore EFI attached in the first post. Patching EDID did nothing for me. I was able to boot directly without patching the EDID and after patching it is the same.)
I do not know how to fix the backlight keys. Maybe try the EFI in the first post and just add your patched EDID and see if it works.
 
Joined
Sep 27, 2016
Messages
182
Motherboard
Gigabyte Aorus z390 Elite
CPU
i7-9700K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
49Hz is all I'm getting on my 4k display. Im guessing this is do to the EDID patching?
 
Joined
May 14, 2020
Messages
31
Motherboard
asus m5a99
CPU
8320e
Graphics
rx580 with 10.15.4
49Hz is all I'm getting on my 4k display. Im guessing this is do to the EDID patching
Yep I'm guessing this is what makes it work from the edid patch
 
Joined
May 14, 2020
Messages
31
Motherboard
asus m5a99
CPU
8320e
Graphics
rx580 with 10.15.4
Yep from what I see that's the only thing that fixes the 4k for now
I am not sure why this is the case. I had 60Hz on Catalina on the same 4k display.
yeah I had 60hz in Catalina as well but I would lose display every other boot.
 
Joined
Sep 27, 2016
Messages
182
Motherboard
Gigabyte Aorus z390 Elite
CPU
i7-9700K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
I am not sure why this is the case. I had 60Hz on Catalina on the same 4k display.
Same here. I never had any issues with the display until Big Sur. Very strange.
 
Joined
Jul 14, 2019
Messages
69
Motherboard
Dell 7559
CPU
i7-6700HQ
Graphics
GTX 960M
Same here. I never had any issues with the display until Big Sur. Very strange.
It hasn't got anything to do with BigSur apparently. But with the EFI folder you are using.
I currently have Catalina installed. I can get 60Hz using Clover 5122. If I use OpenCore to boot the same Catalina installation, I get 48 Hz.
 
Joined
Apr 12, 2018
Messages
44
Motherboard
Dell Inspirion 7559 (OpenCore)
CPU
i7-6700HQ/HM170
Graphics
HD530, UHD (3840x2160)
It hasn't got anything to do with BigSur apparently. But with the EFI folder you are using.
I currently have Catalina installed. I can get 60Hz using Clover 5122. If I use OpenCore to boot the same Catalina installation, I get 48 Hz.
About 48Hz, it's ussue BigSur + Lilu.
On Catalina we used boot flag -cdfon and enable-hdmi20 to get fully support 4k display with 60Hz framerate. But at this moment on Big Sur enable-hdmi20 is unusable since user space patching is disabled. Also there's no binary at /System/Library/Frameworks/CoreDisplay.framework/Versions/A/CoreDisplay

With latest Lilu the enable-hdmi20 still not work. Just wait for a fully functional Lilu first.

Also with Big Sur, quite a bit broke. Mainly the following:
  • Lilu
    • Mainly user-space patching has severely broke, meaning certain functionality may have broken
    • These include:
      • DiskArbitrationFixup
      • MacProMemoryNotificationDisabler
      • SidecarEnabler
      • SystemProfilerMemoryFixup
      • NoTouchID
      • WhateverGreen's DRM and -cdfon patches
 
Last edited:
Joined
May 15, 2020
Messages
45
Motherboard
Dell Inspiron 15 7559
CPU
i7 6700k
Graphics
530
Mac
  1. Mac Pro
Finally got Big Sur to run on my Dell 7559. The patched EDID method worked. It allows me to upgrade or Clean install to Big Sur!. Everything works as normal. Thanks so much @Heisenberg68 for bringing this to my attention. Who would have known. Ive run High Sierra, Mojave and Catalina on this laptop and have never needed my EDID patched. Big Sur will not boot without it being patched. My EFI is attached if it'll help anyone else.
Thanks for sharing, it's worked here, the touchpad works like charm.
To work the screen the EDID was removed, and the layout-id changed to 1B19000 (Intel HD 530) non 4k 7559.
The headphone Jack and HDMI video didn't works.
Could you please help me with the Jack and HDMI?
 
Top