Contribute
Register

[Guide] Dell Inspiron 15 7559 (skylake)

Joined
Nov 21, 2020
Messages
6
Motherboard
Inspiron 15 7000 Series 7559
CPU
i7-6700HQ
Graphics
HD 530
Hey sorry if this sounds like a stupid question, trying to figure out the best way to install Catalina and later Big Sur if I can get it working on my 7559 1080...what the best way as a fresh install to start. I presume I don't need to go back to Mojave and just need Catalina. Trying to understand your first post. thanks
 
Joined
Nov 17, 2020
Messages
4
Motherboard
Dell Inspiron 7559 with 4K touch screen
CPU
i7-6700HQ
Graphics
HD 530
Mobile Phone
  1. Android
Looking for some assistance if possible. No matter what, Im not able to update to Big Sur with this laptop. I have tried clean installs and upgrades from Catalina with no success. If I am able to finally make it through the upgrade process the machine boots to a black screen. Everything in Catalina up to this point works flawless. I have no issues. I have been able to upgrade to upgrade to Big Sur on all my other machines without issues. Even my AMD machine went flawless. So I'm stumped. If anyone has any advice it would be much appreciated.
when boot bigsur to blackscreen, try to wait about half a minute.
I need to wait about 30 seconds when boot Blackscreen, then it display apple logo again.
I my 7559 laptap, bigsur boot seqence:
boot menu->apple logo->black screen(26 seconds) -> apple logo->login.
 
Joined
Jul 14, 2019
Messages
70
Motherboard
Dell 7559
CPU
i7-6700HQ
Graphics
GTX 960M
Looking for some assistance if possible. No matter what, Im not able to update to Big Sur with this laptop. I have tried clean installs and upgrades from Catalina with no success. If I am able to finally make it through the upgrade process the machine boots to a black screen. Everything in Catalina up to this point works flawless. I have no issues. I have been able to upgrade to upgrade to Big Sur on all my other machines without issues. Even my AMD machine went flawless. So I'm stumped. If anyone has any advice it would be much appreciated.
I also have the 4k touch model. The opencore efi folder attached in the first post worked just fine. I was on Catalina before and updated to Big Sur without any issues.
Maybe you cannot boot due to BIOS version? Or maybe some setting in the BIOS is not correct?
 
Joined
Sep 27, 2016
Messages
186
Motherboard
Gigabyte Aorus z390 Elite
CPU
i7-9700K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
MacBookPro13,1 would be a better choice in smbios
I also have the 4k touch model. The opencore efi folder attached in the first post worked just fine. I was on Catalina before and updated to Big Sur without any issues.
Maybe you cannot boot due to BIOS version? Or maybe some setting in the BIOS is not correct?
Thats possible. What BIOS Version are you running?
Ive never been able to update to the latest BIOS version on this laptop. V1.3.1. Windows will boot on it but I've never been able to get Mac to boot with this BIOS version. Is there some setting I'm missing?
 
Last edited:
Joined
Nov 21, 2020
Messages
6
Motherboard
Inspiron 15 7000 Series 7559
CPU
i7-6700HQ
Graphics
HD 530
Booted from USB and was formatted SSD for macOS and installed Big Sur, it rebooted to this screen and just keeps rebooting after Dell logo...these two options in boot menu are open core and the SSD but both just case the boot loop. Is it because of a partition on the SSD or something related to the bios/recovery? If I unplug the USB I get the check media presence message. thanks
 
Joined
Jul 14, 2019
Messages
70
Motherboard
Dell 7559
CPU
i7-6700HQ
Graphics
GTX 960M
Thats possible. What BIOS Version are you running?
Ive never been able to update to the latest BIOS version on this laptop. V1.3.1. Windows will boot on it but I've never been able to get Mac to boot with this BIOS version. Is there some setting I'm missing?
BIOS 1.2.4
Here are my settings
 

Attachments

  • 1.jpeg
    1.jpeg
    89.9 KB · Views: 75
  • 2.jpeg
    2.jpeg
    67.5 KB · Views: 72
Joined
Sep 27, 2016
Messages
186
Motherboard
Gigabyte Aorus z390 Elite
CPU
i7-9700K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
BIOS 1.2.4
Here are my settings
Im on the same BIOS version. with basically the same setting. I leave intel speed step enabled. It dosent seem to make a difference booting either way. I would leave it enabled though for Power Management. Either way i still cant boot big sur. New install or upgrade. Makes no sense.
 
Joined
Nov 21, 2020
Messages
6
Motherboard
Inspiron 15 7000 Series 7559
CPU
i7-6700HQ
Graphics
HD 530
Boots into Big sur after installing, everything works fine apart from WIFI and Bluetooth but I need to install the WIFI card that's compatible so should be ok. What I noticed is when the screen goes to sleep upon starting it again its all static looking with lines and doesn't go away until I do a restart. Possibly the bios? Also is there anyway to get HDMI working, using the OC 6.0.3 zip above as I haven't made any changes.
 
Joined
Jul 14, 2019
Messages
70
Motherboard
Dell 7559
CPU
i7-6700HQ
Graphics
GTX 960M
Boots into Big sur after installing, everything works fine apart from WIFI and Bluetooth but I need to install the WIFI card that's compatible so should be ok. What I noticed is when the screen goes to sleep upon starting it again its all static looking with lines and doesn't go away until I do a restart. Possibly the bios? Also is there anyway to get HDMI working, using the OC 6.0.3 zip above as I haven't made any changes.
install this:

Wifi and bluetooth work just fine
If you use itlwm, you will need heliport.

If you use airportiwltm, it supports native macwifi and airdrop too.
 
Joined
Sep 27, 2016
Messages
186
Motherboard
Gigabyte Aorus z390 Elite
CPU
i7-9700K
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
Top