Contribute
Register

[Guide] Dell Inspiron 15 7559 El Capitan Hackintosh (Dual Boot With Windows)

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,285
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
this guide is nice incl. the efi folders. but i have a problem booting into the installer.
Not the 2 lines of text but the cheksum looks like the problem. (Image included).

bios settings are propper and rolled back to the bios 1.2.0
used the 4k config.plist for the 4k screen bootintoinstaller

is the installer corupted?

A little help would be great, Thnx in advance!

See main laptop guide:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
 
Joined
Dec 29, 2016
Messages
25
Motherboard
DELL Inspiron 7559 (Clover)
CPU
i7-6700HQ
Graphics
Nvidia 960M 4gb / intel 530HD UHD 4K display
UPDATE: Use latest Clover bootloader

It fixed me a problem of beeing unable to boot after some updates. It also fixed the problem of not beeing able to boot without adapter and booting with 2 screens connected now also works. See the EFI folder if you need help
I've been running my 7559 Hackintosh for almost a year. I have done Apple system updates a few time. Each time after the update I have to boot with my USB Hackintosh Build from this thread. I run the Pixel Clock patch and everything works.

This time I got greedy. I did the Apple update and thought I would update Clover. I copied EFI (Boot after installed3) contents to my EFI partition on my boot drive before I started the Apple update. I did backup my EFI partition to my USB stick just in case of trouble. After the update, my 7559 wouldn't boot into OSX. I tried pushing the the FakeID into Clover which usually works. That didn't help.

I'm at a loss for what to try next. Do I need to start over in the Guide and repeat everything I've done? I have a real MacBook Pro I can use to alter the USB stick. I did try to put my backup of my EFI partition back on the boot. I get the same 3 lines of text at boot and then it hangs.

I'm no pro at this. If anyone can point me to a method to try, I'd appreciate it.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,285
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I've been running my 7559 Hackintosh for almost a year. I have done Apple system updates a few time. Each time after the update I have to boot with my USB Hackintosh Build from this thread. I run the Pixel Clock patch and everything works.

This time I got greedy. I did the Apple update and thought I would update Clover. I copied EFI (Boot after installed3) contents to my EFI partition on my boot drive before I started the Apple update. I did backup my EFI partition to my USB stick just in case of trouble. After the update, my 7559 wouldn't boot into OSX. I tried pushing the the FakeID into Clover which usually works. That didn't help.

I'm at a loss for what to try next. Do I need to start over in the Guide and repeat everything I've done? I have a real MacBook Pro I can use to alter the USB stick. I did try to put my backup of my EFI partition back on the boot. I get the same 3 lines of text at boot and then it hangs.

I'm no pro at this. If anyone can point me to a method to try, I'd appreciate it.

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Dec 29, 2016
Messages
25
Motherboard
DELL Inspiron 7559 (Clover)
CPU
i7-6700HQ
Graphics
Nvidia 960M 4gb / intel 530HD UHD 4K display
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/

This is the EFI/Clover partition less the Themes folder and no content from outside the Clover directory. This is the EFI partition from the USB stick I use to boot. I hold F12 choose USB stick and then choose to boot OS X from the SSD once Clover loads.

This EFI folder, I believe, is the same one I use on the internal SSD. I made a backup of it before I tried putting the new Clover boot loader on my internal SSD.

I included a photo of the boot screen. All 3 lines.

I appreciate the help. I do not fully understand which parts are loading from where. i.e. What portion of the boot is taken from the USB stick and where the SSD contents are loaded. Is only Clover loading from the USB stick or are all of the kernel extensions loading from the USB stick as well. Those sorts of things.
 

Attachments

  • EFI.zip
    2.7 MB · Views: 181

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,285
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
This EFI folder, I believe, is the same one I use on the internal SSD. I made a backup of it before I tried putting the new Clover boot loader on my internal SSD.

Problem reporting files must represent the problem scenario, exactly.
You seem to imply your problem happens with a different version of Clover and that the Clover on your SSD is not the same as the version of Clover you attached in these files.
 
Joined
Dec 29, 2016
Messages
25
Motherboard
DELL Inspiron 7559 (Clover)
CPU
i7-6700HQ
Graphics
Nvidia 960M 4gb / intel 530HD UHD 4K display
Problem reporting files must represent the problem scenario, exactly.
You seem to imply your problem happens with a different version of Clover and that the Clover on your SSD is not the same as the version of Clover you attached in these files.

Let me clarify. I asked too many questions at once.

The attached files are the backup of my working EFI partition from my boot drive. I made this before I did any updating.

Here's the order of events which led to an unbootable machine.
-backup EFI partition from SSD
-Did Apple security update.
-Replaced the Clover folder with Clover, from message #446 in this thread, in my EFI partition of my SSD.
-Restarted, no boot.
-Restarted with my Original USB stick I built this Hackintosh with. Used FakeID 0x12345678 in the graphics injector to start up. This usually works. It didn't this time.
-Replaced the EFI Partition on my USB stick with the backup of my EFI partition. Tried booting. I get 3 lines of text on screen. No boot.

I know I tried multiple ways and times to get it going, but this is where I am now. I even tried the EFI partition (boot after install2) from Johnnnnnnnys original post on page 1 of this thread and I couldn't startup.

Thanks for the help.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,285
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Let me clarify. I asked too many questions at once.

The attached files are the backup of my working EFI partition from my boot drive. I made this before I did any updating.

Here's the order of events which led to an unbootable machine.
-backup EFI partition from SSD
-Did Apple security update.
-Replaced the Clover folder with Clover, from message #446 in this thread, in my EFI partition of my SSD.
-Restarted, no boot.
-Restarted with my Original USB stick I built this Hackintosh with. Used FakeID 0x12345678 in the graphics injector to start up. This usually works. It didn't this time.
-Replaced the EFI Partition on my USB stick with the backup of my EFI partition. Tried booting. I get 3 lines of text on screen. No boot.

I know I tried multiple ways and times to get it going, but this is where I am now. I even tried the EFI partition (boot after install2) from Johnnnnnnnys original post on page 1 of this thread and I couldn't startup.

Thanks for the help.

Use current build of Clover, not some random Clover.
See guide for links:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
 
Joined
Jul 20, 2011
Messages
6
Motherboard
OSX
CPU
3.7
Graphics
amd hd 6870
Mac
Classic Mac
Mobile Phone
If you still get 2 lines. Just unplug battery cable and run laptop with ac power
 
Joined
Mar 16, 2014
Messages
2
Motherboard
Dell 7559 - 0H0CC0
CPU
i7-6700HQ
Graphics
HD 530 + Nvidia GTX960M
Mac
  1. MacBook Air
Mobile Phone
  1. Android
By any chance, can i install El Capitan on this laptop?
please clarify some doubts i have:
Q) Since latest MacOs is High Sierra, can i still make an El Capitan bootable usb because app store won't let me download El Capitan install app?

Q) Is El Capitan more stable on this laptop. I prefer stability over updated OS?
Please suggest me the most stable.

Q) I can have an access to a real Mac (I've to use my college library) but can I proceed using a VM because its a bit risky for me to do this while in my college.

Please respond ASAP.

Edit:- I'm on latest bios version : 1.2.7 if that makes a difference in a process.
 
Joined
Apr 3, 2018
Messages
13
Motherboard
Dell Inspiron 15 (7559)
CPU
i7 2.6ghz
Graphics
nvidia 960m 4gb
Mac
  1. MacBook Pro
my screen randomly goes blank and will not wake
 
Top