Contribute
Register

[Guide] Dell Inspiron 15 7559 El Capitan Hackintosh (Dual Boot With Windows)

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,950
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Apr 24, 2016
Messages
57
Motherboard
Dell 7559-I75595012GRY (Clover)
CPU
i7-6700HQ/Skylake H07
Graphics
HD530/3840x2160
Mobile Phone
Android
Cool :). Have you used this guide or you had to fix something not mentioned here?
I think I've got a problem here... after completing the guide (including NVIDIA GPU disabling) my battery shows 1:43 h remaining with 91% of charge, is it normal?

[EDIT!] I noticed something... Mac OS X will never tell me the exact battery time remaining. It's weird but with 8x% it lasted 2:45 hours something that's weird because in Windows with High Performance plan active, it says 1 hour 20 minutes at 69% remaining.


Did I do something wrong?
(this may be helpful) how can I be 100% sure that I disabled NVIDIA GPU completely?
and also... should I patch DSDTs and SDSTs again?

Thanks!
 
Last edited:
Joined
Sep 21, 2011
Messages
252
Motherboard
laptop dell 7348,dell 7559 UHD...desktop asrock H97M anniversary edition
CPU
laptop-i7 --. 6700HQ..i5-5200U...desktop -i7-4790k
Graphics
intel hd-5500,530 . desktop --palit nvidia gtx 1060 6gb ram
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
Android
Sebasriodted i got 132 errors when patching for compilation using macisal how did u manage not to have error in patching for compilation
 
Joined
Aug 20, 2012
Messages
164
Motherboard
Dell 0H87XC / Intel HM170
CPU
i7 - 6700hq
Graphics
HD 530, GTX 960m (1080p display)
Mobile Phone
Android
I used this guide but I have some suggestions...

- Disable the system recovery threshold in BIOS. (sometimes it causes the machine to enter Dell's recovery mode)
- Rename bootmgfw.efi to bootmgfw-old.efi in EFI\Microsoft\Boot. Otherwise Windows Bootloader could bypass Clover.
- Don't defrag the drive. I didn't experimented this now but I won't do it, the problem is that before following this guide I had OS X installed and I did defrag the disk on Windows. OS X didn't boot, so DON'T DEFRAG THE DRIVE.


Also, the 4K variation is working 10/10 the only thing I didn't tried yet is battery life, I think it won't last as long as the 1080p variation because of obvious reasons but I should work properly.
- Disabling recovery threshold shouln´t be necessary if you don´t mess with your EFI partition. I never got to that screen after I did everything described here.
- bootmgfw-orig.efi --> I never needed that too. I think this is only for PCs that can´t define boot from efi file.
- Windows 10 is defragmenting automatically and I haven´t had any troubles with it.

--> So far this seems like Bios is booting correctly from the efi file but it searches for the the file only in one particular adress on the disk. Changing anything in EFI partition or defragmenting it may prevent the Bios from finding the right location of clover.efi on the disk so it has to be set again.
- For me it works now with Win10 auto-defrag on and not messing with EFI partition.
I think I've got a problem here... after completing the guide (including NVIDIA GPU disabling) my battery shows 1:43 h remaining with 91% of charge, is it normal?

[EDIT!] I noticed something... Mac OS X will never tell me the exact battery time remaining. It's weird but with 8x% it lasted 2:45 hours something that's weird because in Windows with High Performance plan active, it says 1 hour 20 minutes at 69% remaining.


Did I do something wrong?
(this may be helpful) how can I be 100% sure that I disabled NVIDIA GPU completely?
and also... should I patch DSDTs and SDSTs again?

Thanks!
I would try to check again after a complete battery cycle.
For me it lasts 5 hours browsing web/ 4 hours watching youtube / 1 hour playing a game. For 4K it should be about 30% less.
If the meter still doesn´t show accurate time remaining try to install kext again and repatch DSDT/SSDTs.
Sebasriodted i got 132 errors when patching for compilation using macisal how did u manage not to have error in patching for compilation
Your question is not accurate. Please be more specific about your problem. You have probably created the DSL files wrong. Try to make them again and remember that you have to have all the *SDT.AML files in one folder to decompile properly. There should be no errors when you try to compile DSL files that were created properly. Warning doesn´t matter.
 
Joined
Sep 21, 2011
Messages
252
Motherboard
laptop dell 7348,dell 7559 UHD...desktop asrock H97M anniversary edition
CPU
laptop-i7 --. 6700HQ..i5-5200U...desktop -i7-4790k
Graphics
intel hd-5500,530 . desktop --palit nvidia gtx 1060 6gb ram
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
Android
johnnnny i extracted dsdt.dsl without error but after patching and compiling and save as dsdt.aml it cannot be save due to error
 
Joined
Aug 20, 2012
Messages
164
Motherboard
Dell 0H87XC / Intel HM170
CPU
i7 - 6700hq
Graphics
HD 530, GTX 960m (1080p display)
Mobile Phone
Android
johnnnny i extracted dsdt.dsl without error but after patching and compiling and save as dsdt.aml it cannot be save due to error
What if you try to compile before patching?
 
Joined
Oct 1, 2011
Messages
57
Motherboard
Razer blade 2016 (Clover)
CPU
i7–6700HQ / HM170
Graphics
Intel HD530 / GeForce GTX 970M /3200x1800
Mac
MacBook Pro
Classic Mac
512K, iMac
Mobile Phone
Android, iOS
any idea if I can apply some of that to make my Razer blade 2016 fully functionnal ?
I am missing graphic acceleration, sound, battery status and touchpad...
 
Joined
Apr 24, 2016
Messages
57
Motherboard
Dell 7559-I75595012GRY (Clover)
CPU
i7-6700HQ/Skylake H07
Graphics
HD530/3840x2160
Mobile Phone
Android
- Disabling recovery threshold shouln´t be necessary if you don´t mess with your EFI partition. I never got to that screen after I did everything described here.
- bootmgfw-orig.efi --> I never needed that too. I think this is only for PCs that can´t define boot from efi file.
- Windows 10 is defragmenting automatically and I haven´t had any troubles with it.

--> So far this seems like Bios is booting correctly from the efi file but it searches for the the file only in one particular adress on the disk. Changing anything in EFI partition or defragmenting it may prevent the Bios from finding the right location of clover.efi on the disk so it has to be set again.
- For me it works now with Win10 auto-defrag on and not messing with EFI partition.

I would try to check again after a complete battery cycle.
For me it lasts 5 hours browsing web/ 4 hours watching youtube / 1 hour playing a game. For 4K it should be about 30% less.
If the meter still doesn´t show accurate time remaining try to install kext again and repatch DSDT/SSDTs.

Your question is not accurate. Please be more specific about your problem. You have probably created the DSL files wrong. Try to make them again and remember that you have to have all the *SDT.AML files in one folder to decompile properly. There should be no errors when you try to compile DSL files that were created properly. Warning doesn´t matter.
I'll try again with a full battery charge. Also I noticed that OS X "charges" the battery way too fast, it's weird. If I'm not satisfied with the results, after testing it again, I'll re-patch DSDTs and install the kext again.

PD. When I sad that OS X won't boot anymore I was talking about using OTHER defrag apps (like Defraggler, Vopt9, etc.) but I didn't say I cannot get into Clover, I did get into but OS X simply didn't load.

[EDIT!] I'm noticing some issues here, the GPU is SLOW AS HELL after using some full screen apps or just at music production it's like the memory doesn't accelerate or something.

Then. Screen flickers a lot! :s

[Other EDIT!]

Sometimes when it 'freezes' (not completely hanging but slow) I cannot even log out! I have to manually turn off the hackintosh then turn it on again, RESTART befor loggin and then it'll behave as usually.
And also, OS X battery icon it's completely wrong! I don't know what's happening.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,950
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
any idea if I can apply some of that to make my Razer blade 2016 fully functionnal ?
I am missing graphic acceleration, sound, battery status and touchpad...
Off-topic. This guide is for Dell Insprion 7559.
 
Joined
Sep 21, 2011
Messages
252
Motherboard
laptop dell 7348,dell 7559 UHD...desktop asrock H97M anniversary edition
CPU
laptop-i7 --. 6700HQ..i5-5200U...desktop -i7-4790k
Graphics
intel hd-5500,530 . desktop --palit nvidia gtx 1060 6gb ram
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
Android
johnnnnny here is my extracted DSDT.dsl i used maciasl applied patches there's a lot of error.checked thru compile..but before applying patches i checked thru compile there's no error...what's causes error when applying patches in imaciasl
 

Attachments

Top