Contribute
Register

[Guide] Dell Inspiron 13 5378 (2-in-1) - MacOS 10.12.6

Joined
Aug 22, 2015
Messages
135
Motherboard
Dell Inspiron 5378
CPU
Intel(R) Core(TM) i7-7500U CPU @ 2.90GHz
Graphics
Intel(R) HD Graphics 620
Mac
MacBook Air
Mobile Phone
Android
AH, ok I found it finally. However, when I wipe my USB to FAT32 and copy over the Shell_EFI folder into a folder named EFI it is still not bootable. Am i doing something wrong here?

I also tried copying it onto the install media usb and it is also not recognized

Again, Sorry for the nooby questions
Did you make sure that Secure Boot is disabled? Also, you will want to use the 'F12' boot selection menu when the laptop first turns on, and select EFI_Shell.
 
Joined
Oct 16, 2016
Messages
187
Motherboard
Dell 7560 (Clover)
CPU
i7 7500u/100 Series Chipset
Graphics
Intel HD 620 & NVIDIA® GeForce® 940MX (1920x1080)
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Card Reader
How did you manage to make Card Reader working?
Did it work OOB or have you made some patching or installed any kext?
Thank you.
 
Joined
Aug 22, 2015
Messages
135
Motherboard
Dell Inspiron 5378
CPU
Intel(R) Core(TM) i7-7500U CPU @ 2.90GHz
Graphics
Intel(R) HD Graphics 620
Mac
MacBook Air
Mobile Phone
Android
How did you manage to make Card Reader working?
Did it work OOB or have you made some patching or installed any kext?
Thank you.
Try the SSDT-UIAC.aml attached to this message. I forgot the USB internal port for the card reader when configuring SSDT-UIAC.
 

Attachments

Joined
Oct 16, 2016
Messages
187
Motherboard
Dell 7560 (Clover)
CPU
i7 7500u/100 Series Chipset
Graphics
Intel HD 620 & NVIDIA® GeForce® 940MX (1920x1080)
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Try the SSDT-UIAC.aml attached to this message. I forgot the USB internal port for the card reader when configuring SSDT-UIAC.
So you are saying that it works without any kext. The only thing that you needed to do was to configure USB ports correctly.
Mine is USB too, but it does not work. I disabled it to spend less power because it does not work.
 
Joined
Aug 22, 2015
Messages
135
Motherboard
Dell Inspiron 5378
CPU
Intel(R) Core(TM) i7-7500U CPU @ 2.90GHz
Graphics
Intel(R) HD Graphics 620
Mac
MacBook Air
Mobile Phone
Android
So you are saying that it works without any kext. The only thing that you needed to do was to configure USB ports correctly.
That is correct. I did not configure SSDT-UIAC correctly.

Mine is USB too, but it does not work. I disabled it to spend less power because it does not work.
Not sure what you mean here, but I am pretty sure it uses power regardless of MacOS recognizing it properly. Credit to RehabMan for the clarification below.

You can keep it disabled, and use the SSDT you are currently using.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,090
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Not sure what you mean here, but I am pretty sure it uses power regardless of MacOS recognizing it properly. You can keep it disabled, and use the SSDT you are currently using.
There is some evidence that ports which are excluded are powered down (I remembered seeing in the disasm).
 
Joined
Oct 14, 2013
Messages
3
Motherboard
Acer Aspire v5 571p-6698
CPU
2nd Gen Intel Core i3 1.5 Ghz
Graphics
Intel HD4000
Mac
Classic Mac
Mobile Phone
Copy the kexts in /EFI/CLOVER/kexts to /System/Library/Extensions.
Already done, but then the Brcm* Kexts are excluded from kernel cache. I get an error "no compatible dependency found" and omits them.
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Sorry about that, swamped with work and school currently, will post as soon as I have the chance.
 
Joined
Oct 14, 2013
Messages
3
Motherboard
Acer Aspire v5 571p-6698
CPU
2nd Gen Intel Core i3 1.5 Ghz
Graphics
Intel HD4000
Mac
Classic Mac
Mobile Phone
Nevermind, got BT working. I must have had an old copy of the zip as I found out the issue was mismatching versions of BrcmPatchRAM2 and BrcmFirmwareData.
 
Joined
Mar 15, 2016
Messages
5
Mac
Classic Mac
Mobile Phone
For your installation did you use Multibeast? You didn't say at all.
 
Joined
Nov 13, 2016
Messages
12
Motherboard
Dell Inspiron 5378 (Clover)
CPU
i7 7500 / P380W
Graphics
Intel HD Graphics 620, 1920x1080
Mac
MacBook Pro
Just one question, how long does the battery last ?
Mine manages just over 2h
 
Last edited:
Top