Contribute
Register

[Guide] Dell Inspiron 13 5378 (2-in-1) - MacOS 10.12.6

Joined
Nov 13, 2016
Messages
12
Motherboard
Dell Inspiron 5378 (Clover)
CPU
i7 7500 / P380W
Graphics
Intel HD Graphics 620, 1920x1080
Mac
MacBook Pro
Thank you for this excellent guide !
Everything worked ! ..except there's no bluetooth.
Think that may be a problem with the 1560 card I got from aliexpress.
Waiting for a replacement.
 
Joined
May 3, 2016
Messages
12
Motherboard
13-5378 (Clover)
CPU
Intel(R) Core(TM) i7-7500U CPU @ 2.90GHz
Graphics
Intel(R) HD Graphics 620
Hey I am trying to complete the step for editing EFI Patches using EFI_Shell

but I cannot figure out how to get to the EFI_Shell to apply the patches. Is this A file I download from somewhere?

Sorry if this is a rookie question
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,090
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Aug 22, 2015
Messages
135
Motherboard
Dell Inspiron 5378
CPU
Intel(R) Core(TM) i7-7500U CPU @ 2.90GHz
Graphics
Intel(R) HD Graphics 620
Mac
MacBook Air
Mobile Phone
Android
Hey I am trying to complete the step for editing EFI Patches using EFI_Shell

but I cannot figure out how to get to the EFI_Shell to apply the patches. Is this A file I download from somewhere?

Sorry if this is a rookie question
Look in the original post and download the zip bundle. You will find EFI_Shell in there.
 
Joined
Nov 13, 2016
Messages
12
Motherboard
Dell Inspiron 5378 (Clover)
CPU
i7 7500 / P380W
Graphics
Intel HD Graphics 620, 1920x1080
Mac
MacBook Pro

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,090
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Got it working.
Moved BrcmPatchRam2 and BrcmFirmwareRepo to /L/E from the EFI/Clover folder and
bluetooth was detected.
Yes... as per BrcmPatchRAM README, BrcmFirmwareRepo does not work from EFI/Clover/kexts.
 
Joined
Oct 14, 2013
Messages
3
Motherboard
Acer Aspire v5 571p-6698
CPU
2nd Gen Intel Core i3 1.5 Ghz
Graphics
Intel HD4000
Mac
Classic Mac
Mobile Phone
Thank you so much for this!!! EVERYTHING is working - WiFi, touch screen imessage, facetime, QE/CI, CPUPM - only thing I can't put my finger on is why DW1560 bluetooth isn't working? I have all the kexts from posts 8 and 9, yet no bluetooth in System Preferences, in the top bar, or in System Report - it says "No Bluetooth Hardware found" - anyone got any ideas??
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,090
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thank you so much for this!!! EVERYTHING is working - WiFi, touch screen imessage, facetime, QE/CI, CPUPM - only thing I can't put my finger on is why DW1560 bluetooth isn't working? I have all the kexts from posts 8 and 9, yet no bluetooth in System Preferences, in the top bar, or in System Report - it says "No Bluetooth Hardware found" - anyone got any ideas??
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Aug 22, 2015
Messages
135
Motherboard
Dell Inspiron 5378
CPU
Intel(R) Core(TM) i7-7500U CPU @ 2.90GHz
Graphics
Intel(R) HD Graphics 620
Mac
MacBook Air
Mobile Phone
Android
Thank you so much for this!!! EVERYTHING is working - WiFi, touch screen imessage, facetime, QE/CI, CPUPM - only thing I can't put my finger on is why DW1560 bluetooth isn't working? I have all the kexts from posts 8 and 9, yet no bluetooth in System Preferences, in the top bar, or in System Report - it says "No Bluetooth Hardware found" - anyone got any ideas??
Copy the kexts in /EFI/CLOVER/kexts to /System/Library/Extensions.
 
Joined
May 3, 2016
Messages
12
Motherboard
13-5378 (Clover)
CPU
Intel(R) Core(TM) i7-7500U CPU @ 2.90GHz
Graphics
Intel(R) HD Graphics 620
Look in the original post and download the zip bundle. You will find EFI_Shell in there.
AH, ok I found it finally. However, when I wipe my USB to FAT32 and copy over the Shell_EFI folder into a folder named EFI it is still not bootable. Am i doing something wrong here?

I also tried copying it onto the install media usb and it is also not recognized

Again, Sorry for the nooby questions
 
Top