[Guide] Darkthing#2 - DELL Latitude E6320 - i7 2640M 2.8 GHz

Not open for further replies.
Jul 11, 2012
Gigabyte GA Z68XP-UD3
i7 3770
GT 210
  1. iMac
  2. Mac mini
Mobile Phone
  1. Android
Ok, this is not the state-of-the-art build, but as there isn't any guide here for this laptop, I think it's a good idea to publicize mine. ;)

Starting point
A friend of mine gave me this laptop and I thought it would be a nice SOS machine in case Darkthing#1 would let me down...
• Here are its specs:
i7 2640M 2.8 GHz (Sandy Bridge)
Chipset : Mobile Intel QM67 Express
8 GB RAM • 320 GB Drive
Intel® HD Graphics 3000 • 13,3" display
=> equivalent to a MacBookPro8,1 from 2011
• before attempting hackintoshing a DELL laptop, be sure that it is correctly charging: there's a very common issue with some DELL laptops where the battery is not charging at all because of an insufficient stock adapter! (that's actually why my friend gave me this machine... :mrgreen:) You should be ok buying a 90W charger like I did.
EDIT: after a few months, the battery appears to be dead, though indicating 95% load... so the charger issue might be the first sign of a failing battery, instead.

What's not working
• Wifi: As I don't need Wifi at the moment, I plan to install a dual-boot Windows 7 solution in the future and use internet from there if I ever need it.
If you want it, you'll have to install another card as explained in those threads:
Note that the author of the guide I took inspiration from (yes, there is one ;)) uses a TP-LINK TL-WN725N USB adaptor, that is incredibly cheap whilst it's not the speediest solution...
• I've never used iMessage in my life, so I'm unable to say if it's working or not.

Initially A08, I've read people saying not to update it past A13, so I made all my trials without updating the BIOS and then updated it to A21 (the latest), quite convinced it wouldn't work but it did! Note that I can't see any improvement/loss from the original BIOS...
Basic BIOS settings are:
- "Load Defaults"
- General - Boot Sequence: choose USB Device if you're making your trials with an external drive first (recommended!)
Note that there's an option for UEFI but it won't work: theoretically, you should select a file in Clover on the EFI partition (/EFI/BOOTX64.efi) but the BIOS crashes before you have a chance to select it! So stick to Legacy!
- System Configuration - SATA Operation: AHCI

My procedure
I've been trying Mac OS 10.11 with clover on my Z68 build (Darkthing#1) for a few years now (but sticking to 10.9 as my main OS because of some incompatible software), so I had this external drive ready for trials and I started tweaking Clover to make it work with the laptop... I'll spare you the details of my many trials and the basic procedure, as it is more or less the same for any hackintosh (format to GUID, etc.), I assume you have an installed El Capitan working partition on an external drive.

• install the latest Standalone tonymacx86 Clover Build: (currently v2.4k_r4428)
• put/replace EFI/CLOVER/ACPI/patched/DSDT.aml and EFI/CLOVER/config.plist with the ones from the attached zip
• install the following kexts in EFI/CLOVER/kexts/10.11:
- ACPIBacklight.kext 3.0.4, ACPIBatteryManager.kext 1.81.4, IntelMausiEthernet.kext 2.4.0d0, VoodooHDA.kext 2.9.1 and FakeSMC 6.26-344 from RehabMan's repository: (the latest at the time of this writing)
• VoodooPS2Controller.kext (used for the keyboard and trackpad): I was totally unable to have RehabMan's version working, even following RehabMan's procedure, even with old versions, so I had to use a modified version (see attached zip).
N.B.: there are a lot of modified versions around, some aiming to use the integrated MacOS Preference Pane (but most of the Multitouch features don't work...) others more basic. I first used the one I found in the file from the guide I mention in the Conclusion (seems like a modified 1.8.8 version...) then I found another version that acts the same and is lighter, I've modified just a setting to enable edge scrolling.
EDIT: I once had the trackpad paralyzed after using the laptop to control my other Mac through Screen Sharing, nothing in the Console... So I reverted to the other version — it might also be because of a connection loss or because I should have put it in S/L/E, this should need further inquiry but I rarely use this laptop, so it's up to you... I've also found that the 1.8.8 version was 1 MB because of some useless development folders inside it, that I deleted safely in the attached zip.
• when all is in place, you can use Kext Utility to clean up things then reboot in Safe Mode and reboot again normally... Everything should be ok!
• once you've checked that everything is ok, you can clone your external drive to the internal one (I did it the punk way with Carbon Copy Cloner from my main admin account, not even from Root user as I usually do...) and give it a shot of Standalone tonymacx86 Clover Build.

Power button
Note that the "Restart, Sleep, Shut Down" menu will appear with Ctrl+Power button, not the Power button alone.
EDIT: this is due to the OS version, I've discovered that 10.6 works with the Power button alone. ;)

I generated a custom SSDT, following Toleda's procedure:
The results are not spectacular (actually a slightly lower Geekbench score...) but there's a visible increase in Cinebench : 5.99 fps instead of 5.29 fps without SSDT.

• The guide from which I took the DSDT.aml and config.plist files (EDIT: and the first VoodooPS2Controller.kext too) in the attached zip made already quite everything working very easily with minimal issues: It provides a preset Clover folder that I've upgraded to eliminate some issues or useless kexts and in the end I achieved a fully functioning system.
I've edited config.plist: cancelled a useless key (kext-dev-mode=1 that was only needed for OS 10.10) and added the RtVariables to disable SIP: BooterConfig=0x28 and CsrActiveConfig=0x67. There probably remains useless settings, as it's a config.plist that probably came from OS 10.10 (at least)...
Don't forget to specify your Default Boot Volume in config.plist if you want the Timeout setting to work...
• Having it working, I then tried to achieve the same result from a basic Clover and ended up with the procedure above. I wish I could make my own DSDT.aml and config.plist, etc. but it's way too complicated for me, nobody's perfect. :oops:

If you happen to get such a laptop, it's super-easy to have it working with the provided files (you just have to chose which VoodooPS2Controller.kext to use).
Here's where you have to put them:


EDIT 08/2020
• As I suspected, some of the settings in that config.plist are useless (all the KextsToPatch, for example), I won't specify which as they are harmless anyway — I have tested disabling the KextsToPatch and everything looks fine in 10.6, 10.9 and 10.11.
• Instead, there's one KextsToPatch that's needed for 10.11, it's the "Boot graphics glitch, 10.10.x/10.11.x (credit lisai9093, cecekpawon)" featured as such in Clover Configurator — that fixes indeed a glitch of the login screen.
• The DSDT.aml is mandatory for USB, all the rest seems to work without it.
• I've switched from VoodooHDA to Lilu (1.4.5)+AppleALC (1.5.0) as I couldn't make it work in 10.9, the audio level is a bit higher and the mute button doesn't work any more, but I don't need it...
As this is mainly my backup machine, it has been working perfectly for that purpose: first partition is a clone of my Desktop 10.11, got a 10.6 partition used exclusively for WiFi (with a DELL Mini 9 card and the appropriate driver!) and a 10.9 partition for Pro Tools (cloned also from my Desktop Z68).

EDIT 02/2021
More changes to config.plist to make this machine a perfect clone of my Desktop Z68 build!
• Adding the SSDT proved many settings being useless (mainly on the ACPI page), so I've simplified many things.
• Keeping SMBIOS MacBookPro8,1 but setting the SN, SmUUID and Custom UUID from the Desktop build works ok ; I set /Rt Variables/ROM to UseMacAddr0 as recommended.
N.B. : in some occasions, I've seen the need to set also the Board Serial Number (MLB) — booting a clone of my Desktop Z68 build through USB.
• I moved all kexts specific to the E6320 in EFI/kexts/10.x (I already did so for the 10.6 and 10.9 partitions) ; setting System Params/Inject Kexts to Yes is now mandatory
I can now directly backup my whole 10.11 partition from Darkthing#1 so it's ready to use in case of failure. :headbang:

EDIT 05/2021
• Currently trying OpenCore, I found that the new 1.0.6 version of IntelMausi is working (
• ACPIBacklight.kext can be replaced for the best by AppleBacklightFixup.kext + Lilu + SSDT-PNLF.aml (
N.B. : Hackintool tells me that WhateverGreen replaced AppleBacklightFixup but it doesn't work here (the backlight level is not saved across reboots and has to be set every time)


  • E6320
    230 KB · Views: 385
Last edited:
Not open for further replies.