Contribute
Register

[Guide] Creating a Custom SSDT for USBInjectAll.kext

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,477
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thanks for the reply.

The key is as you say NOT to search but to open the explore to the AppleACPIPCI tree node and watch the ports change color as one inserts and removes devices.

Yes... the guide in post #1 never instructs you to use search!

But my explorer window shows these controllers and ports on each controller:

Only EH01/EH02/XHC are USB controllers.

Since no controller has MORE than 15 ports, then is it correct to say that this MB does not need any special SSDT to limit any port on all the controllers?

Impossible to know with the information you provided.
Read post #1, "Problem Reporting".
It sounds like you didn't go through the "port discovery" process.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,477
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
i am trying to follow this guide but i do not know what to do if my USB device is listed as this:
RP05@1C,4 instead of XHC@14.

other ports are under the XHC@14 but some are on this strange one.
using Z270 chipset
full

This guide covers only Intel xHCI/EHCI.
You're looking at a third-party USB controller or Thunderbolt controller.
 
Joined
Jan 23, 2011
Messages
885
Motherboard
Gigabyte Z370
CPU
i5 9400F
Graphics
RX 470
Mac
  1. Mac Pro
its a ASmedia chipset. so shall i just ignore these ports? the thing is these ports seem to work perfect while the others dont :)
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,477
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
its a ASmedia chipset. so shall i just ignore these ports?

Yes, of course.

the thing is these ports seem to work perfect while the others dont :)

General rule: Don't fix something that is not broken.

Read post #1 for configuring the Intel ports.
 
Joined
Sep 1, 2016
Messages
442
Motherboard
Gigabyte Z490 I Aorus Ultra
CPU
i9-10900K
Graphics
RX 580
I'm working my way through this guide. I've successfully identified all ports, the last one... which I think Gigabyte refers to as "USB 3.1" is showing up under pic-bridge@2 on different ports. How should I handle them? Z170N Gaming 5.

Screen Shot 2017-10-06 at 2.57.58 PM.png
Screen Shot 2017-10-06 at 2.58.38 PM.png
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,477
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I'm working my way through this guide. I've successfully identified all ports, the last one... which I think Gigabyte refers to as "USB 3.1" is showing up under pic-bridge@2 on different ports. How should I handle them? Z170N Gaming 5.

View attachment 283667View attachment 283668

You are looking at a Thunderbolt controller.
It is not covered by this guide as it usually works fine without doing any injections.
 
Joined
Sep 1, 2016
Messages
442
Motherboard
Gigabyte Z490 I Aorus Ultra
CPU
i9-10900K
Graphics
RX 580
You are looking at a Thunderbolt controller.
It is not covered by this guide as it usually works fine without doing any injections.

Okay. Thank you. I'll leave it alone, then, and concentrate on the others.
 
Joined
Sep 1, 2016
Messages
442
Motherboard
Gigabyte Z490 I Aorus Ultra
CPU
i9-10900K
Graphics
RX 580
Ok... so close. I successfully identified all the ports and thought I had the SSDT ready to go, but when I rebooted... no Bluetooth (which is on HS13). I tried both 255 and 2 as the USB Connector. In both cases, on reboot, HS13 showed nothing connected. The screen grab is before the SSDT, the attached files are the dsl I used to create the aml that I put in Clover/ACPI/patched.
Screen Shot 2017-10-06 at 4.33.17 PM.png
 

Attachments

  • SSDT-UIAC-Bill(dsl)-Z170N.zip
    1.5 KB · Views: 49
  • SSDT-UIAC-Bill-Z170N.zip
    1,003 bytes · Views: 43

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,477
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Ok... so close. I successfully identified all the ports and thought I had the SSDT ready to go, but when I rebooted... no Bluetooth (which is on HS13). I tried both 255 and 2 as the USB Connector. In both cases, on reboot, HS13 showed nothing connected. The screen grab is before the SSDT, the attached files are the dsl I used to create the aml that I put in Clover/ACPI/patched.View attachment 283697

Read post #1, "Problem Reporting".
 
Top