Contribute
Register

[Guide] Creating a Custom SSDT for USBInjectAll.kext

Joined
Jul 6, 2014
Messages
137
Motherboard
HP 250 G5 - X0N65EA
CPU
i7-6500u
Graphics
HD520
Set HS04/UsbConnector=255 as per guide.
Eliminate ports that are not needed.
Read post #1.

Don't forget to patch ACPI ("OS Check Fix" or _OSI->XOSI+SSDT-XOSI.aml) as mentioned in the main USB guide (linked from post #1).
After I used _OSI->XOSI+SSDT-XOSI.aml I was able to see bluetooth working in OS X.
Then I created the custom SSDT-UIAC-ALL.aml.
Just a question: Laptop has a card reader and surprisingly I noticed that it works like a charm because when I insert an SD cart it appears under HS07. So I wanted to know if this kind of connection should be considered as 255 or 0. Thanks for help again.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,101
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
After I used _OSI->XOSI+SSDT-XOSI.aml I was able to see bluetooth working in OS X.
Then I created the custom SSDT-UIAC-ALL.aml.
Just a question: Laptop has a card reader and surprisingly I noticed that it works like a charm because when I insert an SD cart it appears under HS07. So I wanted to know if this kind of connection should be considered as 255 or 0. Thanks for help again.

As per post #1, ports connected to internal devices should be marked UsbConnector=255.

Note: If an internal device does not appear until you activate it (a little hard to tell from your description), then it is considered external.
 
Joined
Jul 6, 2014
Messages
137
Motherboard
HP 250 G5 - X0N65EA
CPU
i7-6500u
Graphics
HD520
As per post #1, ports connected to internal devices should be marked UsbConnector=255.

Note: If an internal device does not appear until you activate it (a little hard to tell from your description), then it is considered external.
The HS07 appears connected only when I insert SD card into card reader......just like when I insert an USB stick and appears under HS01 or HS02 or HS03....so I suppose, staying at your description, that the correct number is 0.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,101
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
The HS07 appears connected only when I insert SD card into card reader......just like when I insert an USB stick and appears under HS01 or HS02 or HS03....so I suppose, staying at your description, that the correct number is 0.

Correct.

Since it is coming and going...
It is considered external (internal devices are always connected).
UsbConnector=0 for USB2 only "external" ports.
 
Joined
Feb 28, 2016
Messages
55
Motherboard
Asus ROG G501JW
CPU
Core i7 4720HQ
Graphics
Intel HD 4600 & GeForce GTX960M
Mac
  1. MacBook Air
Hi, rehabman, when I tried to check which ports are used in IOReg, all of my XHC, EH01, and EH02 remains empty even when I plug and unplug my usb devices. But, the usb itself works as it supposed to be.

Do you know the cause of this problem?
 

Attachments

  • Archive.zip
    2.3 MB · Views: 55

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,101
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi, rehabman, when I tried to check which ports are used in IOReg, all of my XHC, EH01, and EH02 remains empty even when I plug and unplug my usb devices. But, the usb itself works as it supposed to be.

Do you know the cause of this problem?

According to the ioreg you attached, there appears to be plenty of devices on EH01/EH02.
You will only get something on XHC if you use a USB3 device (because you're using FakePCID_XHCIMux).
 
Joined
Feb 28, 2016
Messages
55
Motherboard
Asus ROG G501JW
CPU
Core i7 4720HQ
Graphics
Intel HD 4600 & GeForce GTX960M
Mac
  1. MacBook Air
According to the ioreg you attached, there appears to be plenty of devices on EH01/EH02.
You will only get something on XHC if you use a USB3 device (because you're using FakePCID_XHCIMux).

I already used a USB3 device, still nothing appeared on the XHC tree. haha
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,101
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I already used a USB3 device, still nothing appeared on the XHC tree. haha

You're probably not using IORegistryExplorer correctly.
Show image.
If the device is working it will show under XHC, EH01 or EH02 somewhere.
 
Joined
Feb 28, 2016
Messages
55
Motherboard
Asus ROG G501JW
CPU
Core i7 4720HQ
Graphics
Intel HD 4600 & GeForce GTX960M
Mac
  1. MacBook Air
You're probably not using IORegistryExplorer correctly.
Show image.
If the device is working it will show under XHC, EH01 or EH02 somewhere.

EDIT: my bad, it seems that I'm not using the IOReg correctly lol
 
Last edited:
Joined
Feb 28, 2016
Messages
55
Motherboard
Asus ROG G501JW
CPU
Core i7 4720HQ
Graphics
Intel HD 4600 & GeForce GTX960M
Mac
  1. MacBook Air
Rehabman, when converting from .dsl to .aml, did you use MaciASL? Because when I tried to save as .aml, the MaciASL always not responding. Do you have alternative way to convert from .dsl to .aml?
 
Top