Contribute
Register

[Guide] Creating a Custom SSDT for USBInjectAll.kext

Joined
Nov 11, 2013
Messages
44
Motherboard
HP ENVY m4-1015dx / Hewlett-Packard 18EE
CPU
Intel Core i7-3632QM
Graphics
HD4000 1366x768
Mac
iMac
Mobile Phone
Android, iOS,
You will probably be disappointed with the reliability of the Renasas for front ports (as you're likely to use them more).
You should probably consider connecting those front ports to an Intel header, or install a supported FL1100 based card that has an internal header for those front ports.
Ok, I'm going to look into getting the FL1100 bases card. Thanks!

Depends on what you're asking the question in regards to.
Regarding the installation of GenericUSBXHCI.kext for the Renasas controller.
 
Joined
Jul 17, 2014
Messages
2
Mac
Classic Mac
Mobile Phone
Hey RehabMan,

I'm having trouble detecting USB3 devices on my XHCI ports. The behaviour is the same as mentioned earlier in this thread:

USB3 devices get powered but cannot be detected in ioreg on the USB3 ports, only on the USB2 connectors.
USB2 devices work fine on USB2 and USB3 connectors.

So i cannot even get to the point to test my ports with USB3 devices.

It seems a little off that in the ioreg, you can see HS01-HS14 and only SSP1.
I tried to apply the XOSI-patch and the portlimit patch, but am not even shure if they are working.
EHC renaming works.
the -uia_exclude_hs kernelflag doesn't seem to work when applied in the clover configurator..

I'm on a Gigabyte GA-Z87X-D3H.

Attached are the details,
thanks a lot
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,090
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hey RehabMan,

I'm having trouble detecting USB3 devices on my XHCI ports. The behaviour is the same as mentioned earlier in this thread:

USB3 devices get powered but cannot be detected in ioreg on the USB3 ports, only on the USB2 connectors.
USB2 devices work fine on USB2 and USB3 connectors.

So i cannot even get to the point to test my ports with USB3 devices.

It seems a little off that in the ioreg, you can see HS01-HS14 and only SSP1.
I tried to apply the XOSI-patch and the portlimit patch, but am not even shure if they are working.
EHC renaming works.
the -uia_exclude_hs kernelflag doesn't seem to work when applied in the clover configurator..

I'm on a Gigabyte GA-Z87X-D3H.

Attached are the details,
thanks a lot
The port limit patch you have in your config.plist is for 10.11.x.
You're running 10.12.2.
For 10.12.x, you need a different port limit patch.
Read carefully.
 
Joined
Jul 17, 2014
Messages
2
Mac
Classic Mac
Mobile Phone
Wow that was fast, thanks.
This indeed did help, I'm seeing HS01-HS14 as well as SSP1-SSP6 now.
I guess I messed it up because I had trouble converting the Base64 value to Hex in clover-configurator and later accidentally copied the El Capitan Data in Xcode.

Just for the Sierra-people in this thread, learn from my mistake:

Please do NOT use the data-value for the Find/Replace Key in the OP for Sierra!
Use this instead:
https://www.tonymacx86.com/threads/usb-new-raise-port-limit-patch-for-macos-10-12-sierra.202329/

I guess you don't need to worry when you just include the config_patches.plist from the USBInjectAll-repo in your config.plist
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,090
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Wow that was fast, thanks.
This indeed did help, I'm seeing HS01-HS14 as well as SSP1-SSP6 now.
I guess I messed it up because I had trouble converting the Base64 value to Hex in clover-configurator and later accidentally copied the El Capitan Data in Xcode.

Just for the Sierra-people in this thread, learn from my mistake:

Please do NOT use the data-value for the Find/Replace Key in the OP for Sierra!
Use this instead:
https://www.tonymacx86.com/threads/usb-new-raise-port-limit-patch-for-macos-10-12-sierra.202329/

I guess you don't need to worry when you just include the config_patches.plist from the USBInjectAll-repo in your config.plist
Post #1 shows both 10.11 and 10.12 patches. You just didn't pay attention to what you were doing...

And yes... you should just use copy/paste... there is no sense in typing the data manually.
 
Last edited:
Joined
Nov 11, 2013
Messages
44
Motherboard
HP ENVY m4-1015dx / Hewlett-Packard 18EE
CPU
Intel Core i7-3632QM
Graphics
HD4000 1366x768
Mac
iMac
Mobile Phone
Android, iOS,
Just install the kext.
Before installing GenericUSBXHCI.kext, System Reports showed 2 usb3 controllers. It also showed the Intel one with devices plugged in. With GenericUSBXHCI.kext installed, every USB ports worked, including the Renasas ports, but System Reports only show the Intel controller with nothong plugged in, even when all USB3 ports have devices plugged in. I attached the screenshot below. Is it normal or should I remove the GenericUSBXHCI.kext and ignore the Renasas ports?
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,090
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Before installing GenericUSBXHCI.kext, System Reports showed 2 usb3 controllers. It also showed the Intel one with devices plugged in. With GenericUSBXHCI.kext installed, every USB ports worked, including the Renasas ports, but System Reports only show the Intel controller with nothong plugged in, even when all USB3 ports have devices plugged in. I attached the screenshot below. Is it normal or should I remove the GenericUSBXHCI.kext and ignore the Renasas ports?
Read guide, post #1, "Problem Reporting".
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,090
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Attched zip file as required in guide. Thanks, RehabMan!
Your ssdt-usb.aml is doing what you told it to do (not possible for me to verify correctness as only you can test your ports properly).

Assuming you have only two USB3 ports attached to the Intel XHCI controller, it is possible the setup is correct. You're using FakePCIID_XHCIMux to route USB2 pins connected to XHCI to the EHCI controller, so you should expect USB2 devices to show up on one of the two USB2 buses (corresponding to EH01/EH02).
 
Top