Contribute
Register

[Guide] Booting the OS X installer on LAPTOPS with Clover

Joined
Dec 3, 2014
Messages
72
Motherboard
Hp DV6 7040tx
CPU
Intel core i7 3610QM
Graphics
Intel HD 4000 + Nvidia 630M 2GB
Mac
Classic Mac
Mobile Phone
[GUIDE] Booting the OS X installer on LAPTOPS with Clover UEFI

Provide output from 'lspci -nn' in Linux Terminal here.
This is the O/P I got: :crazy:
HTML:
00:00.0 Host bridge [0600]: Intel Corporation 3rd Gen Core processor DRAM Controller [8086:0154] (rev 09)
00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port [8086:0151] (rev 09)
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04)
00:16.0 Communication controller [0780]: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 [8086:1e3a] (rev 04)
00:1a.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 [8086:1e2d] (rev 04)
00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
00:1c.0 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 [8086:1e10] (rev c4)
00:1c.2 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 [8086:1e14] (rev c4)
00:1c.3 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 [8086:1e16] (rev c4)
00:1c.5 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 6 [8086:1e1a] (rev c4)
00:1d.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 [8086:1e26] (rev 04)
00:1f.0 ISA bridge [0601]: Intel Corporation HM77 Express Chipset LPC Controller [8086:1e57] (rev 04)
00:1f.2 RAID bus controller [0104]: Intel Corporation 82801 Mobile SATA Controller [RAID mode] [8086:282a] (rev 04)
00:1f.3 SMBus [0c05]: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller [8086:1e22] (rev 04)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 630M] [10de:0de9] (rev a1)
08:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader [10ec:5229] (rev 01)
0a:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
0b:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 07)
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,717
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
[GUIDE] Booting the OS X installer on LAPTOPS with Clover UEFI

This is the O/P I got: :crazy:
Code:
00:1f.2 RAID bus controller [0104]: Intel Corporation 82801 Mobile SATA Controller [RAID mode] [8086:282a] (rev 04)
SATA is in RAID mode. Device id 8086:282a matches the ID in HPRAIDInjector.kext. Copy it to Clover/kexts/Other and it will work. You must have done something wrong when you tried it before.
 
Joined
Dec 3, 2014
Messages
72
Motherboard
Hp DV6 7040tx
CPU
Intel core i7 3610QM
Graphics
Intel HD 4000 + Nvidia 630M 2GB
Mac
Classic Mac
Mobile Phone
[GUIDE] Booting the OS X installer on LAPTOPS with Clover UEFI

SATA is in RAID mode. Device id 8086:282a matches the ID in HPRAIDInjector.kext. Copy it to Clover/kexts/Other and it will work. You must have done something wrong when you tried it before.
I have attached the EFI folder. Can you check what I have done wrong?

Update1: IT showed my HDD. Thank you. I'll post back the results
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,717
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
[GUIDE] Booting the OS X installer on LAPTOPS with Clover UEFI

I have attached the EFI folder. Can you check what I have done wrong?
Looks ok to me. Make sure you boot without caches, since you may have created an invalid kernel cache after booting previously without HPRAIDInjector.kext.
 
Joined
Dec 3, 2014
Messages
72
Motherboard
Hp DV6 7040tx
CPU
Intel core i7 3610QM
Graphics
Intel HD 4000 + Nvidia 630M 2GB
Mac
Classic Mac
Mobile Phone
[GUIDE] Booting the OS X installer on LAPTOPS with Clover UEFI

Looks ok to me. Make sure you boot without caches, since you may have created an invalid kernel cache after booting previously without HPRAIDInjector.kext.
Hoohooooo! I installed MAC OSX Yosemite. :headbang::D Thank you so much, rehabman!

But, little issues I'm facing here. I was just googling out solutions for my "Ethernet, WiFi, Bluetooth, GPU". I came across one of the threads: http://www.tonymacx86.com/mountain-lion-laptop-support/109626-hp-pavilion-dv6-no-wifi.html

My WiFi card is: 0a:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)

My Ethernet is: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 07)

It seems like my WiFi card is not supported! But your post was made last year. Hopefully, is there any new ways designed to sort out that issue?

Also, I came across a driver for LAN: http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/
Will this work for me? Or will it mess my System?

Thank you again!
Sille Bille
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,717
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
[GUIDE] Booting the OS X installer on LAPTOPS with Clover UEFI

Hoohooooo! I installed MAC OSX Yosemite. :headbang::D Thank you so much, rehabman!

But, little issues I'm facing here. I was just googling out solutions for my "Ethernet, WiFi, Bluetooth, GPU". I came across one of the threads: http://www.tonymacx86.com/mountain-lion-laptop-support/109626-hp-pavilion-dv6-no-wifi.html

My WiFi card is: 0a:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)

My Ethernet is: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 07)

It seems like my WiFi card is not supported! But your post was made last year. Hopefully, is there any new ways designed to sort out that issue?

Also, I came across a driver for LAN: http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/
Will this work for me? Or will it mess my System?

Thank you again!
Sille Bille
BCM4313 is not supported. You need to replace it.

RTL8111: http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/
 
D

Deleted member 980631

Guest
[GUIDE] Booting the OS X installer on LAPTOPS with Clover UEFI

Hi RehabMan,
I followed instructions,
I used config_HD4600.plist as config, I renamed it.
Used
createinstallmedia method.
Disabled virtualization and selected USB as a boot device.
But nothing happened, since my pc started booting from HDD, so I supposed it cannot find bootable partition in USB.
So what to do in this case?

P.S. I didn't understand the part with
ig-platform-id, where this file is located? Maybe my problem is because of this.

Thank you!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,717
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
[GUIDE] Booting the OS X installer on LAPTOPS with Clover UEFI

Hi RehabMan,
I followed instructions,
I used config_HD4600.plist as config, I renamed it.
It must be config.plist at /EFI/Clover/config.plist.

Used createinstallmedia method.
Disabled virtualization and selected USB as a boot device.
But nothing happened, since my pc started booting from HDD, so I supposed it cannot find bootable partition in USB.
So what to do in this case?
You need to use your BIOS hotkey to access the boot selection menu (not the same as BIOS settings). Refer to your user manual.

P.S. I didn't understand the part with ig-platform-id, where this file is located? Maybe my problem is because of this.
It is not a file, it is a setting in config.plist.
 
Joined
Dec 3, 2014
Messages
72
Motherboard
Hp DV6 7040tx
CPU
Intel core i7 3610QM
Graphics
Intel HD 4000 + Nvidia 630M 2GB
Mac
Classic Mac
Mobile Phone

Attachments

Joined
Nov 17, 2014
Messages
15
Motherboard
Sony Vaio E Series, SVE151D11L
CPU
Intel Core i5-2450M 2.50GHz
Graphics
Intel HD Graphics3000, 1366x768
Mac
Classic Mac
Mobile Phone
[GUIDE] Booting the OS X installer on LAPTOPS with Clover UEFI

This time I am trying to install Yosemite with Clover and formatted the USB drive with MBR partition. I followed all installation guide, however when I reboot my computer it seems that USB is not bootable. I tried with Unibeast, USB is bootable but clover option is not available!
Any idea why this happen?
 
Top