Contribute
Register

[Guide] Booting the OS X installer on LAPTOPS with Clover

Feartech

Moderator
Joined
Aug 3, 2013
Messages
27,624
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
and this?
HFSPlus.efi ?
in driver uefi and not in driver64uefi?
yes, make sure all your .efi files are in :
drivers/UEFI folder
 
Joined
Apr 17, 2020
Messages
27
Motherboard
HP Envy 17
CPU
i7-2630QM/ HM67
Graphics
HD 3000 + HD 6800M, 1920x1080
Mobile Phone
  1. Android
I think I discovered one thing ... my bios is legacy and not uefi ....
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
27,624
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I think I discovered one thing ... my bios is legacy and not uefi ....
try adding those files in drivers/BIOS folder

have not done a legacy install before, you may need to research that
 
Joined
Apr 17, 2020
Messages
27
Motherboard
HP Envy 17
CPU
i7-2630QM/ HM67
Graphics
HD 3000 + HD 6800M, 1920x1080
Mobile Phone
  1. Android
I must to research what? i don't undestand....
 
Joined
Apr 17, 2020
Messages
27
Motherboard
HP Envy 17
CPU
i7-2630QM/ HM67
Graphics
HD 3000 + HD 6800M, 1920x1080
Mobile Phone
  1. Android
This method is not available in ML, Lion, SL.

Using 'createinstallmedia' is the only method that results in the creation of a Recovery partition.


BaseBinaries clone method

Note: BaseBinaries clone method does not work with High Sierra or Mojave.


what does it mean? I am trying to install the operating system on the install osx partition, but I am not succeeding.
I'm doing this usb stick with a hackintosh with os x montain lion installed
Can I use the first method or should I use the second method?
I would like to install high sierra.
I tried using the first method but after the first command it asks me for a password. What password should I give?
thank you!
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
27,624
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
This method is not available in ML, Lion, SL.

Using 'createinstallmedia' is the only method that results in the creation of a Recovery partition.


BaseBinaries clone method

Note: BaseBinaries clone method does not work with High Sierra or Mojave.


what does it mean? I am trying to install the operating system on the install osx partition, but I am not succeeding.
I'm doing this usb stick with a hackintosh with os x montain lion installed
Can I use the first method or should I use the second method?
I would like to install high sierra.
I tried using the first method but after the first command it asks me for a password. What password should I give?
thank you!
the password is the admin password on the machine you are using

download High Sierra from appstore if available or click this:
 
Joined
Apr 17, 2020
Messages
27
Motherboard
HP Envy 17
CPU
i7-2630QM/ HM67
Graphics
HD 3000 + HD 6800M, 1920x1080
Mobile Phone
  1. Android
okey.. but I'm working on mountain lion.. I can use the first method "createinstallmedia"?
 
Joined
Apr 17, 2020
Messages
27
Motherboard
HP Envy 17
CPU
i7-2630QM/ HM67
Graphics
HD 3000 + HD 6800M, 1920x1080
Mobile Phone
  1. Android
when I start the installation it does not ask me where to install high sierra. practically point 3 does not work
 
Joined
May 12, 2019
Messages
1
Motherboard
LAPTOP ASUS G55VW-S1183H
CPU
Intel® Core™ i7 3630QM 2.40 GHz ~ 3.40 GHz
Graphics
Intel® HD 4000 + GeForce® GTX 660M
Mobile Phone
  1. Android
Hello,

Since two weeks i try install high Sierra on my ASUS ROG G55VW.

CPU: Intel® Core™ i7 3630QM 2.40 GHz ~ 3.40 GHz
Chipset: Intel® HM77
Memory: DDR3 1600 MHz SDRAM, 6144 Mo
GPU: NVIDIA 660M

I follow this GUIDE of course.

To installing Clover to USB I chose MBR

I used the Cover RehabMan build and installed it without any problems.
I installed minimal kextes.
I use the config_HD3000_1600x900.plist from OS-X-Clover-Laptop-Config and i modified the Common ig-platform-ids:0x01660004.
I boot on clover, and if i dont choose to boot on OSX Installer with Safe Mode (-x), i have this issue:

IMG_20200422_165537.jpg


Is it normal?

When i check Safe Mode option, the process seems to me better

IMG_20200422_183958.jpg


But my PC reboot after à lot of verbose but to quick to take a picture.

Do you have an idea?

Thank for this incredeble great site.
 

Attachments

  • CLOVER.zip
    4 MB · Views: 49
Last edited:
Top